aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-PEAR/Makefile
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>2002-11-17 05:03:54 +0000
committerSADA Kenji <sada@FreeBSD.org>2002-11-17 05:03:54 +0000
commit050dd1b1031022b49cd1623dd3892f3c4be3a1ae (patch)
tree0876fb5cc1d38a316c0fbaf87137d69775f5dad0 /devel/pear-PEAR/Makefile
parentcf19879c06b65241c187f1b0663a0db0270be14f (diff)
downloadports-050dd1b1031022b49cd1623dd3892f3c4be3a1ae.tar.gz
ports-050dd1b1031022b49cd1623dd3892f3c4be3a1ae.zip
Resurrection of port devel/pear
PR: ports/44473 Submitted by: Thierry Thomas <thierry@pompo.net>
Notes
Notes: svn path=/head/; revision=70285
Diffstat (limited to 'devel/pear-PEAR/Makefile')
-rw-r--r--devel/pear-PEAR/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/devel/pear-PEAR/Makefile b/devel/pear-PEAR/Makefile
new file mode 100644
index 000000000000..b1bb6bede494
--- /dev/null
+++ b/devel/pear-PEAR/Makefile
@@ -0,0 +1,45 @@
+# Ports collection makefile for: pear-PEAR
+# Date created: 22 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= PEAR
+PORTVERSION= 1.0.1
+CATEGORIES= devel www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.1/b1/}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${MV} ${PEARDIR}/PEAR ${PEARDIR}/PEAR.dist
+ @${MV} ${PEARDIR}/PEAR.php ${PEARDIR}/PEAR.php.dist
+ @${MV} ${PEARDIR}/System.php ${PEARDIR}/System.php.dist
+ @${CP} -Rp ${WRKSRC}/* ${PEARDIR}
+ @${CHOWN} -R root:wheel ${PEARDIR}/OS
+ @${CHOWN} -R root:wheel ${PEARDIR}/PEAR*
+ @${CHOWN} -R root:wheel ${PEARDIR}/System.php
+ @${CHOWN} -R root:wheel ${PEARDIR}/package.dtd
+ @${CHOWN} -R root:wheel ${PEARDIR}/scripts
+ @${CHOWN} -R root:wheel ${PEARDIR}/template.spec
+
+.include <bsd.port.post.mk>