aboutsummaryrefslogtreecommitdiff
path: root/devel/phabricator/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /devel/phabricator/Makefile
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
downloadports-a1993564e04f29ecbaa05be740547c8677d423cd.tar.gz
ports-a1993564e04f29ecbaa05be740547c8677d423cd.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Notes
Notes: svn path=/head/; revision=463917
Diffstat (limited to 'devel/phabricator/Makefile')
-rw-r--r--devel/phabricator/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/phabricator/Makefile b/devel/phabricator/Makefile
index f1ab1adb8d58..91cd6eadd210 100644
--- a/devel/phabricator/Makefile
+++ b/devel/phabricator/Makefile
@@ -56,9 +56,9 @@ GD_USE= PHP=gd
.if ${PORT_OPTIONS:MOPCACHE}
USE_PHP+= opcache
. if ${PHP_VER} >= 70
-RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/apcu.so:devel/pecl-APCu
+RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/apcu.so:devel/pecl-APCu@${PHP_FLAVOR}
. else
-RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/apcu.so:devel/pecl-APCu4
+RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/apcu.so:devel/pecl-APCu4@${PHP_FLAVOR}
. endif
.endif