aboutsummaryrefslogtreecommitdiff
path: root/devel/phabricator
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2022-01-26 14:30:13 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2022-01-26 14:31:38 +0000
commit09746fa95ea6e46955f836132f7c1b126c96cdc6 (patch)
treebc20ac1675be182726472b4e581fc98b0cd5d3af /devel/phabricator
parent8a633e7f6cff0d786d477cb36fa93d307989c44d (diff)
downloadports-09746fa95ea6e46955f836132f7c1b126c96cdc6.tar.gz
ports-09746fa95ea6e46955f836132f7c1b126c96cdc6.zip
devel/phabricator: Fix default workboard on projects
This adds a patch to unbreak having workboards as the default view on projects.
Diffstat (limited to 'devel/phabricator')
-rw-r--r--devel/phabricator/Makefile2
-rw-r--r--devel/phabricator/files/patch-src_applications_project_controller_PhabricatorProjectViewController.php11
-rw-r--r--devel/phabricator/files/patch-src_applications_search_engine_PhabricatorProfileMenuEngine.php22
3 files changed, 34 insertions, 1 deletions
diff --git a/devel/phabricator/Makefile b/devel/phabricator/Makefile
index 5ef16edf3e9a..5b3b51d62182 100644
--- a/devel/phabricator/Makefile
+++ b/devel/phabricator/Makefile
@@ -1,6 +1,6 @@
PORTNAME= phabricator
PORTVERSION= 20201119
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
diff --git a/devel/phabricator/files/patch-src_applications_project_controller_PhabricatorProjectViewController.php b/devel/phabricator/files/patch-src_applications_project_controller_PhabricatorProjectViewController.php
new file mode 100644
index 000000000000..72d4ec69e293
--- /dev/null
+++ b/devel/phabricator/files/patch-src_applications_project_controller_PhabricatorProjectViewController.php
@@ -0,0 +1,11 @@
+--- src/applications/project/controller/PhabricatorProjectViewController.php.orig 2022-01-26 14:24:00 UTC
++++ src/applications/project/controller/PhabricatorProjectViewController.php
+@@ -39,7 +39,7 @@ final class PhabricatorProjectViewController
+ $controller_object = new PhabricatorProjectManageController();
+ break;
+ default:
+- return $engine->buildResponse();
++ return $engine->buildResponse(true);
+ }
+
+ return $this->delegateToController($controller_object);
diff --git a/devel/phabricator/files/patch-src_applications_search_engine_PhabricatorProfileMenuEngine.php b/devel/phabricator/files/patch-src_applications_search_engine_PhabricatorProfileMenuEngine.php
new file mode 100644
index 000000000000..cc794c9729a1
--- /dev/null
+++ b/devel/phabricator/files/patch-src_applications_search_engine_PhabricatorProfileMenuEngine.php
@@ -0,0 +1,22 @@
+--- src/applications/search/engine/PhabricatorProfileMenuEngine.php.orig 2022-01-26 14:23:11 UTC
++++ src/applications/search/engine/PhabricatorProfileMenuEngine.php
+@@ -99,7 +99,7 @@ abstract class PhabricatorProfileMenuEngine extends Ph
+ return $this->editMode;
+ }
+
+- public function buildResponse() {
++ public function buildResponse($ignore_item_id = false) {
+ $controller = $this->getController();
+
+ $viewer = $controller->getViewer();
+@@ -130,6 +130,10 @@ abstract class PhabricatorProfileMenuEngine extends Ph
+ $item_id = $request->getURIData('id');
+ }
+
++ if ($ignore_item_id) {
++ $item_id = "";
++ }
++
+ $view_list = $this->newProfileMenuItemViewList();
+
+ if ($is_view) {