aboutsummaryrefslogtreecommitdiff
path: root/devel/py-trio/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2020-07-21 17:15:07 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2020-07-21 17:15:07 +0000
commita961366cfbde9a8e7b1961882ead047cc297082d (patch)
tree858aaee675689febc392a3b8805776575ff567b2 /devel/py-trio/Makefile
parentc10f3fad1bf143903187024b58a6229c85dfe286 (diff)
downloadports-a961366cfbde9a8e7b1961882ead047cc297082d.tar.gz
ports-a961366cfbde9a8e7b1961882ead047cc297082d.zip
- Add devel/py-trio: Friendly Python library for async concurrency and I/O
The Trio project’s goal is to produce a production-quality, permissively licensed, async/await-native I/O library for Python. Like all async libraries, its main purpose is to help you write programs that do multiple things at the same time with parallelized I/O. A web spider that wants to fetch lots of pages in parallel, a web server that needs to juggle lots of downloads and websocket connections at the same time, a process supervisor monitoring multiple subprocesses… that sort of thing. Compared to other libraries, Trio attempts to distinguish itself with an obsessive focus on usability and correctness. Concurrency is complicated; we try to make it easy to get things right. WWW: https://pypi.org/project/trio/
Notes
Notes: svn path=/head/; revision=542760
Diffstat (limited to 'devel/py-trio/Makefile')
-rw-r--r--devel/py-trio/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/devel/py-trio/Makefile b/devel/py-trio/Makefile
new file mode 100644
index 000000000000..ccad3e44b4ab
--- /dev/null
+++ b/devel/py-trio/Makefile
@@ -0,0 +1,38 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= trio
+PORTVERSION= 0.16.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Friendly Python library for async concurrency and I/O
+
+LICENSE= MIT APACHE20
+LICENSE_COMB= dual
+LICENSE_FILE_MIT= ${WRKSRC}/LICENSE.MIT
+LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE.APACHE2
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}async_generator>=0:devel/py-async_generator@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sniffio>=0:devel/py-sniffio@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sortedcontainers>=0:devel/py-sortedcontainers@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}attrs>=0:devel/py-attrs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}idna>=0:dns/py-idna@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}outcome>=0:devel/py-outcome@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}astor>=0:devel/py-astor@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jedi>=0:devel/py-jedi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=0:security/py-openssl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}trustme>=0:security/py-trustme@${PY_FLAVOR} \
+ pylint${PYTHON_PKGNAMESUFFIX}>=0:devel/pylint@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+do-test:
+ @cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest -v -rs
+
+.include <bsd.port.mk>