aboutsummaryrefslogtreecommitdiff
path: root/devel/renpy/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-08-28 14:57:29 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-08-28 14:57:29 +0000
commit8a127a17cf95ecf22344cac4da6cf307fdc6570d (patch)
tree24c9a8f7721996fd14c4ed6089933df842783323 /devel/renpy/Makefile
parent45234bbcb87113e5d70adf6f7314db91637e3cf6 (diff)
downloadports-8a127a17cf95ecf22344cac4da6cf307fdc6570d.tar.gz
ports-8a127a17cf95ecf22344cac4da6cf307fdc6570d.zip
Convert my ports to _VARS option helper
Notes
Notes: svn path=/head/; revision=395493
Diffstat (limited to 'devel/renpy/Makefile')
-rw-r--r--devel/renpy/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/devel/renpy/Makefile b/devel/renpy/Makefile
index d3a4f8b6ffe1..6b5d994a03f2 100644
--- a/devel/renpy/Makefile
+++ b/devel/renpy/Makefile
@@ -53,25 +53,18 @@ OPTIONS_DEFAULT=TKINTER DIST
OPTIONS_DEFINE= DOCS DIST EXAMPLES TKINTER
DIST_DESC= Distribution runtimes for Windows, OS X, Linux
+DIST_VARS= LICENSE+="ART20 PSFL" \
+ PORTDATA+="lib renpy.app renpy.exe renpy.sh"
+EXAMPLES_VARS= PORTDATA+="the_question tutorial"
TKINTER_DESC= Install Tkinter to allow choosing Projects Directory
TKINTER_RUN_DEPENDS=${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDIST}
-LICENSE+= ART20 PSFL
-PORTDATA+= lib renpy.app renpy.exe renpy.sh
. for lic in FREETYPE LIBJPEG LIBPNG MSVCR90
-LICENSE+= ${lic}
+DIST_VARS+= LICENSE+=${lic}
LICENSE_NAME_${lic}= ${lic} license
LICENSE_FILE_${lic}= ${WRKSRC}/LICENSE.txt
LICENSE_PERMS_${lic}= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
. endfor
-.endif
-
-.if ${PORT_OPTIONS:MEXAMPLES}
-PORTDATA+= the_question tutorial
-.endif
post-patch:
@${REINPLACE_CMD} -e 's,/usr/bin/python,${PYTHON_CMD},' \