aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2014-11-06 13:04:52 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2014-11-06 13:04:52 +0000
commite73223bd07d63193a1dc4a04ab90aa5213c0a3c6 (patch)
tree6eda28d1267f4cbbc022a42ca4f3b8c1a3062559 /devel
parent11b9f6533f8e5337b5684a0b18a2d33204119005 (diff)
downloadports-e73223bd07d63193a1dc4a04ab90aa5213c0a3c6.tar.gz
ports-e73223bd07d63193a1dc4a04ab90aa5213c0a3c6.zip
This is yet another file/directory handler that does a bit more than
Path::Class for some parts, and a bit less for other parts. One of the main difference is Path::Extended always tries to use forward slashes when possible, ie. even when you're on the MS Windows, so that you don't need to care about escaping paths that annoys you from time to time when you want to apply regexen to a path, especially in file tests that use 'like' or 'compare'. WWW: http://search.cpan.org/dist/Path-Extended/
Notes
Notes: svn path=/head/; revision=372224
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Path-Extended/Makefile27
-rw-r--r--devel/p5-Path-Extended/distinfo2
-rw-r--r--devel/p5-Path-Extended/pkg-descr9
-rw-r--r--devel/p5-Path-Extended/pkg-plist15
5 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a75f6070b728..6d34d97194a6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2607,6 +2607,7 @@
SUBDIR += p5-Path-Class-File-Lockable
SUBDIR += p5-Path-Dispatcher
SUBDIR += p5-Path-Dispatcher-Declarative
+ SUBDIR += p5-Path-Extended
SUBDIR += p5-Path-FindDev
SUBDIR += p5-Path-IsDev
SUBDIR += p5-Path-Iterator-Rule
diff --git a/devel/p5-Path-Extended/Makefile b/devel/p5-Path-Extended/Makefile
new file mode 100644
index 000000000000..b07e0e5e3481
--- /dev/null
+++ b/devel/p5-Path-Extended/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= Path-Extended
+PORTVERSION= 0.22
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:ISHIGAKI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for yet another Path class
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= \
+ p5-File-Copy-Recursive>0:${PORTSDIR}/devel/p5-File-Copy-Recursive \
+ p5-File-Find-Rule>0:${PORTSDIR}/devel/p5-File-Find-Rule \
+ p5-Log-Dump>0:${PORTSDIR}/devel/p5-Log-Dump \
+ p5-Sub-Install>0:${PORTSDIR}/devel/p5-Sub-Install
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ p5-ExtUtils-MakeMaker-CPANfile>0:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker-CPANfile
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Path-Extended/distinfo b/devel/p5-Path-Extended/distinfo
new file mode 100644
index 000000000000..d5ec74e8f38c
--- /dev/null
+++ b/devel/p5-Path-Extended/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Path-Extended-0.22.tar.gz) = a88fdb85a93be7139672a126002da28708059a29f7d845938cab7712fff166ec
+SIZE (Path-Extended-0.22.tar.gz) = 24121
diff --git a/devel/p5-Path-Extended/pkg-descr b/devel/p5-Path-Extended/pkg-descr
new file mode 100644
index 000000000000..303af5e9bd99
--- /dev/null
+++ b/devel/p5-Path-Extended/pkg-descr
@@ -0,0 +1,9 @@
+This is yet another file/directory handler that does a bit more than
+Path::Class for some parts, and a bit less for other parts. One of
+the main difference is Path::Extended always tries to use forward
+slashes when possible, ie. even when you're on the MS Windows, so that
+you don't need to care about escaping paths that annoys you from time
+to time when you want to apply regexen to a path, especially in file
+tests that use 'like' or 'compare'.
+
+WWW: http://search.cpan.org/dist/Path-Extended/
diff --git a/devel/p5-Path-Extended/pkg-plist b/devel/p5-Path-Extended/pkg-plist
new file mode 100644
index 000000000000..64c6e012c516
--- /dev/null
+++ b/devel/p5-Path-Extended/pkg-plist
@@ -0,0 +1,15 @@
+%%PERL5_MAN3%%/Path::Extended.3.gz
+%%PERL5_MAN3%%/Path::Extended::Class.3.gz
+%%PERL5_MAN3%%/Path::Extended::Class::Dir.3.gz
+%%PERL5_MAN3%%/Path::Extended::Class::File.3.gz
+%%PERL5_MAN3%%/Path::Extended::Dir.3.gz
+%%PERL5_MAN3%%/Path::Extended::Entity.3.gz
+%%PERL5_MAN3%%/Path::Extended::File.3.gz
+%%SITE_PERL%%/Path/Extended.pm
+%%SITE_PERL%%/Path/Extended/Class.pm
+%%SITE_PERL%%/Path/Extended/Class/Dir.pm
+%%SITE_PERL%%/Path/Extended/Class/File.pm
+%%SITE_PERL%%/Path/Extended/Dir.pm
+%%SITE_PERL%%/Path/Extended/Entity.pm
+%%SITE_PERL%%/Path/Extended/File.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Path/Extended/.packlist