aboutsummaryrefslogtreecommitdiff
path: root/editors/xmlcopyeditor/Makefile
diff options
context:
space:
mode:
authorBarbara Guida <bar@FreeBSD.org>2012-12-05 23:27:09 +0000
committerBarbara Guida <bar@FreeBSD.org>2012-12-05 23:27:09 +0000
commitc652b3fdc781d49d6465ca677358b0f8f0f07fd1 (patch)
tree56b3d615dfaeedb47fb94b17d1c14c37140525d8 /editors/xmlcopyeditor/Makefile
parent3717ccbe4ded6d89ecce96171adce053701b0c41 (diff)
downloadports-c652b3fdc781d49d6465ca677358b0f8f0f07fd1.tar.gz
ports-c652b3fdc781d49d6465ca677358b0f8f0f07fd1.zip
- Update to 1.2.0.9
- Change LIB_DEPENDS from textproc/xerces-c2 to textproc/xerces-c3 - Remove obsolete patches - Trim Makefile headers - Remove ABI version from LIB_DEPENDS - Add LICENSE PR: ports/174062 Submitted by: bar Approved by: Jose Garcia Juanino <jjuanino@gmail.com> (maint.), rene (mentor) Feature safe: yes
Notes
Notes: svn path=/head/; revision=308354
Diffstat (limited to 'editors/xmlcopyeditor/Makefile')
-rw-r--r--editors/xmlcopyeditor/Makefile34
1 files changed, 14 insertions, 20 deletions
diff --git a/editors/xmlcopyeditor/Makefile b/editors/xmlcopyeditor/Makefile
index bdf082249761..feb0330a2a84 100644
--- a/editors/xmlcopyeditor/Makefile
+++ b/editors/xmlcopyeditor/Makefile
@@ -1,41 +1,35 @@
-# New ports collection makefile for: xmlcopyeditor
-# Date created: 6 December 2007
-# Whom: José García Juanino <jjuanino@gmail.com>
-#
+# Created by: José García Juanino <jjuanino@gmail.com>
# $FreeBSD$
-#
PORTNAME= xmlcopyeditor
-PORTVERSION= 1.2.0.4
-PORTREVISION= 7
+PORTVERSION= 1.2.0.9
CATEGORIES= editors
MASTER_SITES= SF/xml-copy-editor/${PORTNAME}-linux/${PORTVERSION}
MAINTAINER= jjuanino@gmail.com
COMMENT= Fast validating XML editor
+LICENSE= GPLv2
+
USE_WX= 2.8+
WX_COMPS= wx contrib
WX_CONF_ARGS= absolute
WX_UNICODE= yes
USE_GETTEXT= yes
USE_DOS2UNIX= src/templates/DTD.dtd \
- src/help/html/generic.css \
- src/help/xmlcopyeditor.hhp \
- src/rulesets/ruleset.css \
- src/rng/tei_all.rnc \
- src/rng/docbook.rnc \
- src/rng/tei_minimal.rnc \
+ src/templates/OpenLearn_document.xml \
src/rng/docbookxi.rnc \
- src/po/en_us/messages.po
+ src/rng/tei_all.rnc \
+ src/rng/xhtml-strict.rng \
+ src/rng/xhtml.rng
BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
-LIB_DEPENDS+= xerces-c.27:${PORTSDIR}/textproc/xerces-c2 \
- xslt.2:${PORTSDIR}/textproc/libxslt \
- aspell.16:${PORTSDIR}/textproc/aspell \
- pcre.1:${PORTSDIR}/devel/pcre \
- xml2.5:${PORTSDIR}/textproc/libxml2 \
- expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS+= xerces-c:${PORTSDIR}/textproc/xerces-c3 \
+ xslt:${PORTSDIR}/textproc/libxslt \
+ aspell:${PORTSDIR}/textproc/aspell \
+ pcre:${PORTSDIR}/devel/pcre \
+ xml2:${PORTSDIR}/textproc/libxml2 \
+ expat:${PORTSDIR}/textproc/expat2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}