aboutsummaryrefslogtreecommitdiff
path: root/editors/xmlcopyeditor
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-07-12 22:27:53 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-07-12 22:27:53 +0000
commit398b421be4c337215e64d174fe5f50266c0d7c99 (patch)
treec90acafa038760ccc63cfa1f25a42781e7a52790 /editors/xmlcopyeditor
parent90b7eeea4dc01fb1a16847f6d387d6e5ec6aa89d (diff)
downloadports-398b421be4c337215e64d174fe5f50266c0d7c99.tar.gz
ports-398b421be4c337215e64d174fe5f50266c0d7c99.zip
- Update to 1.2.1.3
PR: 201479 Submitted by: jjuanino@gmail.com
Notes
Notes: svn path=/head/; revision=391845
Diffstat (limited to 'editors/xmlcopyeditor')
-rw-r--r--editors/xmlcopyeditor/Makefile20
-rw-r--r--editors/xmlcopyeditor/distinfo4
-rw-r--r--editors/xmlcopyeditor/files/patch-po_Makefile.in.in.diff10
-rw-r--r--editors/xmlcopyeditor/files/patch-src_Makefile.in.diff27
-rw-r--r--editors/xmlcopyeditor/files/patch-src_styledialog.cpp11
-rw-r--r--editors/xmlcopyeditor/files/patch-src_wrapxerces.cpp17
-rw-r--r--editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.cpp45
-rw-r--r--editors/xmlcopyeditor/pkg-plist60
8 files changed, 58 insertions, 136 deletions
diff --git a/editors/xmlcopyeditor/Makefile b/editors/xmlcopyeditor/Makefile
index ba565e971ae3..2ad93f936e4f 100644
--- a/editors/xmlcopyeditor/Makefile
+++ b/editors/xmlcopyeditor/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xmlcopyeditor
-PORTVERSION= 1.2.0.11
-PORTREVISION= 4
+PORTVERSION= 1.2.1.3
CATEGORIES= editors
MASTER_SITES= SF/xml-copy-editor/${PORTNAME}-linux/${PORTVERSION}
@@ -12,14 +11,7 @@ COMMENT= Fast validating XML editor
LICENSE= GPLv2
-USE_WX= 2.8+
-WX_COMPS= wx contrib
-WX_CONF_ARGS= absolute
-WX_UNICODE= yes
-USES= gettext iconv dos2unix libtool
-GNU_CONFIGURE= yes
-
-BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS= libxerces-c.so.3:${PORTSDIR}/textproc/xerces-c3 \
libxslt.so:${PORTSDIR}/textproc/libxslt \
libaspell.so:${PORTSDIR}/textproc/aspell \
@@ -27,7 +19,13 @@ LIB_DEPENDS= libxerces-c.so.3:${PORTSDIR}/textproc/xerces-c3 \
libxml2.so:${PORTSDIR}/textproc/libxml2 \
libexpat.so:${PORTSDIR}/textproc/expat2
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_WX= 2.8+
+WX_COMPS= wx contrib
+WX_CONF_ARGS= absolute
+WX_UNICODE= yes
+USES= dos2unix gettext gmake iconv libtool
+USE_GNOME= intltool
+GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include \
-I${LOCALBASE}/include/libxml2
diff --git a/editors/xmlcopyeditor/distinfo b/editors/xmlcopyeditor/distinfo
index a6a92ef6098c..6d70a5c750ae 100644
--- a/editors/xmlcopyeditor/distinfo
+++ b/editors/xmlcopyeditor/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xmlcopyeditor-1.2.0.11.tar.gz) = b63a1f5c124d163cf93760fd60cc86c179d4d2b474a875132648f305bc44757b
-SIZE (xmlcopyeditor-1.2.0.11.tar.gz) = 1965438
+SHA256 (xmlcopyeditor-1.2.1.3.tar.gz) = 9b684b5042b4af85d3626fd55108bd1d63c0007b5c794ef7cc4b026012b29d2f
+SIZE (xmlcopyeditor-1.2.1.3.tar.gz) = 4266907
diff --git a/editors/xmlcopyeditor/files/patch-po_Makefile.in.in.diff b/editors/xmlcopyeditor/files/patch-po_Makefile.in.in.diff
new file mode 100644
index 000000000000..80a1d98a5d43
--- /dev/null
+++ b/editors/xmlcopyeditor/files/patch-po_Makefile.in.in.diff
@@ -0,0 +1,10 @@
++++ po/Makefile.in.in
+@@ -34,7 +34,7 @@
+ datarootdir = @datarootdir@
+ libdir = @libdir@
+ DATADIRNAME = @DATADIRNAME@
+-itlocaledir = $(prefix)/$(DATADIRNAME)/locale
++itlocaledir = @localedir@
+ subdir = po
+ install_sh = @install_sh@
+ # Automake >= 1.8 provides @mkdir_p@.
diff --git a/editors/xmlcopyeditor/files/patch-src_Makefile.in.diff b/editors/xmlcopyeditor/files/patch-src_Makefile.in.diff
index fc3843d70a9c..8dcd697033d5 100644
--- a/editors/xmlcopyeditor/files/patch-src_Makefile.in.diff
+++ b/editors/xmlcopyeditor/files/patch-src_Makefile.in.diff
@@ -1,6 +1,5 @@
---- src/Makefile.in.orig 2012-10-07 15:20:23.000000000 +0200
-+++ src/Makefile.in 2012-12-02 17:24:51.000000000 +0100
-@@ -260,8 +260,8 @@
++++ src/Makefile.in
+@@ -283,8 +283,8 @@
# these are the headers for your project
noinst_HEADERS = $(srcdir)/*.h
xmlcopyeditordir = ${prefix}/share/xmlcopyeditor
@@ -10,24 +9,4 @@
+applicationsdir = ${prefix}/share/applications
# the application source, library search path, and link libraries
- xmlcopyeditor_SOURCES = xmlcopyeditor.cpp associatedialog.cpp casehandler.cpp \
-@@ -287,19 +287,6 @@
- -lexpat -lxslt -lxml2 -lpcre -lxerces-c $(ASPELL_LIBS) $(ENCHANT_LIBS)
-
- nobase_dist_xmlcopyeditor_DATA = $(srcdir)/catalog/catalog \
-- $(srcdir)/copying/*.txt \
-- $(srcdir)/copying/Apache/LICENSE-2.0 \
-- $(srcdir)/copying/Apache/LICENSE-2_files/* \
-- $(srcdir)/copying/Aspell/* \
-- $(srcdir)/copying/boost_shared_ptr/* \
-- $(srcdir)/copying/Expat/* \
-- $(srcdir)/copying/libxml2/* \
-- $(srcdir)/copying/libxslt/* \
-- $(srcdir)/copying/PCRE/* \
-- $(srcdir)/copying/Scintilla/* \
-- $(srcdir)/copying/wxStEditor/* \
-- $(srcdir)/copying/wxStyledTextCtrl/* \
-- $(srcdir)/copying/xmlcopyeditor/* \
- $(srcdir)/dtd/*.* \
- $(srcdir)/dtd/dita/*.* \
- $(srcdir)/dtd/docbook/4.4/*.* \
+ xmlcopyeditor_SOURCES = aboutdialog.cpp associatedialog.cpp binaryfile.cpp \
diff --git a/editors/xmlcopyeditor/files/patch-src_styledialog.cpp b/editors/xmlcopyeditor/files/patch-src_styledialog.cpp
deleted file mode 100644
index 223b5237e8df..000000000000
--- a/editors/xmlcopyeditor/files/patch-src_styledialog.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/styledialog.cpp.orig 2013-11-21 15:48:45.000000000 +0100
-+++ src/styledialog.cpp 2013-11-21 15:50:28.000000000 +0100
-@@ -705,7 +705,7 @@
-
- WrapExpat we;
- ofs << "<table><tr><th>Term</th><th>Frequency</th></tr>";
-- std::map<std::string, int>::iterator mapIterator;
-+ std::map<std::string, int, NoCaseCompare>::iterator mapIterator;
- int matchTotal = 0;
-
- for (
diff --git a/editors/xmlcopyeditor/files/patch-src_wrapxerces.cpp b/editors/xmlcopyeditor/files/patch-src_wrapxerces.cpp
deleted file mode 100644
index 19f928cd2394..000000000000
--- a/editors/xmlcopyeditor/files/patch-src_wrapxerces.cpp
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/wrapxerces.cpp.orig 2013-11-21 15:51:13.000000000 +0100
-+++ src/wrapxerces.cpp 2013-11-21 16:01:41.000000000 +0100
-@@ -201,12 +201,12 @@
- return wxConvUTF8;
- case 2:
- {
-- const static wxMBConvUTF16 conv;
-+ static wxMBConvUTF16 conv;
- return conv;
- }
- case 4:
- {
-- const static wxMBConvUTF32 conv;
-+ static wxMBConvUTF32 conv;
- return conv;
- }
- default:
diff --git a/editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.cpp b/editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.cpp
deleted file mode 100644
index d4bad7d52609..000000000000
--- a/editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.cpp
+++ /dev/null
@@ -1,45 +0,0 @@
---- src/xmlcopyeditor.cpp.orig 2013-08-07 15:31:32.000000000 +0200
-+++ src/xmlcopyeditor.cpp 2013-08-07 15:35:13.000000000 +0200
-@@ -2887,7 +2887,7 @@
-
- const int arraySize = templateArray.GetCount();
-
-- wxString choiceArray[arraySize + 1];
-+ wxString *choiceArray = new wxString[arraySize + 1];
- for ( int i = 0; i < arraySize; ++i )
- * ( choiceArray + i ) = templateArray.Item ( i );
-
-@@ -2901,6 +2901,7 @@
- return;
- }
- typeSelection = scd.GetStringSelection();
-+ delete [] choiceArray;
- }
-
- if ( typeSelection == defaultSelection )
-@@ -4384,20 +4385,23 @@
- encodingVector.push_back ( _T ( "ISO-8859-1" ) );
- encodingVector.push_back ( _T ( "US-ASCII" ) );
- const int vectorSize = encodingVector.size();
-- wxString choiceArray[vectorSize + 1];
-+ wxString *choiceArray = new wxString[vectorSize + 1];
- for ( int i = 0; i < vectorSize; ++i )
- * ( choiceArray + i ) = encodingVector.at ( i );
- wxSingleChoiceDialog scd (
- this, _ ( "Choose an encoding:" ), _ ( "Encoding" ), vectorSize, choiceArray );
-
-- if ( scd.ShowModal() == wxID_CANCEL )
-+ if ( scd.ShowModal() == wxID_CANCEL ) {
-+ delete [] choiceArray;
- return;
-+ }
-
- wxString selection;
- std::string selectionUtf8, bufferUtf8;
-
- selection = scd.GetStringSelection();
- selectionUtf8 = selection.mb_str ( wxConvUTF8 );
-+ delete [] choiceArray;
-
- getRawText ( doc, bufferUtf8 );
- XmlEncodingHandler::setUtf8 ( bufferUtf8, true );
diff --git a/editors/xmlcopyeditor/pkg-plist b/editors/xmlcopyeditor/pkg-plist
index b78544d8e661..c18694cae935 100644
--- a/editors/xmlcopyeditor/pkg-plist
+++ b/editors/xmlcopyeditor/pkg-plist
@@ -1,5 +1,21 @@
bin/xmlcopyeditor
+man/man1/xmlcopyeditor.1.gz
+share/appdata/xmlcopyeditor.appdata.xml
share/applications/xmlcopyeditor.desktop
+share/locale/ca/LC_MESSAGES/xmlcopyeditor.mo
+share/locale/de/LC_MESSAGES/xmlcopyeditor.mo
+share/locale/en_US/LC_MESSAGES/xmlcopyeditor.mo
+share/locale/es/LC_MESSAGES/xmlcopyeditor.mo
+share/locale/fr/LC_MESSAGES/xmlcopyeditor.mo
+share/locale/it/LC_MESSAGES/xmlcopyeditor.mo
+share/locale/km/LC_MESSAGES/xmlcopyeditor.mo
+share/locale/nl/LC_MESSAGES/xmlcopyeditor.mo
+share/locale/ru/LC_MESSAGES/xmlcopyeditor.mo
+share/locale/sk/LC_MESSAGES/xmlcopyeditor.mo
+share/locale/sv/LC_MESSAGES/xmlcopyeditor.mo
+share/locale/uk_UA/LC_MESSAGES/xmlcopyeditor.mo
+share/locale/zh_CN/LC_MESSAGES/xmlcopyeditor.mo
+share/locale/zh_TW/LC_MESSAGES/xmlcopyeditor.mo
share/pixmaps/xmlcopyeditor.png
%%DATADIR%%/catalog/catalog
%%DATADIR%%/dtd/NewsML_1.2.dtd
@@ -168,46 +184,38 @@ share/pixmaps/xmlcopyeditor.png
%%DATADIR%%/png/stock_calc-accept-green.png
%%DATADIR%%/png/stock_calc-accept.png
%%DATADIR%%/png/stock_close.png
-%%DATADIR%%/png/stock_copy-16.png
-%%DATADIR%%/png/stock_cut-16.png
+%%DATADIR%%/png/stock_copy_16.png
+%%DATADIR%%/png/stock_cut_16.png
%%DATADIR%%/png/stock_dialog-info-32.png
%%DATADIR%%/png/stock_dialog-question-32.png
%%DATADIR%%/png/stock_dialog-stop-32.png
%%DATADIR%%/png/stock_dialog-warning-32.png
%%DATADIR%%/png/stock_filters.png
-%%DATADIR%%/png/stock_help-16.png
+%%DATADIR%%/png/stock_help_16.png
%%DATADIR%%/png/stock_hyperlink.png
-%%DATADIR%%/png/stock_internet-16.png
%%DATADIR%%/png/stock_internet.png
-%%DATADIR%%/png/stock_new-16.png
+%%DATADIR%%/png/stock_internet_16.png
%%DATADIR%%/png/stock_new.png
-%%DATADIR%%/png/stock_open-16.png
+%%DATADIR%%/png/stock_new_16.png
+%%DATADIR%%/png/stock_next.png
+%%DATADIR%%/png/stock_next_16.png
%%DATADIR%%/png/stock_open.png
-%%DATADIR%%/png/stock_paste-16.png
-%%DATADIR%%/png/stock_print-16.png
-%%DATADIR%%/png/stock_print-preview-16.png
+%%DATADIR%%/png/stock_open_16.png
+%%DATADIR%%/png/stock_paste_16.png
+%%DATADIR%%/png/stock_previous.png
+%%DATADIR%%/png/stock_previous_16.png
%%DATADIR%%/png/stock_print.png
-%%DATADIR%%/png/stock_redo-16.png
+%%DATADIR%%/png/stock_print_16.png
+%%DATADIR%%/png/stock_print_preview_16.png
%%DATADIR%%/png/stock_redo.png
-%%DATADIR%%/png/stock_save-16.png
+%%DATADIR%%/png/stock_redo_16.png
%%DATADIR%%/png/stock_save.png
-%%DATADIR%%/png/stock_search-16.png
-%%DATADIR%%/png/stock_spellcheck-16.png
+%%DATADIR%%/png/stock_save_16.png
+%%DATADIR%%/png/stock_search_16.png
%%DATADIR%%/png/stock_spellcheck.png
-%%DATADIR%%/png/stock_undo-16.png
+%%DATADIR%%/png/stock_spellcheck_16.png
%%DATADIR%%/png/stock_undo.png
-%%DATADIR%%/po/ca/messages.mo
-%%DATADIR%%/po/de/messages.mo
-%%DATADIR%%/po/es/messages.mo
-%%DATADIR%%/po/fr/messages.mo
-%%DATADIR%%/po/it/messages.mo
-%%DATADIR%%/po/nl/messages.mo
-%%DATADIR%%/po/ru/messages.mo
-%%DATADIR%%/po/sk/messages.mo
-%%DATADIR%%/po/sv/messages.mo
-%%DATADIR%%/po/uk_UA/messages.mo
-%%DATADIR%%/po/zh_CN/messages.mo
-%%DATADIR%%/po/zh_TW/messages.mo
+%%DATADIR%%/png/stock_undo_16.png
%%DATADIR%%/rng/docbook.rnc
%%DATADIR%%/rng/docbook.rng
%%DATADIR%%/rng/docbookxi.rnc