aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2020-05-11 11:15:14 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2020-05-11 11:15:14 +0000
commit360715b9c754e1eb536cf3cad3a56de3bd4517a1 (patch)
tree37f8550067c2ffdf03f053f00e00e4eb01b154c0 /editors
parentdea3c7754c08b57d61424a1e1c4ce87dd6b5e335 (diff)
downloadports-360715b9c754e1eb536cf3cad3a56de3bd4517a1.tar.gz
ports-360715b9c754e1eb536cf3cad3a56de3bd4517a1.zip
- Update to 1.46.0
- Fix build on -CURRENT (clang 10) - Change node and npm dependencies to specify package name [1] Approved by: ehaupt (mentor) Suggested by: 0mp (via ports) [1] Changelog: https://github.com/atom/atom/releases/tag/v1.46.0
Notes
Notes: svn path=/head/; revision=534908
Diffstat (limited to 'editors')
-rw-r--r--editors/atom/Makefile9
-rw-r--r--editors/atom/distinfo14
-rw-r--r--editors/atom/files/atom/patch-node__modules_github_test_git-strategies.test.js4
-rw-r--r--editors/atom/files/atom/patch-node__modules_spell-check_lib_checker-env.coffee9
-rw-r--r--editors/atom/files/atom/patch-node__modules_spell-check_lib_locale-checker.coffee10
-rw-r--r--editors/atom/files/atom/patch-node__modules_spell-check_lib_system-checker.coffee12
-rw-r--r--editors/atom/files/node/patch-common.gypi18
-rw-r--r--editors/atom/files/node/patch-configure11
-rw-r--r--editors/atom/files/patch-package.json4
-rw-r--r--editors/atom/files/patch-script_build8
10 files changed, 69 insertions, 30 deletions
diff --git a/editors/atom/Makefile b/editors/atom/Makefile
index 148a12057124..1be519720f55 100644
--- a/editors/atom/Makefile
+++ b/editors/atom/Makefile
@@ -2,7 +2,7 @@
PORTNAME= atom
DISTVERSIONPREFIX= v
-DISTVERSION= 1.45.0
+DISTVERSION= 1.46.0
CATEGORIES= editors
MASTER_SITES= https://nodejs.org/dist/v${APM_NODE_VER}/:node \
https://github.com/tagattie/FreeBSD-Atom/releases/download/v1.42.0/:jasmine_tagged \
@@ -25,8 +25,8 @@ BUILD_DEPENDS= zip:archivers/zip \
electron${ELECTRON_VER_MAJOR}:devel/electron${ELECTRON_VER_MAJOR} \
bash:shells/bash \
rg:textproc/ripgrep \
- node:www/node10 \
- npm:www/npm-node10
+ node10>:www/node10 \
+ npm-node10>0:www/npm-node10
LIB_DEPENDS= libatk-bridge-2.0.so:accessibility/at-spi2-atk \
libsnappy.so:archivers/snappy \
libasound.so:audio/alsa-lib \
@@ -111,6 +111,9 @@ post-patch:
pre-build: build-apm-node bootstrap-script bootstrap-apm bootstrap-atom clean-backup
build-apm-node:
+ for p in ${PATCHDIR}/node/patch-*; do \
+ ${PATCH} -p0 -d ${WRKDIR}/node-v${APM_NODE_VER} < $${p}; \
+ done
cd ${WRKDIR}/node-v${APM_NODE_VER} && \
${SETENV} ${CONFIGURE_ENV} CC=${CC} CXX=${CXX} ./configure && \
${SETENV} ${MAKE_ENV} ${BSDMAKE} -j ${MAKE_JOBS_NUMBER}
diff --git a/editors/atom/distinfo b/editors/atom/distinfo
index 1530bb710f44..f78e5e7aa017 100644
--- a/editors/atom/distinfo
+++ b/editors/atom/distinfo
@@ -1,11 +1,11 @@
-TIMESTAMP = 1584423742
+TIMESTAMP = 1589005815
SHA256 (node-v10.2.1.tar.gz) = dcdba29f6b933969d6a8a36ea91cfd44bcb500a1e582a3273ac3d4d930e721e4
SIZE (node-v10.2.1.tar.gz) = 35757099
SHA256 (jasmine-tagged-1.1.4.tar.gz) = 8988597858ddf9e9ba3333a19d8651691c8384117bf2e362e8a5ba193ed47585
SIZE (jasmine-tagged-1.1.4.tar.gz) = 3071259
-SHA256 (atom-npm-cache-1.45.0.tar.gz) = ebeb3e4df2e149a3935306ac826a045af6be6ded6b90aaca252278479da8f414
-SIZE (atom-npm-cache-1.45.0.tar.gz) = 42498756
-SHA256 (atom-apm-cache-1.45.0.tar.gz) = 7f3cb00b4fa1dd4e4ba5741bd890b93d3486cdba59e77991d3f4e190807bbc3a
-SIZE (atom-apm-cache-1.45.0.tar.gz) = 118410560
-SHA256 (atom-atom-v1.45.0_GH0.tar.gz) = 9d50468ef1c8e1027881f245d205f3ab8446dcf6c40726a3f562de035f46af52
-SIZE (atom-atom-v1.45.0_GH0.tar.gz) = 11909782
+SHA256 (atom-npm-cache-1.46.0.tar.gz) = 9f8175e833cf1e9474fd75d8843f892ee85abdf0302b8b56eab1bbf1de349ec2
+SIZE (atom-npm-cache-1.46.0.tar.gz) = 42511955
+SHA256 (atom-apm-cache-1.46.0.tar.gz) = 1877ee61481756f7e40b93d3930a67bcdcce2588f5be7ff5a7738c267709a63e
+SIZE (atom-apm-cache-1.46.0.tar.gz) = 116830823
+SHA256 (atom-atom-v1.46.0_GH0.tar.gz) = 328b52d012b9ee27c33dda42a2d94c9793a7899b2429db1c71b5d5680ee7f68e
+SIZE (atom-atom-v1.46.0_GH0.tar.gz) = 11915127
diff --git a/editors/atom/files/atom/patch-node__modules_github_test_git-strategies.test.js b/editors/atom/files/atom/patch-node__modules_github_test_git-strategies.test.js
index d0b98a8265fd..fcac53fe7072 100644
--- a/editors/atom/files/atom/patch-node__modules_github_test_git-strategies.test.js
+++ b/editors/atom/files/atom/patch-node__modules_github_test_git-strategies.test.js
@@ -1,6 +1,6 @@
---- node_modules/github/test/git-strategies.test.js.orig 2019-12-11 03:24:32 UTC
+--- node_modules/github/test/git-strategies.test.js.orig 2020-04-22 18:35:27 UTC
+++ node_modules/github/test/git-strategies.test.js
-@@ -1535,7 +1535,7 @@ import * as reporterProxy from '../lib/reporter-proxy'
+@@ -1536,7 +1536,7 @@ import * as reporterProxy from '../lib/reporter-proxy'
assert.match(options.env.DISPLAY, /^.+$/);
assert.match(options.env.SSH_ASKPASS, /git-askpass-atom\.sh$/);
assert.match(options.env.GIT_ASKPASS, /git-askpass-atom\.sh$/);
diff --git a/editors/atom/files/atom/patch-node__modules_spell-check_lib_checker-env.coffee b/editors/atom/files/atom/patch-node__modules_spell-check_lib_checker-env.coffee
new file mode 100644
index 000000000000..d21e50082881
--- /dev/null
+++ b/editors/atom/files/atom/patch-node__modules_spell-check_lib_checker-env.coffee
@@ -0,0 +1,9 @@
+--- node_modules/spell-check/lib/checker-env.coffee.orig 2020-05-09 06:40:15 UTC
++++ node_modules/spell-check/lib/checker-env.coffee
+@@ -1,5 +1,5 @@
+ module.exports =
+- isLinux: -> /linux/.test process.platform
++ isLinux: -> /(linux|freebsd)/.test process.platform
+ isWindows: -> /win32/.test process.platform # TODO: Windows < 8 or >= 8
+ isDarwin: -> /darwin/.test process.platform
+ preferHunspell: -> !!process.env.SPELLCHECKER_PREFER_HUNSPELL
diff --git a/editors/atom/files/atom/patch-node__modules_spell-check_lib_locale-checker.coffee b/editors/atom/files/atom/patch-node__modules_spell-check_lib_locale-checker.coffee
new file mode 100644
index 000000000000..fa21f1011779
--- /dev/null
+++ b/editors/atom/files/atom/patch-node__modules_spell-check_lib_locale-checker.coffee
@@ -0,0 +1,10 @@
+--- node_modules/spell-check/lib/locale-checker.coffee.orig 2020-05-09 06:41:08 UTC
++++ node_modules/spell-check/lib/locale-checker.coffee
+@@ -78,6 +78,7 @@ class LocaleChecker
+ searchPaths.push "/usr/share/hunspell"
+ searchPaths.push "/usr/share/myspell"
+ searchPaths.push "/usr/share/myspell/dicts"
++ searchPaths.push "/usr/local/share/hunspell"
+
+ # OS X uses the following paths.
+ if env.isDarwin()
diff --git a/editors/atom/files/atom/patch-node__modules_spell-check_lib_system-checker.coffee b/editors/atom/files/atom/patch-node__modules_spell-check_lib_system-checker.coffee
deleted file mode 100644
index 982f5c3c3783..000000000000
--- a/editors/atom/files/atom/patch-node__modules_spell-check_lib_system-checker.coffee
+++ /dev/null
@@ -1,12 +0,0 @@
---- node_modules/spell-check/lib/system-checker.coffee.orig 2019-12-27 08:04:33 UTC
-+++ node_modules/spell-check/lib/system-checker.coffee
-@@ -65,6 +65,9 @@ class SystemChecker
- searchPaths.push "/usr/share/myspell"
- searchPaths.push "/usr/share/myspell/dicts"
-
-+ if /freebsd/.test process.platform
-+ searchPaths.push "/usr/local/share/hunspell"
-+
- # OS X uses the following paths.
- if /darwin/.test process.platform
- searchPaths.push "/"
diff --git a/editors/atom/files/node/patch-common.gypi b/editors/atom/files/node/patch-common.gypi
new file mode 100644
index 000000000000..f220f4a61a05
--- /dev/null
+++ b/editors/atom/files/node/patch-common.gypi
@@ -0,0 +1,18 @@
+--- common.gypi.orig 2020-05-09 05:51:01 UTC
++++ common.gypi
+@@ -455,15 +455,6 @@
+ 'libraries': [ '-lelf' ],
+ }],
+ ['OS=="freebsd"', {
+- 'conditions': [
+- ['"0" < llvm_version < "4.0"', {
+- # Use this flag because on FreeBSD std::pairs copy constructor is non-trivial.
+- # Doesn't apply to llvm 4.0 (FreeBSD 11.1) or later.
+- # Refs: https://lists.freebsd.org/pipermail/freebsd-toolchain/2016-March/002094.html
+- # Refs: https://svnweb.freebsd.org/ports/head/www/node/Makefile?revision=444555&view=markup
+- 'cflags': [ '-D_LIBCPP_TRIVIAL_PAIR_COPY_CTOR=1' ],
+- }],
+- ],
+ 'ldflags': [
+ '-Wl,--export-dynamic',
+ ],
diff --git a/editors/atom/files/node/patch-configure b/editors/atom/files/node/patch-configure
new file mode 100644
index 000000000000..c8a3495523e1
--- /dev/null
+++ b/editors/atom/files/node/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2020-05-09 05:50:03 UTC
++++ configure
+@@ -668,7 +668,7 @@ def get_nasm_version(asm):
+
+ def get_llvm_version(cc):
+ return get_version_helper(
+- cc, r"(^(?:FreeBSD )?clang version|based on LLVM) ([3-9]\.[0-9]+)")
++ cc, r"(^(?:FreeBSD )?clang version|based on LLVM) ([0-9]+\.[0-9]+)")
+
+ def get_xcode_version(cc):
+ return get_version_helper(
diff --git a/editors/atom/files/patch-package.json b/editors/atom/files/patch-package.json
index e4a019f76e09..928c324ab84e 100644
--- a/editors/atom/files/patch-package.json
+++ b/editors/atom/files/patch-package.json
@@ -1,6 +1,6 @@
---- package.json.orig 2019-12-29 05:23:50 UTC
+--- package.json.orig 2020-04-22 18:42:32 UTC
+++ package.json
-@@ -74,7 +74,7 @@
+@@ -76,7 +76,7 @@
"incompatible-packages": "file:packages/incompatible-packages",
"jasmine-json": "~0.0",
"jasmine-reporters": "1.1.0",
diff --git a/editors/atom/files/patch-script_build b/editors/atom/files/patch-script_build
index 0cd8f94627c8..e79a30d6250b 100644
--- a/editors/atom/files/patch-script_build
+++ b/editors/atom/files/patch-script_build
@@ -1,6 +1,6 @@
---- script/build.orig 2019-10-21 17:33:40 UTC
+--- script/build.orig 2020-04-22 18:42:32 UTC
+++ script/build
-@@ -68,7 +68,7 @@ process.env.ELECTRON_VERSION = CONFIG.appMetadata.elec
+@@ -69,7 +69,7 @@ process.env.ELECTRON_VERSION = CONFIG.appMetadata.elec
let binariesPromise = Promise.resolve()
if (!argv.existingBinaries) {
@@ -9,12 +9,12 @@
cleanOutputDirectory()
copyAssets()
transpilePackagesWithCustomTranspilerPaths()
-@@ -88,7 +88,7 @@ if (!argv.existingBinaries) {
+@@ -89,7 +89,7 @@ if (!argv.existingBinaries) {
if (!argv.generateApiDocs) {
binariesPromise
.then(packageApplication)
- .then(packagedAppPath => generateStartupSnapshot(packagedAppPath).then(() => packagedAppPath))
+ // .then(packagedAppPath => generateStartupSnapshot(packagedAppPath).then(() => packagedAppPath))
- .then(packagedAppPath => {
+ .then(async packagedAppPath => {
switch (process.platform) {
case 'darwin': {