aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2022-08-01 09:26:37 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2022-08-01 16:12:15 +0000
commitac4cee8e122f502ffcd9a227fd132ee7348f7f77 (patch)
tree562353f641aedf86d2a1940af33ccbfad7ceaac4 /editors
parent19038c6371d34f358988d33a13822b7a25b0b877 (diff)
downloadports-ac4cee8e122f502ffcd9a227fd132ee7348f7f77.tar.gz
ports-ac4cee8e122f502ffcd9a227fd132ee7348f7f77.zip
editors/with-editor-devel: Add new port
Add editors/with-editor-devel, development version of Emacs Lisp library to use the emacsclient as the $$EDITOR of child processes. https://github.com/magit/with-editor
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/with-editor-devel/Makefile61
-rw-r--r--editors/with-editor-devel/distinfo3
-rw-r--r--editors/with-editor-devel/pkg-descr7
-rw-r--r--editors/with-editor/Makefile2
5 files changed, 74 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index 8b37bb92b234..cd1343505a36 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -269,6 +269,7 @@
SUBDIR += vscode
SUBDIR += web-mode
SUBDIR += with-editor
+ SUBDIR += with-editor-devel
SUBDIR += wordgrinder
SUBDIR += wxhexeditor
SUBDIR += xcoral
diff --git a/editors/with-editor-devel/Makefile b/editors/with-editor-devel/Makefile
new file mode 100644
index 000000000000..2f945462294f
--- /dev/null
+++ b/editors/with-editor-devel/Makefile
@@ -0,0 +1,61 @@
+PORTNAME= with-editor
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.2.0-23
+DISTVERSIONSUFFIX= -gcfcbc27
+CATEGORIES= editors elisp
+PKGNAMESUFFIX= -devel${EMACS_PKGNAMESUFFIX}
+
+MAINTAINER= yasu@FreeBSD.org
+COMMENT= Use the Emacsclient as the $$EDITOR of child processes
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= compat.el${EMACS_PKGNAMESUFFIX}>=28.1.1.0:misc/compat.el@${EMACS_FLAVOR}
+RUN_DEPENDS= compat.el${EMACS_PKGNAMESUFFIX}>=28.1.1.0:misc/compat.el@${EMACS_FLAVOR}
+
+USES= emacs gmake makeinfo
+USE_GITHUB= yes
+GH_ACCOUNT= magit
+
+MAKE_ENV+= LOAD_PATH="-L ${WRKSRC}/lisp -L ${PREFIX}/${EMACS_SITE_LISPDIR} -L ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR} -L ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/compat"
+ALL_TARGET= lisp info
+
+CONFLICTS_INSTALL= with-editor-emacs*
+
+NO_ARCH= yes
+
+INFO= with-editor
+PLIST_FILES= ${EMACS_VERSION_SITE_LISPDIR}/with-editor-autoloads.el \
+ ${EMACS_VERSION_SITE_LISPDIR}/with-editor.el \
+ ${EMACS_VERSION_SITE_LISPDIR}/with-editor.elc
+PORTDOCS= README.org with-editor.html
+
+OPTIONS_DEFINE= DOCS PDF
+
+PDF_DESC= Build and install PDF document
+
+DOCS_BUILD_DEPENDS= gsed:textproc/gsed
+DOCS_ALL_TARGET= html
+DOCS_BINARY_ALIAS= sed=gsed
+PDF_BUILD_DEPENDS= texi2pdf:print/texinfo
+PDF_USE= TEX=dvipdfmx:build
+PDF_ALL_TARGET= pdf
+PDF_PLIST_FILES= ${DOCSDIR}/with-editor.pdf
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/lisp/*.el* \
+ ${STAGEDIR}${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/*.info ${STAGEDIR}${PREFIX}/${INFO_PATH}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.org \
+ ${WRKSRC}/docs/with-editor.html ${STAGEDIR}${DOCSDIR}
+
+do-install-PDF-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/with-editor.pdf ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/editors/with-editor-devel/distinfo b/editors/with-editor-devel/distinfo
new file mode 100644
index 000000000000..5779f0b7a7e2
--- /dev/null
+++ b/editors/with-editor-devel/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1659346140
+SHA256 (magit-with-editor-v3.2.0-23-gcfcbc27_GH0.tar.gz) = 9a3a9bfbdaeda7ca3e4cc1be4debc86f389f1382c7422aa57cface72dc182b66
+SIZE (magit-with-editor-v3.2.0-23-gcfcbc27_GH0.tar.gz) = 32544
diff --git a/editors/with-editor-devel/pkg-descr b/editors/with-editor-devel/pkg-descr
new file mode 100644
index 000000000000..a5ee111f4191
--- /dev/null
+++ b/editors/with-editor-devel/pkg-descr
@@ -0,0 +1,7 @@
+The library with-editor makes it easy to use the Emacsclient as the
+$EDITOR of child processes, making sure they know how to call
+home. For remote processes a substitute is provided, which
+communicates with Emacs on standard output instead of using a socket
+as the Emacsclient does.
+
+WWW: https://github.com/magit/with-editor
diff --git a/editors/with-editor/Makefile b/editors/with-editor/Makefile
index 0b742301d4e1..bf70b7969bf1 100644
--- a/editors/with-editor/Makefile
+++ b/editors/with-editor/Makefile
@@ -17,6 +17,8 @@ GH_ACCOUNT= magit
ALL_TARGET= lisp info
+CONFLICTS_INSTALL= with-editor-devel-emacs*
+
NO_ARCH= yes
INFO= with-editor