aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu/files/patch-pc-bios_spapr-rtas_Makefile
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-01-22 17:34:11 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-01-22 17:34:11 +0000
commitb3f15f1bc762df52e33fc20b9e42fc97b3b36a67 (patch)
tree894bd8641232b56603a08021d4da82f89c303d3f /emulators/qemu/files/patch-pc-bios_spapr-rtas_Makefile
parentfdaa50f4815b91bdf9d8c65ecf4765f9c97a43d9 (diff)
downloadports-b3f15f1bc762df52e33fc20b9e42fc97b3b36a67.tar.gz
ports-b3f15f1bc762df52e33fc20b9e42fc97b3b36a67.zip
emulators/qemu: fix build on powerpc64 elfv2
Clang doesn't like -mbig: cc -mbig -c -o spapr-rtas.o spapr-rtas.S cc: error: unknown argument: '-mbig' This file doesn't seem to be built on amd64, so removing -mbig doesn't cause a problem there. I also successfully built on powerpc64 elfv1 and it also builds. PR: 243188 Approved by: bofh (maintainer timeout)
Notes
Notes: svn path=/head/; revision=523823
Diffstat (limited to 'emulators/qemu/files/patch-pc-bios_spapr-rtas_Makefile')
-rw-r--r--emulators/qemu/files/patch-pc-bios_spapr-rtas_Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/emulators/qemu/files/patch-pc-bios_spapr-rtas_Makefile b/emulators/qemu/files/patch-pc-bios_spapr-rtas_Makefile
new file mode 100644
index 000000000000..46ac6f5c6eb1
--- /dev/null
+++ b/emulators/qemu/files/patch-pc-bios_spapr-rtas_Makefile
@@ -0,0 +1,15 @@
+--- pc-bios/spapr-rtas/Makefile.orig 2020-01-08 10:52:05 UTC
++++ pc-bios/spapr-rtas/Makefile
+@@ -15,10 +15,10 @@ $(call set-vpath, $(SRC_PATH)/pc-bios/spapr-rtas)
+ build-all: spapr-rtas.bin
+
+ %.o: %.S
+- $(call quiet-command,$(CCAS) -mbig -c -o $@ $<,"CCAS","$(TARGET_DIR)$@")
++ $(call quiet-command,$(CCAS) -c -o $@ $<,"CCAS","$(TARGET_DIR)$@")
+
+ %.img: %.o
+- $(call quiet-command,$(CC) -nostdlib -mbig -o $@ $<,"Building","$(TARGET_DIR)$@")
++ $(call quiet-command,$(CC) -nostdlib -o $@ $<,"Building","$(TARGET_DIR)$@")
+
+ %.bin: %.img
+ $(call quiet-command,$(OBJCOPY) -O binary -j .text $< $@,"Building","$(TARGET_DIR)$@")