aboutsummaryrefslogtreecommitdiff
path: root/emulators/vba
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-05-14 11:54:26 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-05-14 11:54:26 +0000
commitc5d69a5700401ac5a9592388ee56658bc10cf771 (patch)
tree9b7f463edb145d8e70deccf41fc80a3f3fe96770 /emulators/vba
parentbbcce9438c6cc66f86033e2ef4d10b0410021183 (diff)
downloadports-c5d69a5700401ac5a9592388ee56658bc10cf771.tar.gz
ports-c5d69a5700401ac5a9592388ee56658bc10cf771.zip
maintainer update of emulators/vba
Update of emulators/vba to 1.7.1_2 (this time for real!) PR: ports/64612 Submitted by: No Name <arundel@gmx.net>
Notes
Notes: svn path=/head/; revision=109110
Diffstat (limited to 'emulators/vba')
-rw-r--r--emulators/vba/Makefile20
-rw-r--r--emulators/vba/distinfo1
-rw-r--r--emulators/vba/files/patch-ac2
-rw-r--r--emulators/vba/files/patch-ad2
4 files changed, 13 insertions, 12 deletions
diff --git a/emulators/vba/Makefile b/emulators/vba/Makefile
index d59b48256635..4cfac6b35035 100644
--- a/emulators/vba/Makefile
+++ b/emulators/vba/Makefile
@@ -6,14 +6,14 @@
PORTNAME= vba
PORTVERSION= 1.7.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= VisualBoyAdvance-src-${PORTVERSION}
MAINTAINER= arundel@gmx.net
-COMMENT= Currently the best Gameboy Advance emulator!
+COMMENT= Open Source Gameboy Advance emulator
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
@@ -28,10 +28,12 @@ TARGET_DIR= ${PREFIX}/bin/
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500035
+.if (${OSVERSION} < 500035)
CFLAGS+= -O0
-.else
-CLAGS+=
+.endif
+
+.ifndef(PROFILING)
+CONFIGURE_ARGS= --without-profiling --disable-dev
.endif
DATA_FILES= ${WRKSRC}/src/VisualBoyAdvance.cfg
@@ -40,12 +42,10 @@ DOC_FILES= COPYING AUTHORS NEWS README ChangeLog INSTALL
pre-everything::
@${ECHO_MSG} ""
- @${ECHO_MSG} "GCC must be 3.x or greater in order to compile GBA.cpp with -O2. Earlier"
- @${ECHO_MSG} "versions have a problem during optimization that requires an absurd"
- @${ECHO_MSG} "ammount of memory and usually ends up crashing the compiler/computer"
+ @${ECHO_MSG} "You can enable profiling by defining PROFILING."
@${ECHO_MSG} ""
- @${ECHO_MSG} "Note by MAINTAINER: Currently everything < 500035 is being build with -O0"
- @${ECHO_MSG} "flag."
+ @${ECHO_MSG} "Due to a bug in gcc2 optimsations other than -O0 will be ignored on"
+ @${ECHO_MSG} "FreeBSD releases that didn't ship with gcc3 (prior 500035)."
@${ECHO_MSG} ""
do-install:
diff --git a/emulators/vba/distinfo b/emulators/vba/distinfo
index 6ae83cad81d6..0d1c6d1e6e90 100644
--- a/emulators/vba/distinfo
+++ b/emulators/vba/distinfo
@@ -1,2 +1,3 @@
MD5 (VisualBoyAdvance-src-1.7.1.tar.gz) = 4147eeac55ecf713397f19eae636eef3
SIZE (VisualBoyAdvance-src-1.7.1.tar.gz) = 1001727
+SIZE (VisualBoyAdvance-src-1.7.1.tar.gz) = 1001727
diff --git a/emulators/vba/files/patch-ac b/emulators/vba/files/patch-ac
index af879c36de78..48c1b41660b5 100644
--- a/emulators/vba/files/patch-ac
+++ b/emulators/vba/files/patch-ac
@@ -5,7 +5,7 @@
VisualBoyAdvance_LDADD = gb/libgb.a @VBA_PROF@ @VBA_MMX@
-VisualBoyAdvance_LDFLAGS = `sdl-config --libs`
-+// VisualBoyAdvance_LDFLAGS = ${SDL_CONFIG}
++VisualBoyAdvance_LDFLAGS = `${SDL_CONFIG} --libs`
TestEmu_SOURCES = \
TestEmu.cpp 2xSaI.cpp pixel.cpp motionblur.cpp admame.cpp \
diff --git a/emulators/vba/files/patch-ad b/emulators/vba/files/patch-ad
index 88f170c6e0e0..c63276b54d0c 100644
--- a/emulators/vba/files/patch-ad
+++ b/emulators/vba/files/patch-ad
@@ -5,7 +5,7 @@
VisualBoyAdvance_LDADD = gb/libgb.a @VBA_PROF@ @VBA_MMX@
-VisualBoyAdvance_LDFLAGS = `sdl-config --libs`
-+// VisualBoyAdvance_LDFLAGS = ${SDL_CONFIG}
++VisualBoyAdvance_LDFLAGS = `${SDL_CONFIG} --libs`
TestEmu_SOURCES = \
TestEmu.cpp 2xSaI.cpp pixel.cpp motionblur.cpp admame.cpp \