aboutsummaryrefslogtreecommitdiff
path: root/finance/chiapos/files/patch-setup.py
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-10-03 20:39:03 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-10-03 20:43:55 +0000
commitdf7cb4adce8d56adad5a334ad3821b1259dd29da (patch)
tree246cc755d9ca61704def4a12d2eb174d078d58ee /finance/chiapos/files/patch-setup.py
parent16c89d12ec5c03f824e4925d18b8849c4ab1e86b (diff)
downloadports-df7cb4adce8d56adad5a334ad3821b1259dd29da.tar.gz
ports-df7cb4adce8d56adad5a334ad3821b1259dd29da.zip
finance/chiapos: New port Chia proof of space
Patch from the PR applied basically unchanged, except I cleaned up for current standards and added NOT_FOR_ARCHS to avoid i386 altogether (where the port won't work). PR: 256509 Obtained from: risner@stdio.com (maintainer)
Diffstat (limited to 'finance/chiapos/files/patch-setup.py')
-rw-r--r--finance/chiapos/files/patch-setup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/finance/chiapos/files/patch-setup.py b/finance/chiapos/files/patch-setup.py
new file mode 100644
index 000000000000..89dd1339a6b5
--- /dev/null
+++ b/finance/chiapos/files/patch-setup.py
@@ -0,0 +1,30 @@
+--- setup.py.orig 2021-05-28 02:40:44 UTC
++++ setup.py
+@@ -107,9 +100,6 @@ ext_modules = [
+ "src/chacha8.c",
+ ],
+ include_dirs=[
+- # Path to pybind11 headers
+- get_pybind_include(),
+- get_pybind_include(user=True),
+ "src",
+ "uint128_t",
+ ".",
+@@ -202,6 +192,7 @@ if platform.system() == "Windows":
+ else:
+ setup(
+ name="chiapos",
++ version="1.0.3",
+ author="Mariano Sorgente",
+ author_email="mariano@chia.net",
+ description="Chia proof of space plotting, proving, and verifying (wraps C++)",
+@@ -209,8 +200,7 @@ else:
+ python_requires=">=3.7",
+ long_description=open("README.md").read(),
+ long_description_content_type="text/markdown",
+- url="https://github.com/Chia-Network/chiavdf",
+- ext_modules=[CMakeExtension("chiapos", ".")],
++ url="https://github.com/Chia-Network/chiapos",
+ cmdclass=dict(build_ext=CMakeBuild),
+ zip_safe=False,
+ )