aboutsummaryrefslogtreecommitdiff
path: root/ftp/curl/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-11-01 20:10:06 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-11-01 20:10:06 +0000
commitac2ab461da68e1aaeea48b1ac87a4117eee1bf52 (patch)
treecbf54d87e02c5572504313711183f37699fc6746 /ftp/curl/Makefile
parent036f5218ecb617d1a8c229441da521accd9adb7c (diff)
downloadports-ac2ab461da68e1aaeea48b1ac87a4117eee1bf52.tar.gz
ports-ac2ab461da68e1aaeea48b1ac87a4117eee1bf52.zip
ftp/curl: avoid auto-enabling ZSTD, make explicit option; ensure GSSAPI compilation.
Since August 2020, curl would auto-enable ZSTD if available while configuring, this would however not propagate to the LIB_DEPENDS. Make sure to explicitly control ZSTD by introducing an option that defaults to off. While here, also mark BROKEN if GSSAPI_BASE is selected while krb5 is installed when building. PR: 250414 Approved by: sunpoet@ (maintainer timeout, 14d)
Notes
Notes: svn path=/head/; revision=553854
Diffstat (limited to 'ftp/curl/Makefile')
-rw-r--r--ftp/curl/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index ac266f1d8202..9eedca6663c8 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -32,7 +32,7 @@ DOCS= FAQ FEATURES INSTALL KNOWN_BUGS MAIL-ETIQUETTE THANKS TODO options-in-ver
SHEBANG_FILES= */*.pl
-OPTIONS_DEFINE= ALTSVC BROTLI CA_BUNDLE COOKIES CURL_DEBUG DEBUG DOCS EXAMPLES IDN IPV6 METALINK NTLM PROXY PSL TLS_SRP
+OPTIONS_DEFINE= ALTSVC BROTLI CA_BUNDLE COOKIES CURL_DEBUG DEBUG DOCS EXAMPLES IDN IPV6 METALINK NTLM PROXY PSL TLS_SRP ZSTD
OPTIONS_GROUP= PROTOCOL
OPTIONS_RADIO= SSL
OPTIONS_SINGLE= GSSAPI RESOLV
@@ -136,6 +136,8 @@ THREADED_RESOLVER_CONFIGURE_ENABLE= pthreads threaded-resolver
TLS_SRP_CONFIGURE_ENABLE= tls-srp
WOLFSSL_CONFIGURE_WITH= wolfssl
WOLFSSL_LIB_DEPENDS= libwolfssl.so:security/wolfssl
+ZSTD_CONFIGURE_WITH= zstd
+ZSTD_LIB_DEPENDS= libzstd.so:archivers/zstd
.include <bsd.port.pre.mk>
@@ -151,6 +153,12 @@ IGNORE= only supports TLS-SRP with either OpenSSL or GnuTLS
IGNORE= only supports LDAPS with SSL
.endif
+.if ${PORT_OPTIONS:MGSSAPI_BASE} && exists(${LOCALBASE}/lib/libkrb5support.so)
+BROKEN= The GSSAPI_BASE option is selected, but you have krb5 installed. \
+ This is incompatible. In order to build, either select GSSAPI_MIT, \
+ or temporarily deinstall krb5 to build curl, or build in poudriere
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS = / s|$$| docs scripts|; /^DIST_SUBDIRS = / s| docs scripts||; /cd docs &&/d' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|\(flags_dbg_off=\)".*"|\1""|; s|\(flags_opt_off=\)".*"|\1""|' ${WRKSRC}/configure