aboutsummaryrefslogtreecommitdiff
path: root/ftp/curl
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-30 15:57:34 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-05-13 19:42:07 +0000
commitc4d2293e5d6c3db60c992e4c503ac0153436ef18 (patch)
tree23be80855951166d946d15bd212f7914dac8db03 /ftp/curl
parent31caf6ed3dd888da21b40cf6e6f8ae62762649d3 (diff)
downloadports-c4d2293e5d6c3db60c992e4c503ac0153436ef18.tar.gz
ports-c4d2293e5d6c3db60c992e4c503ac0153436ef18.zip
ftp/curl: Update to 7.83.0
Changes: https://curl.se/changes.html Security: CVE-2022-22576, CVE-2022-27774, CVE-2022-27775, CVE-2022-27776 Security: 92a4d881-c6cf-11ec-a06f-d4c9ef517024 (cherry picked from commit b6762dd51196c0231e5e5153feac06e55361ee67)
Diffstat (limited to 'ftp/curl')
-rw-r--r--ftp/curl/Makefile3
-rw-r--r--ftp/curl/distinfo6
-rw-r--r--ftp/curl/pkg-plist6
3 files changed, 9 insertions, 6 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 779c63db6adf..2fdc22d0dca5 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -1,8 +1,7 @@
# Created by: Neil Blakey-Milner <nbm@rucus.ru.ac.za>
PORTNAME= curl
-PORTVERSION= 7.82.0
-PORTREVISION= 1
+PORTVERSION= 7.83.0
CATEGORIES= ftp net www
MASTER_SITES= https://curl.se/download/ \
https://github.com/curl/curl/releases/download/curl-${PORTVERSION:S|.|_|g}/
diff --git a/ftp/curl/distinfo b/ftp/curl/distinfo
index edc0a5460d1b..58a5bf541143 100644
--- a/ftp/curl/distinfo
+++ b/ftp/curl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1647264430
-SHA256 (curl-7.82.0.tar.xz) = 0aaa12d7bd04b0966254f2703ce80dd5c38dbbd76af0297d3d690cdce58a583c
-SIZE (curl-7.82.0.tar.xz) = 2446764
+TIMESTAMP = 1651316585
+SHA256 (curl-7.83.0.tar.xz) = bbff0e6b5047e773f3c3b084d80546cc1be4e354c09e419c2d0ef6116253511a
+SIZE (curl-7.83.0.tar.xz) = 2472560
diff --git a/ftp/curl/pkg-plist b/ftp/curl/pkg-plist
index 42412dfd9f07..10d3a0fb2647 100644
--- a/ftp/curl/pkg-plist
+++ b/ftp/curl/pkg-plist
@@ -3,6 +3,7 @@ bin/curl-config
include/curl/curl.h
include/curl/curlver.h
include/curl/easy.h
+include/curl/header.h
include/curl/mprintf.h
include/curl/multi.h
include/curl/options.h
@@ -13,7 +14,7 @@ include/curl/urlapi.h
%%STATIC%%lib/libcurl.a
lib/libcurl.so
lib/libcurl.so.4
-lib/libcurl.so.4.7.0
+lib/libcurl.so.4.8.0
libdata/pkgconfig/libcurl.pc
man/man1/curl-config.1.gz
man/man1/curl.1.gz
@@ -405,7 +406,9 @@ man/man3/curl_easy_cleanup.3.gz
man/man3/curl_easy_duphandle.3.gz
man/man3/curl_easy_escape.3.gz
man/man3/curl_easy_getinfo.3.gz
+man/man3/curl_easy_header.3.gz
man/man3/curl_easy_init.3.gz
+man/man3/curl_easy_nextheader.3.gz
man/man3/curl_easy_option_by_id.3.gz
man/man3/curl_easy_option_by_name.3.gz
man/man3/curl_easy_option_next.3.gz
@@ -570,6 +573,7 @@ share/aclocal/libcurl.m4
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/getredirect.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/getreferrer.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ghiper.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/headerapi.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hiperfifo.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/href_extractor.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/htmltidy.c