aboutsummaryrefslogtreecommitdiff
path: root/ftp/lftp
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2013-11-15 12:42:21 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2013-11-15 12:42:21 +0000
commit0fac70f5f040bf5ffcff4ce4eb513e8cee6948e7 (patch)
tree2a55b74b81015ac8599daecff58e2eefc644b807 /ftp/lftp
parentde8ae1d14d89acca75355fb2a6ea21bd9aea3b43 (diff)
downloadports-0fac70f5f040bf5ffcff4ce4eb513e8cee6948e7.tar.gz
ports-0fac70f5f040bf5ffcff4ce4eb513e8cee6948e7.zip
- Use new LIB_DEPENDS format
- Fix shebang of helper scripts - Switch to new options format - Always stage documentation
Notes
Notes: svn path=/head/; revision=333856
Diffstat (limited to 'ftp/lftp')
-rw-r--r--ftp/lftp/Makefile59
-rw-r--r--ftp/lftp/pkg-plist3
2 files changed, 21 insertions, 41 deletions
diff --git a/ftp/lftp/Makefile b/ftp/lftp/Makefile
index e7f44e4a7c4a..f686655d623a 100644
--- a/ftp/lftp/Makefile
+++ b/ftp/lftp/Makefile
@@ -3,6 +3,7 @@
PORTNAME= lftp
PORTVERSION= 4.4.9
+PORTREVISION= 1
CATEGORIES= ftp ipv6
MASTER_SITES= http://ftp.yars.free.net/pub/source/lftp/ \
http://ftp.yars.free.net/pub/source/lftp/old/ \
@@ -18,9 +19,9 @@ COMMENT= Shell-like command line ftp client
LICENSE= GPLv3
-LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
-USES= iconv
+USES= iconv shebangfix
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
@@ -33,50 +34,26 @@ PORTDOCS= AUTHORS BUGS ChangeLog FAQ FEATURES INSTALL \
MIRRORS NEWS README README.debug-levels README.modules \
THANKS TODO
+SHEBANG_FILES= src/verify-file \
+ src/convert-mozilla-cookies \
+ src/xdg-move
+
OPTIONS_DEFINE= NLS
OPTIONS_RADIO= SSL
OPTIONS_RADIO_SSL= OPENSSL GNUTLS
OPTIONS_DEFAULT= SSL OPENSSL NLS
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MOPENSSL}
-USE_OPENSSL= yes
-CONFIGURE_ARGS+= --with-openssl
-.else
-CONFIGURE_ARGS+= --without-openssl
-.endif
-
-.if ${PORT_OPTIONS:MGNUTLS}
-LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
-CONFIGURE_ARGS+= --with-gnutls
-.else
-CONFIGURE_ARGS+= --without-gnutls
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+= --enable-nls
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-MAN1= lftp.1 lftpget.1
-MAN5= lftp.conf.5
+OPTIONS_SUB= yes
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+OPENSSL_CONFIGURE_WITH= openssl
+OPENSSL_USE= OPENSSL=yes
+GNUTLS_CONFIGURE_WITH= gnutls
+GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
post-install:
- @${INSTALL_DATA} ${WRKSRC}/lftp.conf ${PREFIX}/etc/lftp.conf.sample
-.if !exists(${PREFIX}/etc/lftp.conf)
- ${CP} -p ${PREFIX}/etc/lftp.conf.sample ${PREFIX}/etc/lftp.conf
-.endif
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
-.for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
-.endfor
-.endif
+ ${MV} ${STAGEDIR}${PREFIX}/etc/lftp.conf \
+ ${STAGEDIR}${PREFIX}/etc/lftp.conf.sample
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/ftp/lftp/pkg-plist b/ftp/lftp/pkg-plist
index e83925b3fc9f..ba66792fdf2d 100644
--- a/ftp/lftp/pkg-plist
+++ b/ftp/lftp/pkg-plist
@@ -11,6 +11,9 @@ lib/liblftp-tasks.a
%%DATADIR%%/verify-file
%%DATADIR%%/xdg-move
@dirrm %%DATADIR%%
+man/man1/lftp.1.gz
+man/man1/lftpget.1.gz
+man/man5/lftp.conf.5.gz
%%NLS%%share/locale/cs/LC_MESSAGES/lftp.mo
%%NLS%%share/locale/de/LC_MESSAGES/lftp.mo
%%NLS%%share/locale/es/LC_MESSAGES/lftp.mo