aboutsummaryrefslogtreecommitdiff
path: root/ftp/wget+ipv6/Makefile
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2001-12-17 05:15:58 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2001-12-17 05:15:58 +0000
commit3e081cd251430731ecba0b96c3bc6449fd6039ce (patch)
tree095fafbd533700212781c4d8b056f87730ddd9a8 /ftp/wget+ipv6/Makefile
parenta2c3ef380a5fd1116894cf3def78a88bce4f3a48 (diff)
downloadports-3e081cd251430731ecba0b96c3bc6449fd6039ce.tar.gz
ports-3e081cd251430731ecba0b96c3bc6449fd6039ce.zip
add wget+ipv6, a bit old wget but capable to speak IPv6.
Due to radical development of wget, KAME patch would always not be released in short. This port will happily retire when wget aquires ability to speak IPv6 itself.
Notes
Notes: svn path=/head/; revision=51647
Diffstat (limited to 'ftp/wget+ipv6/Makefile')
-rw-r--r--ftp/wget+ipv6/Makefile60
1 files changed, 60 insertions, 0 deletions
diff --git a/ftp/wget+ipv6/Makefile b/ftp/wget+ipv6/Makefile
new file mode 100644
index 000000000000..df3a9703779b
--- /dev/null
+++ b/ftp/wget+ipv6/Makefile
@@ -0,0 +1,60 @@
+# Ports collection makefile for: wget+ipv6
+# Date created: 17 Dec 2001
+# Whom: FUJISHIMA Satsuki <sf@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wget
+PORTVERSION= 1.7
+CATEGORIES= ftp www ipv6
+MASTER_SITES= ${MASTER_SITE_GNU} \
+ ftp://ftp.dl.ac.uk/ccp14/ftp-mirror/wget/pub/unix/util/wget/ \
+ ftp://ftp.informatik.hu-berlin.de/gnu/wget/ \
+ ftp://ftp.uni-mainz.de/pub/gnu/wget/ \
+ ftp://ftp.max.irk.ru/unix/net/www/wget/
+MASTER_SITE_SUBDIR= wget
+PKGNAMESUFFIX= +ipv6
+
+PATCH_SITES= ftp://ftp.kame.net/pub/kame/misc/ \
+ ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/kame/misc/&,}
+PATCHFILES= wget-17-v6-20010716a.diff.gz
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= sf@FreeBSD.org
+
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
+BUILD_DEPENDS= giconv:${PORTSDIR}/converters/libiconv
+
+.if !defined(WITHOUT_SSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE}
+.endif
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
+ LIBS=-L${LOCALBASE}/lib
+
+MAN1= wget.1
+
+post-patch:
+# made by broken KAME patch. Already contacted.
+ @${RM} -f ${WRKSRC}/po/zh.po*
+# we don't need to run autoconf.
+ ${TOUCH} ${WRKSRC}/configure
+# convert utf-8 to Big5 for FreeBSD's default old fashioned gettext.
+ (cd ${WRKSRC}; \
+ ${MV} po/zh_TW.po po/zh_TW.po.utf-8; \
+ ${LOCALBASE}/bin/giconv -f UTF-8 -t BIG5 po/zh_TW.po.utf-8 |\
+ ${SED} -e 's/utf-8/big5/' |\
+ ${PERL} -p -e 's{([\x81-\xfe])\\}{$$1\\\\}g' |\
+ ${PERL} -p -e 's,\\\\([nt\"]),\\$$1,g' \
+ > po/zh_TW.po)
+
+pre-build:
+ @${RM} -f ${WRKSRC}/doc/wget.info*
+
+post-install:
+ install-info ${PREFIX}/info/wget.info ${PREFIX}/info/dir
+
+.include <bsd.port.mk>