aboutsummaryrefslogtreecommitdiff
path: root/ftp/wget
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2017-07-26 05:02:41 +0000
committerVasil Dimov <vd@FreeBSD.org>2017-07-26 05:02:41 +0000
commitf577936c076356eab3c7a2f11891d0bcd6f95765 (patch)
tree4a4b2123e08d436d2dd984a6d7d21daa9f225d4a /ftp/wget
parentab313cc2236f5f05652d6f93e715d5e5a68ba5ed (diff)
downloadports-f577936c076356eab3c7a2f11891d0bcd6f95765.tar.gz
ports-f577936c076356eab3c7a2f11891d0bcd6f95765.zip
ftp/wget: Tweak docs options
* Add a separate option to control whether man page is to be installed * Handle wgetrc.sample with @sample, according to https://www.freebsd.org/doc/en/books/porters-handbook/plist-config.html and https://www.freebsd.org/doc/en/books/porters-handbook/plist-keywords.html#plist-keywords-sample * Now the DOCS option only controls whether an info page is installed or not Submitted by: jkim
Notes
Notes: svn path=/head/; revision=446640
Diffstat (limited to 'ftp/wget')
-rw-r--r--ftp/wget/Makefile29
-rw-r--r--ftp/wget/pkg-plist6
2 files changed, 22 insertions, 13 deletions
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index f1c87cd9edc7..937ee8e661a5 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wget
DISTVERSION= 1.19.1
+PORTREVISION= 1
CATEGORIES= ftp www ipv6
MASTER_SITES= GNU
@@ -22,13 +23,13 @@ OPTIONS_SUB= yes
OPTIONS_RADIO= SSL
OPTIONS_RADIO_SSL=GNUTLS OPENSSL
-OPTIONS_DEFINE= DOCS IDN IPV6 METALINK NLS PCRE PSL
-OPTIONS_DEFAULT=DOCS IDN OPENSSL
+OPTIONS_DEFINE= DOCS IDN IPV6 MANPAGES METALINK NLS PCRE PSL
+OPTIONS_DEFAULT=DOCS IDN IPV6 MANPAGES NLS OPENSSL
-DOCS_DESC= Install sample config file, info page and man page
+DOCS_DESC= Install info page
+DOCS_CONFIGURE_ENV= MAKEINFO="${LOCALBASE}/bin/makeinfo"
DOCS_INFO= wget
-DOCS_USE= PERL5=build
-DOCS_USES= makeinfo perl5
+DOCS_USES= makeinfo
IDN_LIB_DEPENDS= libidn2.so:dns/libidn2 \
libunistring.so:devel/libunistring
@@ -41,6 +42,10 @@ IDN_CONFIGURE_OFF= --with-included-libunistring
IPV6_CONFIGURE_ENABLE= ipv6
+MANPAGES_CONFIGURE_ENV_OFF= ac_cv_path_POD2MAN=no
+MANPAGES_USE= PERL5=build
+MANPAGES_USES= perl5
+
METALINK_CONFIGURE_WITH=metalink
METALINK_LIB_DEPENDS= libmetalink.so:misc/libmetalink
@@ -77,17 +82,21 @@ CONFIGURE_ARGS+=--without-ssl
TEST_TARGET= check
-post-patch-DOCS-off:
- ${REINPLACE_CMD} -e '/^SUBDIRS = / s/ doc / /' ${WRKSRC}/Makefile.in
-
-post-patch-DOCS-on:
+# Executed regardless of whether DOCS is ON or OFF.
+post-patch:
${REINPLACE_CMD} -e 's,WGETRC = $$(sysconfdir)/wgetrc,&.sample,' \
${WRKSRC}/doc/Makefile.in
${REINPLACE_CMD} -e 's,/usr/local/etc/wgetrc,${PREFIX}/etc/wgetrc,' \
${WRKSRC}/doc/sample.wgetrc* \
- ${WRKSRC}/doc/wget.info \
${WRKSRC}/doc/wget.texi
+post-patch-DOCS-off:
+ ${REINPLACE_CMD} \
+ -e '/^all: wget.info/ s,wget.info,,' \
+ -e '/^all-am:/ s, $$(INFO_DEPS),,' \
+ -e '/^install-data-am:/ s, install-info-am,,' \
+ ${WRKSRC}/doc/Makefile.in
+
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MOPENSSL} && ${SSL_DEFAULT:Mopenssl-devel}
diff --git a/ftp/wget/pkg-plist b/ftp/wget/pkg-plist
index 801e9c18bda5..b0bde8c3120f 100644
--- a/ftp/wget/pkg-plist
+++ b/ftp/wget/pkg-plist
@@ -1,6 +1,4 @@
-bin/wget
-%%DOCS%%etc/wgetrc.sample
-%%DOCS%%man/man1/wget.1.gz
+%%MANPAGES%%man/man1/wget.1.gz
%%NLS%%share/locale/be/LC_MESSAGES/wget.mo
%%NLS%%share/locale/bg/LC_MESSAGES/wget.mo
%%NLS%%share/locale/ca/LC_MESSAGES/wget.mo
@@ -40,3 +38,5 @@ bin/wget
%%NLS%%share/locale/vi/LC_MESSAGES/wget.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/wget.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/wget.mo
+@sample etc/wgetrc.sample
+bin/wget