aboutsummaryrefslogtreecommitdiff
path: root/games/burgerspace/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-17 17:47:17 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-17 17:47:17 +0000
commit27984d171f3967a405acd13783d5ea0fe054295e (patch)
tree725803ce097e50e55be6152f66104487fe30f380 /games/burgerspace/Makefile
parentf2143cd88121bee9a55bff672184ec79feaccae4 (diff)
downloadports-27984d171f3967a405acd13783d5ea0fe054295e.tar.gz
ports-27984d171f3967a405acd13783d5ea0fe054295e.zip
Add burgerspace 1.4, a BurgerTime clone for X.
PR: 26526 Submitted by: Mark Pulford <mark@kyne.com.au>
Notes
Notes: svn path=/head/; revision=41584
Diffstat (limited to 'games/burgerspace/Makefile')
-rw-r--r--games/burgerspace/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/games/burgerspace/Makefile b/games/burgerspace/Makefile
new file mode 100644
index 000000000000..6086cf1c3e6c
--- /dev/null
+++ b/games/burgerspace/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: burgerspace
+# Date created: Apr 13, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= burgerspace
+PORTVERSION= 1.4
+CATEGORIES= games
+MASTER_SITES= http://sites.netscape.net/sarrazip/
+
+MAINTAINER= mark@kyne.com.au
+
+LIB_DEPENDS= gengameng.2:${PORTSDIR}/devel/gengameng \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lgnugetopt"
+CONFIGURE_ARGS+= --with-gengameng-prefix="${X11BASE}"
+
+MAN6= burgerspace.6
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/burgerspace ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/burgerspace.6 ${PREFIX}/man/man6
+
+.include <bsd.port.mk>