aboutsummaryrefslogtreecommitdiff
path: root/games/flightgear
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-11-20 22:16:58 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-11-20 22:16:58 +0000
commitfe6bee82eca48c4cd18750562eb8b436d175f2fc (patch)
treea811fc88ea51021de73f7c47f683197c84c31274 /games/flightgear
parentdbb156a8bf3307512ab20269abd8f9a70a819f08 (diff)
downloadports-fe6bee82eca48c4cd18750562eb8b436d175f2fc.tar.gz
ports-fe6bee82eca48c4cd18750562eb8b436d175f2fc.zip
- Update to 0.9.9
- Move to ${X11BASE}
Notes
Notes: svn path=/head/; revision=148886
Diffstat (limited to 'games/flightgear')
-rw-r--r--games/flightgear/Makefile12
-rw-r--r--games/flightgear/distinfo5
-rw-r--r--games/flightgear/files/patch-src_Airports_simple.hxx10
-rw-r--r--games/flightgear/files/patch-src_Main_metar__main.cxx10
-rw-r--r--games/flightgear/files/patch-src_Main_renderer.cxx11
-rw-r--r--games/flightgear/files/patch-src_Network_ATC-Inputs.cxx15
-rw-r--r--games/flightgear/files/patch-src_Network_ATC-Outputs.cxx18
-rw-r--r--games/flightgear/pkg-plist1
8 files changed, 74 insertions, 8 deletions
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index 859f83e116df..5a2dab3db448 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= FlightGear
-PORTVERSION= 0.9.8
-PORTREVISION= 2
+PORTVERSION= 0.9.9
CATEGORIES= games
MASTER_SITES= ftp://ftp.flightgear.org/pub/fgfs/Source/ \
ftp://ftp.de.flightgear.org/pub/fgfs/Source/
@@ -15,19 +14,22 @@ MASTER_SITES= ftp://ftp.flightgear.org/pub/fgfs/Source/ \
MAINTAINER= jylefort@FreeBSD.org
COMMENT= The FlightGear flight simulator
-LIB_DEPENDS= glut:${PORTSDIR}/graphics/libglut
+LIB_DEPENDS= glut:${PORTSDIR}/graphics/libglut \
+ openal.0:${PORTSDIR}/audio/openal
BUILD_DEPENDS= ${X11BASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${X11BASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear
RUN_DEPENDS= ${X11BASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${X11BASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear \
- ${LOCALBASE}/share/FlightGear/version:${PORTSDIR}/games/fgfs-base
+ ${X11BASE}/share/FlightGear/version:${PORTSDIR}/games/fgfs-base
+USE_X_PREFIX= yes
+USE_GL= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
-CONFIGURE_ARGS= --datadir=${LOCALBASE}/share # location of fgfs-base
+CONFIGURE_ARGS= --datadir=${X11BASE}/share # location of fgfs-base
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= est-epsilon.1 fgfs.1 fgjs.1 gl-info.1 js_demo.1 pstest.1
diff --git a/games/flightgear/distinfo b/games/flightgear/distinfo
index 1ac5c78bb80c..eb875fd33bf1 100644
--- a/games/flightgear/distinfo
+++ b/games/flightgear/distinfo
@@ -1,2 +1,3 @@
-MD5 (FlightGear-0.9.8.tar.gz) = 614d11b4fc75479cb3bf42a333705242
-SIZE (FlightGear-0.9.8.tar.gz) = 1644191
+MD5 (FlightGear-0.9.9.tar.gz) = c1bff0cc9eda34f2a31ec9cd4e5216e6
+SHA256 (FlightGear-0.9.9.tar.gz) = 46597145e087d116e479bf9048c06a0c84107ebda62420d783104831e4775c6a
+SIZE (FlightGear-0.9.9.tar.gz) = 1771791
diff --git a/games/flightgear/files/patch-src_Airports_simple.hxx b/games/flightgear/files/patch-src_Airports_simple.hxx
new file mode 100644
index 000000000000..db875e37d9c0
--- /dev/null
+++ b/games/flightgear/files/patch-src_Airports_simple.hxx
@@ -0,0 +1,10 @@
+--- src/Airports/simple.hxx.orig Sun Nov 20 18:54:27 2005
++++ src/Airports/simple.hxx Sun Nov 20 18:54:43 2005
+@@ -36,6 +36,7 @@
+ #ifdef HAVE_CONFIG_H
+ # include <config.h>
+ #endif
++#include <time.h>
+ #include <simgear/math/point3d.hxx>
+ #include <simgear/route/waypoint.hxx>
+ #include <simgear/compiler.h>
diff --git a/games/flightgear/files/patch-src_Main_metar__main.cxx b/games/flightgear/files/patch-src_Main_metar__main.cxx
new file mode 100644
index 000000000000..5cb1cd8edc24
--- /dev/null
+++ b/games/flightgear/files/patch-src_Main_metar__main.cxx
@@ -0,0 +1,10 @@
+--- src/Main/metar_main.cxx.orig Sun Nov 20 19:38:38 2005
++++ src/Main/metar_main.cxx Sun Nov 20 19:39:05 2005
+@@ -20,6 +20,7 @@
+ //
+ // $Id: metar_main.cxx,v 1.10 2005/10/25 16:28:46 ehofman Exp $
+
++#include <time.h>
+ #include <iomanip>
+ #include <sstream>
+ #include <string.h>
diff --git a/games/flightgear/files/patch-src_Main_renderer.cxx b/games/flightgear/files/patch-src_Main_renderer.cxx
new file mode 100644
index 000000000000..29f4a710a069
--- /dev/null
+++ b/games/flightgear/files/patch-src_Main_renderer.cxx
@@ -0,0 +1,11 @@
+--- src/Main/renderer.cxx.orig Sun Nov 20 19:23:36 2005
++++ src/Main/renderer.cxx Sun Nov 20 19:28:43 2005
+@@ -122,7 +122,7 @@
+ FGRenderer::FGRenderer()
+ {
+ #ifdef FG_JPEG_SERVER
+- jpgRenderFrame = FGRenderer::update;
++ jpgRenderFrame = &FGRenderer::update;
+ #endif
+ }
+
diff --git a/games/flightgear/files/patch-src_Network_ATC-Inputs.cxx b/games/flightgear/files/patch-src_Network_ATC-Inputs.cxx
new file mode 100644
index 000000000000..77117453f87f
--- /dev/null
+++ b/games/flightgear/files/patch-src_Network_ATC-Inputs.cxx
@@ -0,0 +1,15 @@
+--- src/Network/ATC-Inputs.cxx.orig Sun Nov 20 19:02:57 2005
++++ src/Network/ATC-Inputs.cxx Sun Nov 20 19:05:33 2005
+@@ -32,7 +32,11 @@
+ # include <sys/stat.h>
+ # include <fcntl.h>
+ # include <unistd.h>
+-# include <istream>
++# ifdef SG_HAVE_STD_INCLUDES
++# include <istream>
++# else
++# include <istream.h>
++# endif
+ #endif
+
+ #include <errno.h>
diff --git a/games/flightgear/files/patch-src_Network_ATC-Outputs.cxx b/games/flightgear/files/patch-src_Network_ATC-Outputs.cxx
new file mode 100644
index 000000000000..c7e213e9bdef
--- /dev/null
+++ b/games/flightgear/files/patch-src_Network_ATC-Outputs.cxx
@@ -0,0 +1,18 @@
+--- src/Network/ATC-Outputs.cxx.orig Sun Nov 20 19:14:22 2005
++++ src/Network/ATC-Outputs.cxx Sun Nov 20 19:14:47 2005
+@@ -32,7 +32,6 @@
+ # include <sys/stat.h>
+ # include <fcntl.h>
+ # include <unistd.h>
+-# include <ostream>
+ #endif
+
+ #include <errno.h>
+@@ -47,6 +46,7 @@
+
+ #include "ATC-Outputs.hxx"
+
++SG_USING_STD(ostream);
+ SG_USING_STD(string);
+
+
diff --git a/games/flightgear/pkg-plist b/games/flightgear/pkg-plist
index 5dbef19e8fb8..c3e8c1cd3b4b 100644
--- a/games/flightgear/pkg-plist
+++ b/games/flightgear/pkg-plist
@@ -6,4 +6,3 @@ bin/js_demo
bin/metar
bin/terrasync
bin/yasim
-sbin/js_server