aboutsummaryrefslogtreecommitdiff
path: root/games/liblcf
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-11 15:44:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-11 15:44:29 +0000
commite3b403395fc97784ab14fc42a4e0f572a515cd92 (patch)
tree42166c9c65a1184a3323995b2bef73117bf1a5bf /games/liblcf
parentc64c608e1281afd9989c60288f1f72e05a4d3348 (diff)
downloadports-e3b403395fc97784ab14fc42a4e0f572a515cd92.tar.gz
ports-e3b403395fc97784ab14fc42a4e0f572a515cd92.zip
liblcf is a library to handle RPG Maker 2000 and 2003 game data.
It can read and write LCF and XML files. liblcf is part of the EasyRPG Project. WWW: https://easy-rpg.org/
Notes
Notes: svn path=/head/; revision=421827
Diffstat (limited to 'games/liblcf')
-rw-r--r--games/liblcf/Makefile36
-rw-r--r--games/liblcf/distinfo3
-rw-r--r--games/liblcf/files/patch-src_reader__util.cpp15
-rw-r--r--games/liblcf/pkg-descr6
-rw-r--r--games/liblcf/pkg-plist89
5 files changed, 149 insertions, 0 deletions
diff --git a/games/liblcf/Makefile b/games/liblcf/Makefile
new file mode 100644
index 000000000000..853aad2d6774
--- /dev/null
+++ b/games/liblcf/Makefile
@@ -0,0 +1,36 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= liblcf
+PORTVERSION= 0.3.2
+CATEGORIES= games
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Library to handle RPG Maker 2000/2003 and EasyRPG projects
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libicui18n.so:devel/icu \
+ libexpat.so:textproc/expat2
+
+USE_GITHUB= yes
+GH_ACCOUNT= EasyRPG
+
+USES= autoreconf libtool pathfix pkgconfig
+PATHFIX_MAKEFILEIN= Makefile.am
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
+
+PORTDOCS= AUTHORS README
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/games/liblcf/distinfo b/games/liblcf/distinfo
new file mode 100644
index 000000000000..7a2ec4797818
--- /dev/null
+++ b/games/liblcf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1471887290
+SHA256 (EasyRPG-liblcf-0.3.2_GH0.tar.gz) = cf98a43f3f10047bf51e92a472bae2904eb61eb7d9495130e17857324047f529
+SIZE (EasyRPG-liblcf-0.3.2_GH0.tar.gz) = 141239
diff --git a/games/liblcf/files/patch-src_reader__util.cpp b/games/liblcf/files/patch-src_reader__util.cpp
new file mode 100644
index 000000000000..ce8c058ca3b2
--- /dev/null
+++ b/games/liblcf/files/patch-src_reader__util.cpp
@@ -0,0 +1,15 @@
+--- src/reader_util.cpp.orig 2015-09-14 08:49:23 UTC
++++ src/reader_util.cpp
+@@ -310,11 +310,7 @@ std::string ReaderUtil::Recode(const std
+ size_t dst_size = str_to_encode.size() * 5 + 10;
+ char *dst = new char[dst_size];
+ size_t dst_left = dst_size;
+-# ifdef ICONV_CONST
+- char ICONV_CONST *p = src;
+-# else
+- char *p = src;
+-# endif
++ char const *p = src;
+ char *q = dst;
+ size_t status = iconv(cd, &p, &src_left, &q, &dst_left);
+ iconv_close(cd);
diff --git a/games/liblcf/pkg-descr b/games/liblcf/pkg-descr
new file mode 100644
index 000000000000..ebdb032664b7
--- /dev/null
+++ b/games/liblcf/pkg-descr
@@ -0,0 +1,6 @@
+liblcf is a library to handle RPG Maker 2000 and 2003 game data.
+It can read and write LCF and XML files.
+
+liblcf is part of the EasyRPG Project.
+
+WWW: https://easy-rpg.org/
diff --git a/games/liblcf/pkg-plist b/games/liblcf/pkg-plist
new file mode 100644
index 000000000000..ae6fad69d1ff
--- /dev/null
+++ b/games/liblcf/pkg-plist
@@ -0,0 +1,89 @@
+include/liblcf/command_codes.h
+include/liblcf/data.h
+include/liblcf/ini.h
+include/liblcf/inireader.h
+include/liblcf/ldb_chunks.h
+include/liblcf/ldb_reader.h
+include/liblcf/lmt_chunks.h
+include/liblcf/lmt_reader.h
+include/liblcf/lmu_chunks.h
+include/liblcf/lmu_reader.h
+include/liblcf/lsd_chunks.h
+include/liblcf/lsd_reader.h
+include/liblcf/reader_lcf.h
+include/liblcf/reader_options.h
+include/liblcf/reader_struct.h
+include/liblcf/reader_types.h
+include/liblcf/reader_util.h
+include/liblcf/reader_xml.h
+include/liblcf/rpg_actor.h
+include/liblcf/rpg_animation.h
+include/liblcf/rpg_animationcelldata.h
+include/liblcf/rpg_animationframe.h
+include/liblcf/rpg_animationtiming.h
+include/liblcf/rpg_attribute.h
+include/liblcf/rpg_battlecommand.h
+include/liblcf/rpg_battlecommands.h
+include/liblcf/rpg_battleranimation.h
+include/liblcf/rpg_battleranimationdata.h
+include/liblcf/rpg_battleranimationextension.h
+include/liblcf/rpg_chipset.h
+include/liblcf/rpg_class.h
+include/liblcf/rpg_commonevent.h
+include/liblcf/rpg_database.h
+include/liblcf/rpg_encounter.h
+include/liblcf/rpg_enemy.h
+include/liblcf/rpg_enemyaction.h
+include/liblcf/rpg_equipment.h
+include/liblcf/rpg_event.h
+include/liblcf/rpg_eventcommand.h
+include/liblcf/rpg_eventpage.h
+include/liblcf/rpg_eventpagecondition.h
+include/liblcf/rpg_item.h
+include/liblcf/rpg_itemanimation.h
+include/liblcf/rpg_learning.h
+include/liblcf/rpg_map.h
+include/liblcf/rpg_mapinfo.h
+include/liblcf/rpg_movecommand.h
+include/liblcf/rpg_moveroute.h
+include/liblcf/rpg_music.h
+include/liblcf/rpg_parameters.h
+include/liblcf/rpg_rect.h
+include/liblcf/rpg_save.h
+include/liblcf/rpg_saveactor.h
+include/liblcf/rpg_savecommonevent.h
+include/liblcf/rpg_saveeventcommands.h
+include/liblcf/rpg_saveeventdata.h
+include/liblcf/rpg_saveevents.h
+include/liblcf/rpg_saveinventory.h
+include/liblcf/rpg_savemapevent.h
+include/liblcf/rpg_savemapinfo.h
+include/liblcf/rpg_savepartylocation.h
+include/liblcf/rpg_savepicture.h
+include/liblcf/rpg_savescreen.h
+include/liblcf/rpg_savesystem.h
+include/liblcf/rpg_savetarget.h
+include/liblcf/rpg_savetitle.h
+include/liblcf/rpg_savevehiclelocation.h
+include/liblcf/rpg_skill.h
+include/liblcf/rpg_sound.h
+include/liblcf/rpg_start.h
+include/liblcf/rpg_state.h
+include/liblcf/rpg_switch.h
+include/liblcf/rpg_system.h
+include/liblcf/rpg_terms.h
+include/liblcf/rpg_terrain.h
+include/liblcf/rpg_testbattler.h
+include/liblcf/rpg_treemap.h
+include/liblcf/rpg_troop.h
+include/liblcf/rpg_troopmember.h
+include/liblcf/rpg_trooppage.h
+include/liblcf/rpg_trooppagecondition.h
+include/liblcf/rpg_variable.h
+include/liblcf/writer_lcf.h
+include/liblcf/writer_xml.h
+lib/liblcf.a
+lib/liblcf.so
+lib/liblcf.so.0
+lib/liblcf.so.0.0.0
+libdata/pkgconfig/liblcf.pc