aboutsummaryrefslogtreecommitdiff
path: root/games/scummvm/files
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-03-26 19:28:47 +0000
committerPatrick Li <pat@FreeBSD.org>2002-03-26 19:28:47 +0000
commit5d3ebef53def78529aa54b0070360073a8f04fe0 (patch)
treef751679f6f2d3419d786a297e5814edd47b632f3 /games/scummvm/files
parent092f407f34cab07e56dc8f9a8c8e3d51c8129e6d (diff)
downloadports-5d3ebef53def78529aa54b0070360073a8f04fe0.tar.gz
ports-5d3ebef53def78529aa54b0070360073a8f04fe0.zip
Add new port games/scummvm - A free implementation of LucasArts S.C.U.M.M.
interpreter PR: 36335 Submitted by: Miguel Mendez <flynn@energyhq.homeip.net>
Notes
Notes: svn path=/head/; revision=56713
Diffstat (limited to 'games/scummvm/files')
-rw-r--r--games/scummvm/files/patch-Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/games/scummvm/files/patch-Makefile b/games/scummvm/files/patch-Makefile
new file mode 100644
index 000000000000..a724b8cb19b9
--- /dev/null
+++ b/games/scummvm/files/patch-Makefile
@@ -0,0 +1,32 @@
+--- Makefile.orig Tue Jan 15 08:06:24 2002
++++ Makefile Tue Mar 26 13:17:48 2002
+@@ -1,12 +1,10 @@
+ # $Header: /cvsroot/scummvm/scummvm/Makefile,v 1.19 2002/01/13 19:48:30 strigeus Exp $
+
+-CC = gcc
+-CFLAGS = -g -Wno-multichar
+ DEFINES = -DUNIX -DUSE_ADLIB
+ LDFLAGS :=
+-INCLUDES:= `sdl-config --cflags` -I./ -I./sound
+-CPPFLAGS= $(DEFINES) $(INCLUDES)
+-LIBS = `sdl-config --libs` -lreadline -lncurses -lhistory -lm
++INCLUDES:= `sdl11-config --cflags` -I./ -I./sound
++CPPFLAGS+= $(DEFINES) $(INCLUDES)
++LIBS = `sdl11-config --libs` -lreadline -lncurses -lhistory -lm
+ ZIPFILE := scummvm-`date '+%Y-%m-%d'`.zip
+
+ INCS = scumm.h scummsys.h stdafx.h
+@@ -22,12 +20,12 @@
+ scummvm.dsp scummvm.dsw sound/fmopl.h gui.h sound.h
+
+ .cpp.o:
+- $(CC) $(CFLAGS) $(CPPFLAGS) -c $(<) -o $*.o
++ $(CXX) $(CFLAGS) $(CPPFLAGS) -c $(<) -o $*.o
+
+ all: scummvm
+
+ scummvm: $(OBJS)
+- $(CC) $(LDFLAGS) -o $(@) $(OBJS) $(LIBS)
++ $(CXX) $(LDFLAGS) -o $(@) $(OBJS) $(LIBS)
+
+ $(OBJS): Makefile