aboutsummaryrefslogtreecommitdiff
path: root/games/ufoai
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-10-01 21:20:15 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-10-01 21:20:15 +0000
commit3150e2f27c980c1a52ecdef2f820423b53e083ad (patch)
tree38f6cb9b06cd47c0a491567b91e912565ed211f2 /games/ufoai
parent18699495ab3eea221ee7a6ffc811829c6c934729 (diff)
downloadports-3150e2f27c980c1a52ecdef2f820423b53e083ad.tar.gz
ports-3150e2f27c980c1a52ecdef2f820423b53e083ad.zip
- Fix the installation path of some files. It causes a crash on UFO missions
- Add pkg-message - Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=174264
Diffstat (limited to 'games/ufoai')
-rw-r--r--games/ufoai/Makefile13
-rw-r--r--games/ufoai/files/pkg-message.in22
-rw-r--r--games/ufoai/pkg-descr2
-rw-r--r--games/ufoai/pkg-plist3
4 files changed, 36 insertions, 4 deletions
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
index 4e983b030162..f2762a7625d8 100644
--- a/games/ufoai/Makefile
+++ b/games/ufoai/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ufoai
DISTVERSION= 2.0RC5
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF
DISTNAME= ${PORTNAME:S/$/-/}${DISTVERSION:S/R/-R/}-source
@@ -26,8 +27,9 @@ USE_GETTEXT= yes
USE_GMAKE= yes
DATADIR= share/${PORTNAME}
+SUB_FILES= pkg-message
UFO_DIR= ${PREFIX}/lib/${PORTNAME}
-UFO_LIBS= ref_glx ref_sdl snd_sdl ref_glx snd_oss game
+UFO_LIBS= ref_glx ref_sdl snd_sdl ref_glx snd_oss
UFO_FILES= ufo
OPTIONS= SERVER "Install dedicated server" on \
@@ -63,10 +65,13 @@ PLIST_SUB+= UFO2MAP="@comment "
.if defined(WITH_ARTS)
HAVE_ARTS= true
-LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
MAKE_ENV+= BUILD_ARTS="YES"
+LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
+UFO_LIBS+= snd_arts
+PLIST_SUB+= ARTS=""
.else
MAKE_ENV+= BUILD_ARTS="NO"
+PLIST_SUB+= ARTS="@comment "
.endif
.if defined(WITH_IPV6)
@@ -102,10 +107,14 @@ do-install:
. for FILE in ${UFO_LIBS}
${INSTALL_PROGRAM} ${WRKSRC}/release${ARCH}/${FILE}.so ${UFO_DIR}
. endfor
+ ${INSTALL_PROGRAM} ${WRKSRC}/release${ARCH}/game.so ${UFO_DIR}/base
@cd ${WRKSRC}/base/i18n && \
${FIND} * -type d -exec ${MKDIR} "${UFO_DIR}/base/i18n/{}" \; && \
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${UFO_DIR}/base/i18n/{}" \;
${LN} -s ${PREFIX}/${DATADIR}/* ${UFO_DIR}/base
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.post.mk>
diff --git a/games/ufoai/files/pkg-message.in b/games/ufoai/files/pkg-message.in
new file mode 100644
index 000000000000..69c03ad2a9c4
--- /dev/null
+++ b/games/ufoai/files/pkg-message.in
@@ -0,0 +1,22 @@
+###############################################################################
+
+The UFO ALien Invasion was installed
+
+1) Run the UFO Client using:
+
+ # ufo
+
+2) or UFO Dedicated Server using:
+
+ # ufoded
+
+3) or UFO Maps Tool using:
+
+ # ufo2map
+
+4) If you are using the UFO CLient, you need a minimal 1024x968 resolution. It
+ avoids some problems during the game.
+
+5) Enjoy it ;)
+
+###############################################################################
diff --git a/games/ufoai/pkg-descr b/games/ufoai/pkg-descr
index 0708d72fae27..cf785c18d3ee 100644
--- a/games/ufoai/pkg-descr
+++ b/games/ufoai/pkg-descr
@@ -5,4 +5,4 @@ strike force. To be successful on the long run, you will also have to have a
research team study the aliens and their technologies in order to learn as much
as possible about their technology, their goals and the aliens themselves.
-WWW: http://ufo.myexp.de/
+WWW: http://www.ufoai.net/
diff --git a/games/ufoai/pkg-plist b/games/ufoai/pkg-plist
index 9f42f57a0a44..772d0fd107ce 100644
--- a/games/ufoai/pkg-plist
+++ b/games/ufoai/pkg-plist
@@ -5,6 +5,7 @@ lib/ufoai/base/autoexec.cfg
lib/ufoai/base/dedicated.cfg
lib/ufoai/base/default.cfg
lib/ufoai/base/keys.cfg
+lib/ufoai/base/game.so
lib/ufoai/base/maps
lib/ufoai/base/mapshots.cfg
lib/ufoai/base/media
@@ -32,9 +33,9 @@ lib/ufoai/ufo
%%UFO2MAP%%lib/ufoai/ufo2map
lib/ufoai/ref_glx.so
lib/ufoai/ref_sdl.so
+%%ARTS%%lib/ufoai/snd_arts.so
lib/ufoai/snd_sdl.so
lib/ufoai/snd_oss.so
-lib/ufoai/game.so
@dirrm lib/ufoai/base/i18n/slo/LC_MESSAGES
@dirrm lib/ufoai/base/i18n/slo
@dirrm lib/ufoai/base/i18n/ru/LC_MESSAGES