aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1996-11-16 12:38:32 +0000
committerSatoshi Asami <asami@FreeBSD.org>1996-11-16 12:38:32 +0000
commit4803609bdda9045b6d1694feb95ed332c5e003c8 (patch)
tree769a51c84f859a8aded416b870f866b6534e1429 /games
parent5fb18d0a1fbe4cf4253758993c0733af136780c0 (diff)
downloadports-4803609bdda9045b6d1694feb95ed332c5e003c8.tar.gz
ports-4803609bdda9045b6d1694feb95ed332c5e003c8.zip
Triangle puzzle game.
Closes PR 1802/2031. Submitted by: Yukihiro Nakai <Nakai@Mlab.t.u-tokyo.ac.jp>
Notes
Notes: svn path=/head/; revision=4517
Diffstat (limited to 'games')
-rw-r--r--games/xtriangles/Makefile25
-rw-r--r--games/xtriangles/distinfo1
-rw-r--r--games/xtriangles/pkg-comment1
-rw-r--r--games/xtriangles/pkg-descr60
-rw-r--r--games/xtriangles/pkg-plist3
5 files changed, 90 insertions, 0 deletions
diff --git a/games/xtriangles/Makefile b/games/xtriangles/Makefile
new file mode 100644
index 000000000000..bc83c081f7b6
--- /dev/null
+++ b/games/xtriangles/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: xtriangles
+# Version required: V5.3
+# Date created: 12 October 1996
+# Whom: Yukihiro Nakai <Nakai@Mlab.t.u-tokyo.ac.jp>
+#
+# $Id$
+#
+
+DISTNAME= xtriangles
+PKGNAME= xtriangles-5.3
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_XCONTRIB}
+MASTER_SITE_SUBDIR= games/puzzles
+
+MAINTAINER= Nakai@Mlab.t.u-tokyo.ac.jp
+
+USE_IMAKE= yes
+
+post-install:
+ @chmod 755 ${PREFIX}/bin/xtriangles
+ @chown bin.bin ${PREFIX}/bin/xtriangles
+ @${INSTALL_DATA} ${WRKSRC}/Triangles.ad \
+ ${PREFIX}/lib/X11/app-defaults/Triangles
+
+.include <bsd.port.mk>
diff --git a/games/xtriangles/distinfo b/games/xtriangles/distinfo
new file mode 100644
index 000000000000..a7f56ac02598
--- /dev/null
+++ b/games/xtriangles/distinfo
@@ -0,0 +1 @@
+MD5 (xtriangles.tar.gz) = 195f816861a6918c74e492a9a2a5b6f2
diff --git a/games/xtriangles/pkg-comment b/games/xtriangles/pkg-comment
new file mode 100644
index 000000000000..78f6a44ef876
--- /dev/null
+++ b/games/xtriangles/pkg-comment
@@ -0,0 +1 @@
+Triangles puzzle
diff --git a/games/xtriangles/pkg-descr b/games/xtriangles/pkg-descr
new file mode 100644
index 000000000000..43d436db44e4
--- /dev/null
+++ b/games/xtriangles/pkg-descr
@@ -0,0 +1,60 @@
+XTriangles, triangle puzzle for X-Window
+
+Usage:
+ xtriangles [ options ]
+
+Description:
+
+ Use "mouse-left" to move a tile.
+
+ "mouse-right", "R", or "r", to randomize. One must double
+ click on "mouse-right" if the puzzle is being worked on.
+ "I" or "i" keys "increase" or move "up" the number of tri-
+ angles.
+
+ "D" or "d" keys "decrease" or move "down" the number of
+ triangles.
+
+ "S" or "s" keys reserved for the auto-solver (unimple-
+ mented).
+
+ "U" or "u" keys to undo move.
+
+ "G" or "g" keys to get a saved puzzle.
+
+ "W" or "w" keys to write or save a puzzle.
+
+ "Q", "q", or "CTRL-C" keys kill program.
+
+ Use the key pad or "R" keys to move without the mouse.
+
+Options:
+
+ -display host:dpy
+ This option specifies the X server to contact.
+
+ -geometry {+|-}X{+|-}Y
+ This option sets the initial position of the tri-
+ angles window (resource name "geometry").
+
+ -{foreground | fg} color
+ This option specifies the foreground of the trian-
+ gles window (resource name "foreground").
+
+ -{background | bg} color
+ This option specifies the background of the trian-
+ gles window (resource name "background").
+
+ -tile color
+ This option specifies the tile color of the trian-
+ gles window (resource name "tileColor").
+
+ -{border | bd} color
+ This option specifies the border color of the
+ tiles in the triangles window (resource name "bor-
+ derColor").
+
+ -size <int>
+ This option allows you to change the number of
+ triangles in a row (resource name "sizeA").
+
diff --git a/games/xtriangles/pkg-plist b/games/xtriangles/pkg-plist
new file mode 100644
index 000000000000..5894aca113c8
--- /dev/null
+++ b/games/xtriangles/pkg-plist
@@ -0,0 +1,3 @@
+bin/xtriangles
+man/man1/xtriangles.1.gz
+lib/X11/app-defaults/Triangles