aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorJohann Visagie <wjv@FreeBSD.org>2001-10-24 08:30:33 +0000
committerJohann Visagie <wjv@FreeBSD.org>2001-10-24 08:30:33 +0000
commit9444360effc8fea69fd1a4933dd1502e6cbeb76a (patch)
tree2534e2e9b6d0e7425ba7a2a3b556d7e877227823 /games
parente559f704c0c9bf19fd0a2a5c5d07055bed25d357 (diff)
downloadports-9444360effc8fea69fd1a4933dd1502e6cbeb76a.tar.gz
ports-9444360effc8fea69fd1a4933dd1502e6cbeb76a.zip
Add newkind 1.0, Elite: The New Kind - a remake of the 8-bit classic.
Notes
Notes: svn path=/head/; revision=49163
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/newkind/Makefile56
-rw-r--r--games/newkind/distinfo2
-rw-r--r--games/newkind/files/patch-makefile32
-rw-r--r--games/newkind/pkg-comment1
-rw-r--r--games/newkind/pkg-descr21
-rw-r--r--games/newkind/pkg-plist37
7 files changed, 150 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 8f5922fe56e2..16cd0915a45f 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -180,6 +180,7 @@
SUBDIR += netrek-COW3-bin
SUBDIR += netris
SUBDIR += nettoe
+ SUBDIR += newkind
SUBDIR += newvox
SUBDIR += nighthawk
SUBDIR += nil
diff --git a/games/newkind/Makefile b/games/newkind/Makefile
new file mode 100644
index 000000000000..ba216d070a96
--- /dev/null
+++ b/games/newkind/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: Elite - The New Kind
+# Date created: 23 October 2001
+# Whom: Johann Visagie <wjv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= newkind
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://home.clara.net/cjpinder/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTFILES= ${PORTNAME}${EXTRACT_SUFX} ${PORTNAME}b${EXTRACT_SUFX}
+
+MAINTAINER= wjv@FreeBSD.org
+
+# It doesn't seem possible to construct a LIB_DEPENDS for Allegro(?)
+# The dependence on the version number is also sub-optimal.
+BUILD_DEPENDS= allegro-config:${PORTSDIR}/devel/allegro
+RUN_DEPENDS= allegro-config:${PORTSDIR}/devel/allegro
+
+NO_CDROM= Reverse-engineered version of copyrighted abandonware
+NO_PACKAGE= ${NO_CDROM}
+USE_ZIP= yes
+EXTRACT_BEFORE_ARGS= -oq
+NO_WRKSUBDIR= yes
+USE_GMAKE= yes
+MAKEFILE= makefile
+ALL_TARGET=
+SHAREDIR= ${PREFIX}/share/${PORTNAME}
+
+# Currently, everything required to run newkind (including the binary) is
+# installed to ${SHAREDIR}. A shell script wrapper is then installed to
+# ${PREFIX}/bin. A more elegant installation to the standard directory
+# hierarchy under ${PREFIX} would require extensive patching of source files,
+# which will have to be maintained across future versions. If anyone feels
+# up to it, you're more than welcome... :-)
+do-install:
+ @ ${MKDIR} ${SHAREDIR}/data
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/newkind.exe ${SHAREDIR}
+ @ ${INSTALL_DATA} ${WRKSRC}/elite.dat ${WRKSRC}/*.cfg \
+ ${WRKSRC}/*.bmp ${WRKSRC}/*.wav ${SHAREDIR}
+ @ ${INSTALL_DATA} ${WRKSRC}/data/* ${SHAREDIR}/data
+ @ ${MKDIR} ${PREFIX}/bin
+ @ ${ECHO} "#!${SH}" > ${WRKSRC}/newkind
+ @ ${ECHO} "cd ${SHAREDIR} && exec \"./newkind.exe\" \"\$$@\"" \
+ >> ${WRKSRC}/newkind
+ @ ${INSTALL_SCRIPT} ${WRKSRC}/newkind ${PREFIX}/bin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${DOCSDIR}
+ @ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/newkind/distinfo b/games/newkind/distinfo
new file mode 100644
index 000000000000..c2d4484ac18c
--- /dev/null
+++ b/games/newkind/distinfo
@@ -0,0 +1,2 @@
+MD5 (newkind.zip) = 515d893509f26763fc8f19ae5f6d3d50
+MD5 (newkindb.zip) = 139ef6b52b549fd5c7e9d97e0db743e1
diff --git a/games/newkind/files/patch-makefile b/games/newkind/files/patch-makefile
new file mode 100644
index 000000000000..af05f834facb
--- /dev/null
+++ b/games/newkind/files/patch-makefile
@@ -0,0 +1,32 @@
+--- makefile.orig Fri Jul 6 21:29:04 2001
++++ makefile Tue Oct 23 17:40:09 2001
+@@ -2,25 +2,20 @@
+ # Makefile for Elite - The New Kind.
+ #
+
+-CC = gcc
+-WRES = windres
+-
+-LIBS = -s -mwindows -lalleg_s -lkernel32 -lgdi32 -lcomdlg32 -luser32 -lole32 -lddraw -ldxguid -lwinmm -ldsound -ldinput
+-CFLAGS = -mpentium -O2 -funroll-loops -Wall -DALLEGRO_STATICLINK
++CC ?= gcc
++LIBS = -L/usr/local/lib -lalleg-3.9.34 -lalleg_unsharable
++CFLAGS += -mpentium -O2 -funroll-loops -Wall -DALLEGRO_STATICLINK -I/usr/local/include
+
+ OBJS = alg_gfx.o alg_main.o docked.o elite.o\
+ intro.o planet.o shipdata.o shipface.o sound.o space.o\
+ swat.o threed.o vector.o random.o trade.o options.o \
+- stars.o missions.o nkres.o pilot.o file.o keyboard.o
++ stars.o missions.o pilot.o file.o keyboard.o
+
+ .c.o:
+ $(CC) $(CFLAGS) -c $<
+
+ newkind.exe: $(OBJS)
+ $(CC) -o newkind.exe $(OBJS) $(LIBS)
+-
+-nkres.o: nkres.rc
+- $(WRES) nkres.rc nkres.o
+
+
+ alg_gfx.o: alg_gfx.c alg_data.h config.h elite.h planet.h gfx.h
diff --git a/games/newkind/pkg-comment b/games/newkind/pkg-comment
new file mode 100644
index 000000000000..5c56eea0c24c
--- /dev/null
+++ b/games/newkind/pkg-comment
@@ -0,0 +1 @@
+Elite: The New Kind - a remake of the 8-bit classic
diff --git a/games/newkind/pkg-descr b/games/newkind/pkg-descr
new file mode 100644
index 000000000000..9c654777e074
--- /dev/null
+++ b/games/newkind/pkg-descr
@@ -0,0 +1,21 @@
+Elite: The New Kind - a remake of 1984's 8-bit classic space combat and
+trading game "Elite" by Ian Bell and David Braben.
+
+There remains a large contingent of veteran gamers who maintain that the Bell
+and Braben classic Elite was the greatest computer game of all time. This
+remake - Elite: The New Kind - was produced by reverse engineering the
+original disk-based version of Elite on the BBC Microcomputer. However, it
+was updated with shaded polygon graphics and most of the enhanced gameplay
+elements which characterised later versions of Elite.
+
+Snapshots of the original Elite for various emulators (including some which
+will run on FreeBSD) may be downloaded from co-author Ian Bell's Elite site:
+http://www.iancgbell.clara.net/elite/
+
+Shareware versions of the later Elite sequels (for MS-DOS) may be downloaded
+from David Braben's Elite Club: http://www.eliteclub.co.uk/download/
+
+Author: Christian Pinder <christian@newkind.co.uk>
+WWW: http://www.newkind.co.uk/
+
+-- Johann Visagie <wjv@FreeBSD.org>
diff --git a/games/newkind/pkg-plist b/games/newkind/pkg-plist
new file mode 100644
index 000000000000..55d4c26fec04
--- /dev/null
+++ b/games/newkind/pkg-plist
@@ -0,0 +1,37 @@
+%%PORTDOCS%%share/doc/newkind/readme.txt
+bin/newkind
+share/newkind/beep.wav
+share/newkind/boop.wav
+share/newkind/crash.wav
+share/newkind/data/blake.bmp
+share/newkind/data/danube.mid
+share/newkind/data/ecm.bmp
+share/newkind/data/elitetx3.bmp
+share/newkind/data/greendot.bmp
+share/newkind/data/missgrn.bmp
+share/newkind/data/missred.bmp
+share/newkind/data/missyell.bmp
+share/newkind/data/reddot.bmp
+share/newkind/data/safe.bmp
+share/newkind/data/theme.mid
+share/newkind/data/verd2.pcx
+share/newkind/data/verd4.pcx
+share/newkind/dock.wav
+share/newkind/ecm.wav
+share/newkind/elite.dat
+share/newkind/explode.wav
+share/newkind/gameover.wav
+share/newkind/hitem.wav
+share/newkind/hyper.wav
+share/newkind/incom1.wav
+share/newkind/incom2.wav
+share/newkind/launch.wav
+share/newkind/missile.wav
+share/newkind/newkind.cfg
+share/newkind/newkind.exe
+share/newkind/newscan.cfg
+share/newkind/pulse.wav
+share/newkind/scanner.bmp
+@dirrm share/newkind/data
+@dirrm share/newkind
+%%PORTDOCS%%@dirrm share/doc/newkind