aboutsummaryrefslogtreecommitdiff
path: root/german/bsdpaste/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-12 16:55:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-12 16:55:46 +0000
commite652b95ddd2fb4e053c0f06be46f4cb186392ce4 (patch)
tree30af547f4ba8b05fabc6982734d5886631057d08 /german/bsdpaste/Makefile
parent01998ed72c5211b6a329b71441b4d9c232a03f29 (diff)
downloadports-e652b95ddd2fb4e053c0f06be46f4cb186392ce4.tar.gz
ports-e652b95ddd2fb4e053c0f06be46f4cb186392ce4.zip
Another pastebin Application written in Ruby.
Allows the upload of text to a webserver and reading of these information. Often used in IRC channels to show large amounts of text, like config files. WWW: http://bsdgroup.de Submitted by: Aron Schlesinger <as at bsdgroup.de>
Notes
Notes: svn path=/head/; revision=182211
Diffstat (limited to 'german/bsdpaste/Makefile')
-rw-r--r--german/bsdpaste/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/german/bsdpaste/Makefile b/german/bsdpaste/Makefile
new file mode 100644
index 000000000000..6c8904ac7feb
--- /dev/null
+++ b/german/bsdpaste/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: nopastectl
+# Date created: 12 January 2007
+# Whom: Aron Schlesinger <as@bsdgroup.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bsdpaste
+PORTVERSION= 1.0
+CATEGORIES= german ruby
+MASTER_SITES= http://portal.bsdgroup.de/~as/bsdpaste/
+DISTNAME= ${PORTNAME}-${DISTVERSION}
+
+MAINTAINER= as@bsdgroup.de
+COMMENT= Pastebin web application to upload and read text on a webserver.
+
+NO_BUILD= yes
+USE_RUBY= yes
+USE_RUBY_FEATURES= ruby18
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bsdpaste.rb ${PREFIX}/bin/bsdpaste
+
+.include <bsd.port.mk>