aboutsummaryrefslogtreecommitdiff
path: root/graphics/SciPlot
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2013-09-02 17:47:54 +0000
committerThierry Thomas <thierry@FreeBSD.org>2013-09-02 17:47:54 +0000
commitc2c4c7bd1a5979c0066d6ffd4097f99a111528b0 (patch)
treea99ab259a8cc91919d5b0b6dca50ec0b4ba421d3 /graphics/SciPlot
parent6009aff0ca66216ce25970a5727383ad78133db6 (diff)
downloadports-c2c4c7bd1a5979c0066d6ffd4097f99a111528b0.tar.gz
ports-c2c4c7bd1a5979c0066d6ffd4097f99a111528b0.zip
- Fix the build on -CURRENT ;
- Since I'm there, define LICENSE and split PORTDOCS/PORTEXAMPLES. PR: ports/181759 Submitted by: tijl
Notes
Notes: svn path=/head/; revision=326044
Diffstat (limited to 'graphics/SciPlot')
-rw-r--r--graphics/SciPlot/Makefile8
-rw-r--r--graphics/SciPlot/files/patch-Imakefile15
-rw-r--r--graphics/SciPlot/pkg-plist8
3 files changed, 15 insertions, 16 deletions
diff --git a/graphics/SciPlot/Makefile b/graphics/SciPlot/Makefile
index c67410e02fb5..ba96d9958809 100644
--- a/graphics/SciPlot/Makefile
+++ b/graphics/SciPlot/Makefile
@@ -3,7 +3,7 @@
PORTNAME= SciPlot
PORTVERSION= 1.36
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics math
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= widgets
@@ -11,8 +11,10 @@ MASTER_SITE_SUBDIR= widgets
MAINTAINER= thierry@FreeBSD.org
COMMENT= Full-featured Xt widget to display 2D data in a graph
+LICENSE= GPLv2
+
USES= imake motif
-USE_XORG= xp
+USE_XORG= xp xt x11
MAKE_ENV= EXTRA_DEFINES="-fPIC" LIBNAME=${LIBNAME}
USE_LDCONFIG= yes
@@ -36,6 +38,8 @@ post-install:
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${EXDATA:S|^|${WRKSRC}/|} ${EXAMPLESDIR}
${INSTALL_PROGRAM} ${EXBINS:S|^|${WRKSRC}/|} ${EXAMPLESDIR}
diff --git a/graphics/SciPlot/files/patch-Imakefile b/graphics/SciPlot/files/patch-Imakefile
index e32181f4a679..1a496e7363b0 100644
--- a/graphics/SciPlot/files/patch-Imakefile
+++ b/graphics/SciPlot/files/patch-Imakefile
@@ -18,7 +18,7 @@
MOTIFDEPS = $(DEPXMLIB) $(DEPXMULIB) $(DEPXTOOLLIB) $(DEPXLIB)
-MOTIFLIBS = $(MOTIF) $(XMULIB) $(XTOOLLIB) $(XLIB)
-+# MOTIFLIBS = $(MOTIF) $(XMULIB) $(XTOOLLIB) $(XLIB)
++MOTIFLIBS = $(MOTIFLIB) $(XTOOLONLYLIB) $(XONLYLIB)
SYS_LIBRARIES = -lm
CDEBUGFLAGS =
@@ -32,20 +32,15 @@
SRCS = SciPlot.c SciPlotUtil.c xyplot.c realtime.c
HDRS = SciPlot.h SciPlotP.h SciPlotUtil.h
OBJS = $(SRCS:.c=.o)
-@@ -54,10 +58,10 @@
+@@ -54,7 +58,7 @@
$(HDOC) $*.hdoc > $*.html
-AllTarget(sciplot realtime)
+AllTarget(sciplot realtime libs)
--NormalProgramTarget(sciplot,$(PLOTOBJS),$(MOTIFDEPS),$(MOTIFLIBS),$(SYS_LIBRARIES))
--NormalProgramTarget(realtime,$(RTOBJS),$(MOTIFDEPS),$(MOTIFLIBS),$(SYS_LIBRARIES))
-+NormalProgramTarget(sciplot,$(PLOTOBJS),$(MOTIFDEPS),$(MOTIFLIB),$(SYS_LIBRARIES))
-+NormalProgramTarget(realtime,$(RTOBJS),$(MOTIFDEPS),$(MOTIFLIB),$(SYS_LIBRARIES))
-
- doc: $(HOBJS) $(HDOC)
- @echo "Updated html."
+ NormalProgramTarget(sciplot,$(PLOTOBJS),$(MOTIFDEPS),$(MOTIFLIBS),$(SYS_LIBRARIES))
+ NormalProgramTarget(realtime,$(RTOBJS),$(MOTIFDEPS),$(MOTIFLIBS),$(SYS_LIBRARIES))
@@ -79,9 +83,16 @@
tar cfv $(TARFILE).tar $(TARFILES)
compress $(TARFILE).tar
@@ -54,7 +49,7 @@
+ $(AR) $(LIBNAME).a $(WIDGET).o $(WIDGET)Util.o
+ $(RANLIB) $(LIBNAME).a
+ $(CC) $(SHLIBLDFLAGS) -o $(SONAME).$(SONUM) $(WIDGET).o $(WIDGET)Util.o \
-+ $(LDFLAGS) $(MOTIFLIB) $(LDLIBS)
++ $(LDFLAGS) $(MOTIFLIBS) $(LDLIBS)
+
# Dependencies:
diff --git a/graphics/SciPlot/pkg-plist b/graphics/SciPlot/pkg-plist
index d234528246d0..dc578764f666 100644
--- a/graphics/SciPlot/pkg-plist
+++ b/graphics/SciPlot/pkg-plist
@@ -4,8 +4,8 @@ include/SciPlot/SciPlotUtil.h
lib/%%LIBNAME%%.a
lib/%%LIBNAME%%.so
lib/%%LIBNAME%%.so.0
-%%PORTDOCS%%%%EXAMPLESDIR%%/data.txt
-%%PORTDOCS%%%%EXAMPLESDIR%%/realtime
-%%PORTDOCS%%%%EXAMPLESDIR%%/sciplot
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/data.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/realtime
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sciplot
@dirrm include/SciPlot
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%