aboutsummaryrefslogtreecommitdiff
path: root/graphics/imv/Makefile
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2021-08-07 16:06:13 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2021-08-07 16:11:49 +0000
commit695cccdd5a00e9690e9b0855596cd7ffa7e770b2 (patch)
tree698ba0764effb31725322d8f5971e623a0467749 /graphics/imv/Makefile
parentc45834e17fc487ddb045a2507c3647b60789c8ca (diff)
downloadports-695cccdd5a00e9690e9b0855596cd7ffa7e770b2.tar.gz
ports-695cccdd5a00e9690e9b0855596cd7ffa7e770b2.zip
graphics/imv: Update to 4.3.0
* use pkg-plist file instead of Makefile PLIST_FILES due to its size * reformat Makefile with portfmt * pet portlint ChangeLog: https://github.com/eXeC64/imv/blob/master/CHANGELOG
Diffstat (limited to 'graphics/imv/Makefile')
-rw-r--r--graphics/imv/Makefile42
1 files changed, 19 insertions, 23 deletions
diff --git a/graphics/imv/Makefile b/graphics/imv/Makefile
index 0d33228e3806..3c3ba03af047 100644
--- a/graphics/imv/Makefile
+++ b/graphics/imv/Makefile
@@ -1,7 +1,6 @@
PORTNAME= imv
DISTVERSIONPREFIX= v
-DISTVERSION= 4.2.0
-PORTREVISION= 2
+DISTVERSION= 4.3.0
CATEGORIES= graphics
MAINTAINER= eduardo@FreeBSD.org
@@ -14,42 +13,36 @@ BUILD_DEPENDS= a2x:textproc/asciidoc
LIB_DEPENDS= libicuuc.so:devel/icu \
libinih.so:devel/inih \
libxkbcommon.so:x11/libxkbcommon
+RUN_DEPENDS= bash:shells/bash
-USES= compiler:c11 desktop-file-utils gettext-runtime gl gnome \
- meson pkgconfig
+USES= compiler:c11 desktop-file-utils gettext-runtime gl gnome meson \
+ pkgconfig shebangfix
USE_GITHUB= yes
GH_ACCOUNT= eXeC64
USE_GL= egl
USE_GNOME= cairo glib20 pango
-
-PLIST_FILES= bin/imv \
- bin/imv-msg \
- etc/imv_config \
- man/man1/imv-msg.1.gz \
- man/man1/imv.1.gz \
- man/man5/imv.5.gz \
- share/applications/imv.desktop
+SHEBANG_FILES= contrib/imv-folder
OPTIONS_DEFINE= FREEIMAGE HEIF JPEG NSGIF PNG SVG TEST TIFF
-OPTIONS_DEFAULT= FREEIMAGE HEIF JPEG NSGIF PNG SVG TIFF ALL
+OPTIONS_DEFAULT= ALL FREEIMAGE HEIF JPEG NSGIF PNG SVG TIFF
OPTIONS_SINGLE= WIN
-OPTIONS_SINGLE_WIN= WAYLAND X11 ALL
+OPTIONS_SINGLE_WIN= ALL WAYLAND X11
OPTIONS_SUB= yes
+ALL_DESC= Both Wayland and X11 support
FREEIMAGE_DESC= FreeImage backend (support for many image formats)
HEIF_DESC= HEIF backend
NSGIF_DESC= NetSurf GIF backend (support for animated GIF)
WIN_DESC= Windowing system
ALL_LIB_DEPENDS+= libwayland-client.so:graphics/wayland
-ALL_USES= xorg
-ALL_USE= gl=glu xorg=x11,xcb
-ALL_MESON_ON= -Dwindows=all
-ALL_PLIST_FILES= bin/imv-wayland \
- bin/imv-x11
+ALL_USES= xorg
+ALL_USE= GL=glu \
+ XORG=x11,xcb
+ALL_MESON_ON= -Dwindows=all
-FREEIMAGE_LIB_DEPENDS= libfreeimage.so:graphics/freeimage
-FREEIMAGE_MESON_ENABLED=freeimage
+FREEIMAGE_LIB_DEPENDS= libfreeimage.so:graphics/freeimage
+FREEIMAGE_MESON_ENABLED= freeimage
HEIF_LIB_DEPENDS= libheif.so:graphics/libheif
HEIF_MESON_ENABLED= libheif
@@ -77,8 +70,11 @@ WAYLAND_LIB_DEPENDS= libwayland-client.so:graphics/wayland \
WAYLAND_MESON_ON= -Dwindows=wayland
X11_USES= xorg
-X11_USE= gl=glu \
- xorg=x11,xcb
+X11_USE= GL=glu \
+ XORG=x11,xcb
X11_MESON_ON= -Dwindows=x11
+post-patch:
+ @${REINPLACE_CMD} -e 's|--sort=version|-V|g' ${WRKSRC}/contrib/imv-folder
+
.include <bsd.port.mk>