aboutsummaryrefslogtreecommitdiff
path: root/graphics/kamera/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-08-11 01:27:37 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-08-11 01:27:37 +0000
commit461f3c5adb635525af6de102321df3e6288bfb1c (patch)
tree2025e3327a038c580b6f13bdc201e220e2077bb4 /graphics/kamera/Makefile
parent5036b1c6d43d4a6652f933702bfcc8b3553fddfd (diff)
downloadports-461f3c5adb635525af6de102321df3e6288bfb1c.tar.gz
ports-461f3c5adb635525af6de102321df3e6288bfb1c.zip
Factor out all but one of the build switches of the KDE main module ports
into separate ports. The OPTIONS will remain as of yet and trigger dependencies now, for easy transition. Update KOffice to version 1.3.2. Add patches to fix a number of issues, including: - fix kxkb on Xorg - fix kdemultimedia WITH_MPEGLIB (now mpeglib_artsplug) compilation on gcc 3.4.2 with optimizations greater than -O Add security related patches and entries to portaudit.txt.
Notes
Notes: svn path=/head/; revision=115880
Diffstat (limited to 'graphics/kamera/Makefile')
-rw-r--r--graphics/kamera/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/graphics/kamera/Makefile b/graphics/kamera/Makefile
new file mode 100644
index 000000000000..ffe88592513a
--- /dev/null
+++ b/graphics/kamera/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: kamera
+# Date created: July 09 2004
+# Whom: Michael Nottebrock <lofi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kamera
+PORTVERSION= ${KDE_VERSION}
+CATEGORIES= graphics kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+PKGNAMEPREFIX= kdegraphics-
+DISTNAME= kdegraphics-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Digital camera support for KDE
+
+LIB_DEPENDS+= gphoto2:${PORTSDIR}/graphics/libgphoto2
+
+CONFLICTS= kdegraphics-3.1.* kdegraphics-3.2.[0-3]
+
+USE_KDELIBS_VER=3
+PREFIX= ${KDE_PREFIX}
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/kdegraphics-${PORTVERSION}
+
+pre-configure:
+ ${ECHO_CMD} ${PORTNAME} doc > ${WRKSRC}/inst-apps
+ ${REINPLACE_CMD} \
+ 's|^SUBDIRS =.*${PORTNAME}.*$$|SUBDIRS =\. ${PORTNAME}|g' \
+ ${WRKSRC}/doc/Makefile.in
+
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include <bsd.port.mk>