aboutsummaryrefslogtreecommitdiff
path: root/graphics/ogre3d/Makefile
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2020-05-29 05:12:21 +0000
committerMark Linimon <linimon@FreeBSD.org>2020-05-29 05:12:21 +0000
commitd010df2eed195a20e28798413b88a19869bb5006 (patch)
treea8efd1ce50b699d2d173d351a3a5eb56cd269731 /graphics/ogre3d/Makefile
parent254fc05ec5e3c8505f176534714888e9203dee46 (diff)
downloadports-d010df2eed195a20e28798413b88a19869bb5006.tar.gz
ports-d010df2eed195a20e28798413b88a19869bb5006.zip
Mark as BROKEN on powerc64-12.
While here, pet portlint (no actual content change). Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=536937
Diffstat (limited to 'graphics/ogre3d/Makefile')
-rw-r--r--graphics/ogre3d/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/graphics/ogre3d/Makefile b/graphics/ogre3d/Makefile
index 86eec352816d..7362866cdbcc 100644
--- a/graphics/ogre3d/Makefile
+++ b/graphics/ogre3d/Makefile
@@ -7,26 +7,28 @@ DISTVERSION= 1.11.6
PORTREVISION= 0
CATEGORIES= graphics devel
-USE_GITHUB= yes
-GH_ACCOUNT= OGRECave
-GH_PROJECT= ogre
-
MAINTAINER= oliver@FreeBSD.org
COMMENT= Scene-oriented, flexible 3D engine written in C++
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_FreeBSD_12_powerpc64= fails to build: /usr/local/bin/ld: /usr/lib/crt1.o:(.got+0x60): undefined reference to 'main'
+
LIB_DEPENDS= libzzip.so:devel/zziplib \
libfreetype.so:print/freetype2
CONFLICTS= ogre3d19-[0-9]*
+USES= cmake compiler:c++11-lib pkgconfig sdl xorg
USE_LDCONFIG= yes
-USES= cmake pkgconfig compiler:c++11-lib sdl xorg
USE_SDL= sdl2
USE_XORG= x11 xaw xext xrandr xt
+USE_GITHUB= yes
+GH_ACCOUNT= OGRECave
+GH_PROJECT= ogre
+
CMAKE_ARGS+= -DOGRE_BUILD_RENDERSYSTEM_GL3PLUS:BOOL=OFF \
-DOGRE_BUILD_RENDERSYSTEM_GL:BOOL=OFF \
-DOGRE_BUILD_RENDERSYSTEM_GLES2:BOOL=OFF \
@@ -46,7 +48,7 @@ OPTIONS_SUB= yes
DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
DOCS_CMAKE_BOOL= OGRE_INSTALL_DOCS
-
+
FREEIMAGE_DESC= Build FreeImage codec
FREEIMAGE_CMAKE_BOOL= OGRE_BUILD_PLUGIN_FREEIMAGE
FREEIMAGE_LIB_DEPENDS= libfreeimage.so:graphics/freeimage