aboutsummaryrefslogtreecommitdiff
path: root/graphics/opencolorio/files
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-09-19 15:19:59 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-09-19 15:19:59 +0000
commitb35c32f5afaf6de3ed85017c1cb79bc416e74ea3 (patch)
treec9db88f286fea3ac1a08db65dd0e3105110294ca /graphics/opencolorio/files
parent4c9bce9df078e4ab7bf78c993882fc9dfd556a65 (diff)
downloadports-b35c32f5afaf6de3ed85017c1cb79bc416e74ea3.tar.gz
ports-b35c32f5afaf6de3ed85017c1cb79bc416e74ea3.zip
OpenColorIO (OCIO) is a complete color management solution geared
towards motion picture production with an emphasis on visual effects and computer animation. WWW: http://www.opencolorio.org PR: ports/171667 Submitted by: FreeBSD@Shaneware.biz
Notes
Notes: svn path=/head/; revision=304532
Diffstat (limited to 'graphics/opencolorio/files')
-rw-r--r--graphics/opencolorio/files/patch-src_apps_ocioconvert_CMakeLists.txt11
-rw-r--r--graphics/opencolorio/files/patch-src_apps_ociolutimage_CMakeLists.txt11
-rw-r--r--graphics/opencolorio/files/patch-src_core_CMakeLists.txt8
-rw-r--r--graphics/opencolorio/files/patch-src_core_Platform.h12
4 files changed, 42 insertions, 0 deletions
diff --git a/graphics/opencolorio/files/patch-src_apps_ocioconvert_CMakeLists.txt b/graphics/opencolorio/files/patch-src_apps_ocioconvert_CMakeLists.txt
new file mode 100644
index 000000000000..0eda747c65f1
--- /dev/null
+++ b/graphics/opencolorio/files/patch-src_apps_ocioconvert_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/apps/ocioconvert/CMakeLists.txt.orig 2012-06-21 20:37:46.118893014 +0930
++++ src/apps/ocioconvert/CMakeLists.txt 2012-06-21 20:38:07.547827470 +0930
+@@ -10,7 +10,7 @@
+
+ add_executable(ocioconvert ${share_src_files} main.cpp)
+
+- target_link_libraries(ocioconvert ${OIIO_LIBRARIES} OpenColorIO dl)
++ target_link_libraries(ocioconvert ${OIIO_LIBRARIES} OpenColorIO)
+
+ install(TARGETS ocioconvert DESTINATION ${CMAKE_INSTALL_EXEC_PREFIX}/bin)
+ endif()
diff --git a/graphics/opencolorio/files/patch-src_apps_ociolutimage_CMakeLists.txt b/graphics/opencolorio/files/patch-src_apps_ociolutimage_CMakeLists.txt
new file mode 100644
index 000000000000..056c7da954d2
--- /dev/null
+++ b/graphics/opencolorio/files/patch-src_apps_ociolutimage_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/apps/ociolutimage/CMakeLists.txt.orig 2012-04-18 09:38:16.000000000 +0930
++++ src/apps/ociolutimage/CMakeLists.txt 2012-06-21 20:40:39.147826612 +0930
+@@ -10,7 +10,7 @@
+
+ add_executable(ociolutimage ${share_src_files} main.cpp)
+
+- target_link_libraries(ociolutimage ${OIIO_LIBRARIES} OpenColorIO dl)
++ target_link_libraries(ociolutimage ${OIIO_LIBRARIES} OpenColorIO)
+
+ install(TARGETS ociolutimage DESTINATION ${CMAKE_INSTALL_EXEC_PREFIX}/bin)
+ endif()
diff --git a/graphics/opencolorio/files/patch-src_core_CMakeLists.txt b/graphics/opencolorio/files/patch-src_core_CMakeLists.txt
new file mode 100644
index 000000000000..019c31266307
--- /dev/null
+++ b/graphics/opencolorio/files/patch-src_core_CMakeLists.txt
@@ -0,0 +1,8 @@
+--- src/core/CMakeLists.txt.orig 2012-09-19 16:50:29.000000000 +0200
++++ src/core/CMakeLists.txt 2012-09-19 16:51:18.000000000 +0200
+@@ -90,4 +90,4 @@
+ configure_file(${CMAKE_SOURCE_DIR}/export/pkgconfig/OpenColorIO.pc.in
+ ${CMAKE_CURRENT_BINARY_DIR}/OpenColorIO.pc @ONLY)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/OpenColorIO.pc
+- DESTINATION ${CMAKE_INSTALL_EXEC_PREFIX}/lib${LIB_SUFFIX}/pkgconfig/)
++ DESTINATION ${CMAKE_INSTALL_EXEC_PREFIX}/libdata/pkgconfig/)
diff --git a/graphics/opencolorio/files/patch-src_core_Platform.h b/graphics/opencolorio/files/patch-src_core_Platform.h
new file mode 100644
index 000000000000..137c3547fae2
--- /dev/null
+++ b/graphics/opencolorio/files/patch-src_core_Platform.h
@@ -0,0 +1,12 @@
+--- src/core/Platform.h.orig 2012-06-21 20:18:57.343827187 +0930
++++ src/core/Platform.h 2012-06-21 20:20:38.915828064 +0930
+@@ -85,7 +85,9 @@
+
+ // linux/unix/posix
+ #include <stdlib.h>
++#if !defined(__FreeBSD__)
+ #include <alloca.h>
++#endif
+ #include <string.h>
+ #include <pthread.h>
+ // OS for spinlock