aboutsummaryrefslogtreecommitdiff
path: root/graphics/openimageio
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-07-17 09:07:32 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-07-17 09:17:59 +0000
commita8825ced6ef6b02befb50f332be4dd7c1b534c5a (patch)
tree96c7d11089499bb86b9a4d7d7f4b2a3f9d3ac980 /graphics/openimageio
parent8d67ee6b1b33edfb5dfb105bc33e58e88b773b2d (diff)
downloadports-a8825ced6ef6b02befb50f332be4dd7c1b534c5a.tar.gz
ports-a8825ced6ef6b02befb50f332be4dd7c1b534c5a.zip
graphics/*openimageio: chase Imath, update->2.2.16
openimageio upstream versions received lots of build fixes for Imath compatibility, so update to 2.2.16 from 2.2.13. (oiio 2.2.13 does not build with Imath 3.1.0) The patch fiddling is due to Ptex-related changes in openimageio's cmake build system, https://github.com/OpenImageIO/oiio/pull/3001 Changelogs (one document to read through): https://github.com/OpenImageIO/oiio/blob/v2.2.16.0/CHANGES.md#release-2216-1-jul-2021----compared-to-2215 or with clickable links to issues/merges: https://github.com/OpenImageIO/oiio/releases/tag/v2.2.16.0 https://github.com/OpenImageIO/oiio/releases/tag/v2.2.15.1 https://github.com/OpenImageIO/oiio/releases/tag/v2.2.15.0 https://github.com/OpenImageIO/oiio/releases/tag/v2.2.14.0
Diffstat (limited to 'graphics/openimageio')
-rw-r--r--graphics/openimageio/Makefile6
-rw-r--r--graphics/openimageio/distinfo6
-rw-r--r--graphics/openimageio/files/patch-src_cmake_modules_FindPtex.cmake (renamed from graphics/openimageio/files/patch-src_cmake_modules_FindPTex.cmake)4
-rw-r--r--graphics/openimageio/files/patch-src_libutil_ustring.cpp6
4 files changed, 11 insertions, 11 deletions
diff --git a/graphics/openimageio/Makefile b/graphics/openimageio/Makefile
index 6b7a3a927b74..650b82aae25f 100644
--- a/graphics/openimageio/Makefile
+++ b/graphics/openimageio/Makefile
@@ -2,12 +2,12 @@
PORTNAME= openimageio
DISTVERSIONPREFIX= Release-
-DISTVERSION= 2.2.13.1
+DISTVERSION= 2.2.16.0
# PORTREVISION must be set with ?= so as not to stomp over
# py-openimageio's PORTREVISION.
# Also, just to be on the safe side, when resetting,
# best keep PORTREVISION?= 0.
-PORTREVISION?= 5
+PORTREVISION?= 0
CATEGORIES?= graphics multimedia
MAINTAINER?= FreeBSD@Shaneware.biz
@@ -101,7 +101,7 @@ VDB_LIB_DEPENDS= libopenvdb.so:misc/openvdb
PLIST_SUB+= LIBVERS=${DISTVERSION:C/([0-9]*)\.([0-9]*)\.([0-9]*)(.*)/\1.\2.\3/}
post-patch:
- @${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE}," ${WRKSRC}/src/cmake/modules/FindPTex.cmake
+ @${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE}," ${WRKSRC}/src/cmake/modules/FindPtex.cmake
.include <bsd.port.options.mk>
diff --git a/graphics/openimageio/distinfo b/graphics/openimageio/distinfo
index a6d855710f57..9b8442a05f6d 100644
--- a/graphics/openimageio/distinfo
+++ b/graphics/openimageio/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1618069447
-SHA256 (OpenImageIO-oiio-Release-2.2.13.1_GH0.tar.gz) = 7f810124e866ac14ad9c11b0ab528a6ed4c8e62a190cc44a77eed8159f57405c
-SIZE (OpenImageIO-oiio-Release-2.2.13.1_GH0.tar.gz) = 29265740
+TIMESTAMP = 1626457176
+SHA256 (OpenImageIO-oiio-Release-2.2.16.0_GH0.tar.gz) = d1a59f32dbba3ba71ad2e62e107034d1c5287bca1b0696474e927d504cd05ef4
+SIZE (OpenImageIO-oiio-Release-2.2.16.0_GH0.tar.gz) = 29240993
diff --git a/graphics/openimageio/files/patch-src_cmake_modules_FindPTex.cmake b/graphics/openimageio/files/patch-src_cmake_modules_FindPtex.cmake
index 77bff523c2a0..3666e0a58ebe 100644
--- a/graphics/openimageio/files/patch-src_cmake_modules_FindPTex.cmake
+++ b/graphics/openimageio/files/patch-src_cmake_modules_FindPtex.cmake
@@ -1,5 +1,5 @@
---- src/cmake/modules/FindPTex.cmake.orig 2020-05-11 03:43:52 UTC
-+++ src/cmake/modules/FindPTex.cmake
+--- src/cmake/modules/FindPtex.cmake.orig 2021-07-01 18:54:28 UTC
++++ src/cmake/modules/FindPtex.cmake
@@ -70,6 +70,7 @@ else ()
PATHS
/usr/include
diff --git a/graphics/openimageio/files/patch-src_libutil_ustring.cpp b/graphics/openimageio/files/patch-src_libutil_ustring.cpp
index 1e71c22a807e..c54dc6a8c78f 100644
--- a/graphics/openimageio/files/patch-src_libutil_ustring.cpp
+++ b/graphics/openimageio/files/patch-src_libutil_ustring.cpp
@@ -1,6 +1,6 @@
---- src/libutil/ustring.cpp.orig 2020-01-27 21:27:51 UTC
+--- src/libutil/ustring.cpp.orig 2021-07-01 18:54:28 UTC
+++ src/libutil/ustring.cpp
-@@ -314,7 +314,7 @@ struct libcpp_string__long {
+@@ -308,7 +308,7 @@ struct libcpp_string__long {
std::string::size_type __size_;
std::string::size_type __cap_;
};
@@ -9,7 +9,7 @@
enum { libcpp_string__long_mask = 0x1ul };
# else // _LIBCPP_BIG_ENDIAN
enum { libcpp_string__long_mask = ~(std::string::size_type(~0) >> 1) };
-@@ -325,7 +325,7 @@ struct libcpp_string__long {
+@@ -319,7 +319,7 @@ struct libcpp_string__long {
std::string::size_type __size_;
std::string::pointer __data_;
};