aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Google-Chart
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-09 20:11:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-09 20:11:02 +0000
commitd53ed73a7fb813d6fab24dc75cdfd30cad02bfc7 (patch)
treea0358f741b3f8a746dc9c2ad20f0ca21c155c03f /graphics/p5-Google-Chart
parent0af225c1ad7942809ea843fa704e731bdf81bf53 (diff)
downloadports-d53ed73a7fb813d6fab24dc75cdfd30cad02bfc7.tar.gz
ports-d53ed73a7fb813d6fab24dc75cdfd30cad02bfc7.zip
p5-Google-Chart is a Perl interface to Google Charts API.
WWW: http://search.cpan.org/dist/Google-Chart/ PR: ports/131163 Submitted by: Wen Heping <wenheping at gmail.com>
Notes
Notes: svn path=/head/; revision=227940
Diffstat (limited to 'graphics/p5-Google-Chart')
-rw-r--r--graphics/p5-Google-Chart/Makefile44
-rw-r--r--graphics/p5-Google-Chart/distinfo3
-rw-r--r--graphics/p5-Google-Chart/pkg-descr3
-rw-r--r--graphics/p5-Google-Chart/pkg-plist43
4 files changed, 93 insertions, 0 deletions
diff --git a/graphics/p5-Google-Chart/Makefile b/graphics/p5-Google-Chart/Makefile
new file mode 100644
index 000000000000..3f0272780362
--- /dev/null
+++ b/graphics/p5-Google-Chart/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: p5-Google-Chart
+# Date created: 30 January 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Google-Chart
+PORTVERSION= 0.05013
+CATEGORIES= graphics perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Perl Interface to Google Charts API
+
+RUN_DEPENDS= p5-Class-MOP>=0.63:${PORTSDIR}/devel/p5-Class-MOP \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-Moose>=0.54:${PORTSDIR}/devel/p5-Moose \
+ p5-Scalar-List-Utils>0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-URI>0:${PORTSDIR}/net/p5-URI
+
+MAN3= Google::Chart.3 Google::Chart::Axis.3 \
+ Google::Chart::Axis::Item.3 Google::Chart::Axis::Style.3 \
+ Google::Chart::Color.3 Google::Chart::Data.3 \
+ Google::Chart::Data::Extended.3 Google::Chart::Data::Simple.3 \
+ Google::Chart::Data::Text.3 Google::Chart::Fill.3 \
+ Google::Chart::Fill::LinearGradient.3 \
+ Google::Chart::Fill::LinearStripes.3 \
+ Google::Chart::Fill::Solid.3 Google::Chart::Grid.3 \
+ Google::Chart::Legend.3 Google::Chart::Marker.3 \
+ Google::Chart::QueryComponent.3 \
+ Google::Chart::QueryComponent::Simple.3 \
+ Google::Chart::Size.3 Google::Chart::Title.3 \
+ Google::Chart::Type.3 Google::Chart::Type::Bar.3 \
+ Google::Chart::Type::Line.3 Google::Chart::Type::Pie.3 \
+ Google::Chart::Type::QRcode.3 Google::Chart::Type::Radar.3 \
+ Google::Chart::Type::ScatterPlot.3 Google::Chart::Type::Simple.3 \
+ Google::Chart::Type::SparkLine.3 Google::Chart::Type::Venn.3 \
+ Google::Chart::Types.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Google-Chart/distinfo b/graphics/p5-Google-Chart/distinfo
new file mode 100644
index 000000000000..759c0bc6887d
--- /dev/null
+++ b/graphics/p5-Google-Chart/distinfo
@@ -0,0 +1,3 @@
+MD5 (Google-Chart-0.05013.tar.gz) = 51b2d4da84a7a739124ff8ddbfce884e
+SHA256 (Google-Chart-0.05013.tar.gz) = a0d764cbdc6196fa1c3f1a7dc0408528309eb1ab3eecb73ddc03349d5f99da33
+SIZE (Google-Chart-0.05013.tar.gz) = 38545
diff --git a/graphics/p5-Google-Chart/pkg-descr b/graphics/p5-Google-Chart/pkg-descr
new file mode 100644
index 000000000000..374664e315bf
--- /dev/null
+++ b/graphics/p5-Google-Chart/pkg-descr
@@ -0,0 +1,3 @@
+p5-Google-Chart is a Perl interface to Google Charts API.
+
+WWW: http://search.cpan.org/dist/Google-Chart/
diff --git a/graphics/p5-Google-Chart/pkg-plist b/graphics/p5-Google-Chart/pkg-plist
new file mode 100644
index 000000000000..f3565937f58f
--- /dev/null
+++ b/graphics/p5-Google-Chart/pkg-plist
@@ -0,0 +1,43 @@
+%%SITE_PERL%%/Google/Chart.pm
+%%SITE_PERL%%/Google/Chart/Marker.pm
+%%SITE_PERL%%/Google/Chart/Size.pm
+%%SITE_PERL%%/Google/Chart/Color.pm
+%%SITE_PERL%%/Google/Chart/Axis.pm
+%%SITE_PERL%%/Google/Chart/Title.pm
+%%SITE_PERL%%/Google/Chart/Type.pm
+%%SITE_PERL%%/Google/Chart/Types.pm
+%%SITE_PERL%%/Google/Chart/QueryComponent.pm
+%%SITE_PERL%%/Google/Chart/Grid.pm
+%%SITE_PERL%%/Google/Chart/Legend.pm
+%%SITE_PERL%%/Google/Chart/Data.pm
+%%SITE_PERL%%/Google/Chart/Fill.pm
+%%SITE_PERL%%/Google/Chart/Type/Bar.pm
+%%SITE_PERL%%/Google/Chart/Type/Line.pm
+%%SITE_PERL%%/Google/Chart/Type/QRcode.pm
+%%SITE_PERL%%/Google/Chart/Type/Venn.pm
+%%SITE_PERL%%/Google/Chart/Type/Pie.pm
+%%SITE_PERL%%/Google/Chart/Type/Radar.pm
+%%SITE_PERL%%/Google/Chart/Type/ScatterPlot.pm
+%%SITE_PERL%%/Google/Chart/Type/SparkLine.pm
+%%SITE_PERL%%/Google/Chart/Type/Simple.pm
+%%SITE_PERL%%/Google/Chart/Axis/Item.pm
+%%SITE_PERL%%/Google/Chart/Axis/Style.pm
+%%SITE_PERL%%/Google/Chart/Data/Simple.pm
+%%SITE_PERL%%/Google/Chart/Data/Text.pm
+%%SITE_PERL%%/Google/Chart/Data/Extended.pm
+%%SITE_PERL%%/Google/Chart/QueryComponent/Simple.pm
+%%SITE_PERL%%/Google/Chart/Fill/LinearGradient.pm
+%%SITE_PERL%%/Google/Chart/Fill/Solid.pm
+%%SITE_PERL%%/Google/Chart/Fill/LinearStripes.pm
+@dirrm %%SITE_PERL%%/Google/Chart/Type
+@dirrm %%SITE_PERL%%/Google/Chart/Fill
+@dirrm %%SITE_PERL%%/Google/Chart/QueryComponent
+@dirrm %%SITE_PERL%%/Google/Chart/Data
+@dirrm %%SITE_PERL%%/Google/Chart/Axis
+@dirrm %%SITE_PERL%%/Google/Chart
+@dirrmtry %%SITE_PERL%%/Google
+%%SITE_PERL%%/mach/auto/Google/Chart/.packlist
+@dirrm %%SITE_PERL%%/mach/auto/Google/Chart
+@dirrm %%SITE_PERL%%/mach/auto/Google
+@dirrmtry %%SITE_PERL%%/mach/auto
+@dirrmtry %%SITE_PERL%%/mach