aboutsummaryrefslogtreecommitdiff
path: root/graphics/poppler/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /graphics/poppler/Makefile
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'graphics/poppler/Makefile')
-rw-r--r--graphics/poppler/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/graphics/poppler/Makefile b/graphics/poppler/Makefile
index c00aa8ac9d52..840d27982291 100644
--- a/graphics/poppler/Makefile
+++ b/graphics/poppler/Makefile
@@ -64,7 +64,8 @@ CONFIGURE_ARGS+=--disable-poppler-glib
.if ${SLAVEPORT}==qt4
CONFIGURE_ARGS+=--enable-poppler-qt4
CONFIGURE_ENV+= MOCQT4=${MOC}
-USE_QT4= gui corelib xml qtestlib moc_build
+USES+= qt:4
+USE_QT= gui corelib xml qtestlib moc_build
BUILD_WRKSRC= ${WRKSRC}/qt4
INSTALL_WRKSRC= ${WRKSRC}/qt4
.else
@@ -74,7 +75,8 @@ CONFIGURE_ARGS+=--disable-poppler-qt4
.if ${SLAVEPORT}==qt5
CONFIGURE_ARGS+=--enable-poppler-qt5
CONFIGURE_ENV+= MOCQT5=${MOC}
-USE_QT5= core gui widgets xml buildtools_build testlib_build
+USES+= qt:5
+USE_QT= core gui widgets xml buildtools_build testlib_build
# Qt from 5.7.0 on requires c++11.
USE_CXXSTD= c++11
BUILD_WRKSRC= ${WRKSRC}/qt5