aboutsummaryrefslogtreecommitdiff
path: root/graphics/povray37/Makefile
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-07-07 11:00:16 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-07-07 11:00:16 +0000
commit760887f574c626b100fae4a7847c818de717400a (patch)
tree730467251549782ea3af82591a9310b7a0604d49 /graphics/povray37/Makefile
parentc321a67c68929c2d789895d77dbb1e118ec54f23 (diff)
downloadports-760887f574c626b100fae4a7847c818de717400a.tar.gz
ports-760887f574c626b100fae4a7847c818de717400a.zip
graphics/povray37: Update to 3.7.0.8
- Fixes build with Clang 6 - Reset maintainer after not responding for > 6 months - While here add license and sort variables Changes: https://github.com/POV-Ray/povray/releases/ PR: 215473 Submitted by: Andrey Zholos <aaz@q-fu.com>, Chad Jacob Milios <milios@ccsys.com> Approved by: bkoenig@alpha-tierchen.de (maintainer timeout, > 6 months)
Notes
Notes: svn path=/head/; revision=474071
Diffstat (limited to 'graphics/povray37/Makefile')
-rw-r--r--graphics/povray37/Makefile91
1 files changed, 35 insertions, 56 deletions
diff --git a/graphics/povray37/Makefile b/graphics/povray37/Makefile
index 8b189c4e5261..17e5ab86eb29 100644
--- a/graphics/povray37/Makefile
+++ b/graphics/povray37/Makefile
@@ -1,47 +1,48 @@
# $FreeBSD$
PORTNAME= povray
-DISTVERSION= 3.7.0.RC6
-PORTREVISION= 14
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.7.0.8
CATEGORIES= graphics
-MASTER_SITES= http://www.povray.org/beta/source/
PKGNAMESUFFIX= 37
-DIST_SUBDIR= ${PORTNAME}${PKGNAMESUFFIX}
-MAINTAINER= bkoenig@alpha-tierchen.de
+MAINTAINER= ports@FreeBSD.org
COMMENT= Persistence of Vision Ray Tracer
-LIB_DEPENDS= libboost_thread.so:devel/boost-libs
+LICENSE= AGPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_powerpc64= Does not build: c++: Internal error: Killed (program cc1plus)
-OPTIONS_DEFINE= X11 PNG JPEG TIFF OPENEXR STATIC IO EXAMPLES DOCS
-OPTIONS_DEFAULT=PNG JPEG
-OPTIONS_SUB= yes
-IO_DESC= Without I/O restrictions (security risk)
-EXAMPLES_DESC= Install example scenes
-DOCS_DESC= Install HTML documentation
+LIB_DEPENDS= libboost_thread.so:devel/boost-libs
+
+USES= autoreconf:build gmake
+USE_GITHUB= yes
+GH_ACCOUNT= POV-Ray
-USES= gmake localbase
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= COMPILED_BY=${MAINTAINER} \
+ --program-transform-name='s/povray/${PKGBASE}/' \
+ --disable-optimiz
VERSION_BASE= ${PORTVERSION:C/([0-9]+\.[0-9]+).*/\1/}
-
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${VERSION_BASE}
-EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}-${VERSION_BASE}
DATADIR= ${PREFIX}/share/${PORTNAME}-${VERSION_BASE}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${VERSION_BASE}
ETCDIR= ${PREFIX}/etc/${PORTNAME}/${VERSION_BASE}
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}-${VERSION_BASE}
-LIBS+= -lboost_system
+OPTIONS_DEFINE= X11 PNG JPEG TIFF OPENEXR STATIC IO EXAMPLES DOCS
+OPTIONS_DEFAULT=PNG JPEG
+OPTIONS_SUB= yes
-CONFIGURE_ARGS= COMPILED_BY=${MAINTAINER} \
- --program-transform-name='s/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/' \
- --disable-optimiz
+DOCS_DESC= Install HTML documentation
+EXAMPLES_DESC= Install example scenes
+IO_DESC= Without I/O restrictions (security risk)
+IO_CONFIGURE_ON= --disable-io-restrictions
+STATIC_CONFIGURE_ON= --enable-static
X11_USE= XORG=xpm,sm,ice,x11 SDL=sdl
X11_CONFIGURE_OFF= --without-x
-STATIC_CONFIGURE_ON= --enable-static
-IO_CONFIGURE_ON= --disable-io-restrictions
.include <bsd.port.options.mk>
@@ -90,49 +91,27 @@ CONFIGURE_ARGS+=--without-openexr
CONFIGURE_ARGS+=NON_REDISTRIBUTABLE_BUILD=yes
.endif
-DOC_FILES= AUTHORS ChangeLog NEWS
PORTDOCS= *
PORTEXAMPLES= *
post-patch:
-# Fix with boost 1.52 and now boost 1.55
- @${REINPLACE_CMD} -e 's/TIME_UTC/TIME_UTC_/g' ${WRKSRC}/source/backend/scene/view.cpp \
- ${WRKSRC}/source/base/timer.cpp \
- ${WRKSRC}/vfe/vfepovms.cpp \
- ${WRKSRC}/vfe/unix/platformbase.cpp \
- ${WRKSRC}/vfe/vfesession.cpp
- @${FIND} ${WRKSRC}/source/*end \( -name \*.h -o -name \*.cpp \) | \
- ${XARGS} ${GREP} -l shared_ptr | ${SED} '/shellout/d' | \
- ${XARGS} ${REINPLACE_CMD} -e 's|shared_ptr|boost::shared_ptr|g'
+ ${REINPLACE_CMD} -e 's|@@EXAMPLESDIR@@|${EXAMPLESDIR}|' \
+ -e 's|@@ETCDIR@@|${ETCDIR}|' \
+ ${WRKSRC}/unix/povray.conf
+
+pre-configure:
+ cd ${WRKSRC}/unix && ./prebuild.sh
pre-build:
.if ${PORT_OPTIONS:MSTATIC} && ${PORT_OPTIONS:MTIFF}
-# graphics/tiff adds dependencies on libjpeg and libjbig
- @${REINPLACE_CMD} -e 's,^\(LIBS = .*\)-ltiff\(.*\),\1-ltiff -ljpeg -ljbig\2,' ${WRKSRC}/unix/Makefile
+# graphics/tiff adds dependencies on libjpeg, libjbig and liblzma
+ @${REINPLACE_CMD} -e 's,^\(LIBS = .*\)-ltiff\(.*\),\1-ltiff -ljpeg -ljbig -llzma\2,' ${WRKSRC}/unix/Makefile
.endif
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/unix/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/${PORTNAME}${PKGNAMESUFFIX}.1
- @${MKDIR} ${STAGEDIR}${ETCDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${STAGEDIR}${ETCDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.ini ${STAGEDIR}${ETCDIR}
-.for i in include ini scripts
- ${MKDIR} ${STAGEDIR}${DATADIR}/$i
- cd ${WRKSRC}/$i && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/$i
+post-install:
+ ${MV} ${STAGEDIR}${DATADIR}/scenes ${STAGEDIR}${EXAMPLESDIR}
+.for i in povray.conf povray.ini
+ ${MV} ${STAGEDIR}${ETCDIR}/${i} ${STAGEDIR}${ETCDIR}/${i}.sample
.endfor
-do-install-X11-on:
- @${MKDIR} ${STAGEDIR}${DATADIR}/icons
- cd ${WRKSRC}/icons && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/icons
-
-do-install-EXAMPLES-on:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- cd ${WRKSRC}/scenes && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
-
-do-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOC_FILES} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
-
.include <bsd.port.mk>