aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-opencv
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2016-09-23 22:45:02 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2016-09-23 22:45:02 +0000
commit16a147efd11807adfcaed38c539fb00904944852 (patch)
tree3d62a1e461f7a69157e704859cf7aa438f389bd7 /graphics/py-opencv
parent1cbd3576d5c61de441cb731ffcde9fc791088d83 (diff)
downloadports-16a147efd11807adfcaed38c539fb00904944852.tar.gz
ports-16a147efd11807adfcaed38c539fb00904944852.zip
graphics/py-opencv: limit python version to 2.x
Python module of OpenCV 2.4.9 is not compatible with Python 3.x - both on cmake infrastructure level and on module itself level, so just mark it as Python 2.x only and remove all the python3 shims - they are don't make any difference anyway. We can patch that hardly to make it work, but it's better to just update to latest version that have python3 support out of the box. PR: 204519 (for tracking)
Notes
Notes: svn path=/head/; revision=422698
Diffstat (limited to 'graphics/py-opencv')
-rw-r--r--graphics/py-opencv/Makefile9
-rw-r--r--graphics/py-opencv/pkg-plist6
2 files changed, 2 insertions, 13 deletions
diff --git a/graphics/py-opencv/Makefile b/graphics/py-opencv/Makefile
index 77b0a0d7c295..c4b156385c22 100644
--- a/graphics/py-opencv/Makefile
+++ b/graphics/py-opencv/Makefile
@@ -12,13 +12,4 @@ OCV_PYTHON= yes
MASTERDIR= ${.CURDIR:H}/opencv
PLIST= ${.CURDIR}/pkg-plist
-.if defined(PYTHON_REL) && ${PYTHON_REL} >= 3200
-PLIST_SUB+= PYTHON3="" \
- PYTHON2="@comment " \
- PYTHON_SUFFIX="${PYTHON_SUFFIX}"
-.else
-PLIST_SUB+= PYTHON3="@comment " \
- PYTHON2=""
-.endif
-
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/py-opencv/pkg-plist b/graphics/py-opencv/pkg-plist
index 10122aa92232..cc41f22ca9c3 100644
--- a/graphics/py-opencv/pkg-plist
+++ b/graphics/py-opencv/pkg-plist
@@ -1,6 +1,4 @@
%%PYTHON_SITELIBDIR%%/cv.py
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/cv.pyc
-%%PYTHON2%%%%PYTHON_SITELIBDIR%%/cv.pyo
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/__pycache__/cv.cpython-%%PYTHON_SUFFIX%%.pyc
-%%PYTHON3%%%%PYTHON_SITELIBDIR%%/__pycache__/cv.cpython-%%PYTHON_SUFFIX%%.pyo
+%%PYTHON_SITELIBDIR%%/cv.pyc
+%%PYTHON_SITELIBDIR%%/cv.pyo
%%PYTHON_SITELIBDIR%%/cv2.so