aboutsummaryrefslogtreecommitdiff
path: root/graphics/qcomicbook/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2005-05-27 21:38:42 +0000
committerPatrick Li <pat@FreeBSD.org>2005-05-27 21:38:42 +0000
commit3f9322712a9781e51c0c4cca36b85318a164413d (patch)
tree875b1332e0ae8e8161c0d2d82a617831c052e241 /graphics/qcomicbook/Makefile
parent267cb82866ca9f1141a39f81b0b30de9a3e05a71 (diff)
downloadports-3f9322712a9781e51c0c4cca36b85318a164413d.tar.gz
ports-3f9322712a9781e51c0c4cca36b85318a164413d.zip
Update to 0.2.1
(anyone want to make this DATADIR safe?) PR: ports/81510 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=136300
Diffstat (limited to 'graphics/qcomicbook/Makefile')
-rw-r--r--graphics/qcomicbook/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/graphics/qcomicbook/Makefile b/graphics/qcomicbook/Makefile
index c82e50f30919..df1068771991 100644
--- a/graphics/qcomicbook/Makefile
+++ b/graphics/qcomicbook/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qcomicbook
-PORTVERSION= 0.2.0
+PORTVERSION= 0.2.1
CATEGORIES= graphics
MASTER_SITES= http://linux.bydg.org/~yogin/
@@ -18,21 +18,20 @@ RUN_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
USE_X_PREFIX= yes
USE_QT_VER= 3
-
-GNU_CONFIGURE= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS+=--with-Qt-dir="${X11BASE}"
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-Qt-dir="${QT_PREFIX}"
+
+MAN1= qcomicbook.1
+
# Luckily, QT apps on FreeBSD don't compile against
# pthread by default. That might *gasp* make them work!
QTCPPFLAGS+= ${PTHREAD_CFLAGS}
QTCFGLIBS+= ${PTHREAD_LIBS}
-MAN1= qcomicbook.1
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Configure fails on FreeBSD 4.x"
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|="failure"|=""|g' ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>