aboutsummaryrefslogtreecommitdiff
path: root/graphics/sane-backends/Makefile
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-01-29 12:31:51 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-01-29 12:31:51 +0000
commit9088421f9e0b9e80eeb324b2c41acd2125a63c84 (patch)
tree56944404b9aea136917c73574ccf3ce2d0b83e92 /graphics/sane-backends/Makefile
parent803d412667d031a58499133fb5f1669a1b060410 (diff)
downloadports-9088421f9e0b9e80eeb324b2c41acd2125a63c84.tar.gz
ports-9088421f9e0b9e80eeb324b2c41acd2125a63c84.zip
graphics/sane-backends: Actually update to 1.0.27
The current version is 1.0.25 with a wrongly named distfile which fails to fetch from the fossies.org mirror with a size mismatch. The update to 1.0.27 in r444767 also shows that the checksum and size have not changed in distinfo in that commit. Full changes between the distfiles from 1.0.27_4 & 1.0.27_5 can be found at [1]. - Remove dead alioth.debian.org mirror - Remove some no longer needed patches [1] https://people.freebsd.org/~tobik/logs/sane-backends-1.0.27.diff ABI: https://abi-laboratory.pro/tracker/timeline/sane-backends/ PR: 229653 Submitted by: Peter Wullinger <freebsd@dhke.de>
Notes
Notes: svn path=/head/; revision=491557
Diffstat (limited to 'graphics/sane-backends/Makefile')
-rw-r--r--graphics/sane-backends/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index 6faeddc6138b..5dd51b2a99d5 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -3,10 +3,9 @@
PORTNAME= sane-backends
PORTVERSION= 1.0.27
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
-MASTER_SITES= https://alioth.debian.org/frs/download.php/file/4146/ \
- http://fossies.org/linux/misc/
+MASTER_SITES= http://fossies.org/linux/misc/
MAINTAINER= ports@FreeBSD.org
COMMENT= API for access to scanners, digitals camera, frame grabbers etc
@@ -18,21 +17,19 @@ LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff
USES= gmake jpeg libtool localbase pathfix pkgconfig
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-docdir=${DOCSDIR} \
- --disable-latex \
- --disable-locking \
+CONFIGURE_ARGS= --disable-locking \
--enable-pthread \
--without-systemd
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
USE_RC_SUBR= saned
-WRKSRC= ${WRKDIR}/${PORTNAME}-1.0.25
SUB_FILES= pkg-message
-USERS= saned
-GROUPS= saned
+USERS= saned
+GROUPS= saned
PORTDOCS= *
@@ -40,21 +37,22 @@ OPTIONS_DEFINE= AVAHI DOCS GPHOTO IEEE1284 IPV6 NLS SNMP USB V4L
OPTIONS_DEFAULT= USB
OPTIONS_SUB= yes
+IEEE1284_DESC= Parallel port support via libieee1284
+USB_DESC= USB support
+
AVAHI_LIB_DEPENDS= libavahi-client.so:net/avahi-app
AVAHI_CONFIGURE_ENABLE= avahi
GPHOTO_LIB_DEPENDS= libgphoto2.so:graphics/libgphoto2
GPHOTO_CONFIGURE_OFF= --with-gphoto2=no
-IEEE1284_DESC= Parallel port support via libieee1284
IEEE1284_LIB_DEPENDS= libieee1284.so:sysutils/libieee1284
IEEE1284_CONFIGURE_ENV_OFF= sane_cv_use_libieee1284=no
IPV6_CONFIGURE_ENABLE= ipv6
NLS_USES= gettext
-NLS_CONFIGURE_ENABLE= translations
+NLS_CONFIGURE_ENABLE= nls
SNMP_LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp
SNMP_CONFIGURE_WITH= snmp
-USB_DESC= USB support
-USB_CONFIGURE_ON= --enable-libusb_1_0
-USB_CONFIGURE_OFF= --enable-libusb=no
+USB_CONFIGURE_ON= --with-usb
+USB_CONFIGURE_OFF= --with-usb=no
V4L_LIB_DEPENDS= libv4l1.so:multimedia/libv4l
V4L_CONFIGURE_WITH= v4l