aboutsummaryrefslogtreecommitdiff
path: root/graphics/sane-backends/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2004-08-22 11:24:34 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2004-08-22 11:24:34 +0000
commite59fb64cbf9731733d1fa5583f48b8a02d43f298 (patch)
tree8760363c508b7a294d833cf43bbd86fd6323bb25 /graphics/sane-backends/Makefile
parent2e57b8e0dc450b3f87d751de5dd82341d71d1c3c (diff)
downloadports-e59fb64cbf9731733d1fa5583f48b8a02d43f298.tar.gz
ports-e59fb64cbf9731733d1fa5583f48b8a02d43f298.zip
- add OPTION (WITHOUT_)USB
- make use of DOCSDIR - Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=117014
Diffstat (limited to 'graphics/sane-backends/Makefile')
-rw-r--r--graphics/sane-backends/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index 77cabfebb109..6659c1eda548 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sane-backends
PORTVERSION= 1.0.14
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.no.mostang.com/pub/sane/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME}-${PORTVERSION}
@@ -14,22 +15,31 @@ MASTER_SITE_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= API for access to scanners, digitals camera, frame grabbers etc
-LIB_DEPENDS= usb-0.1.7:${PORTSDIR}/devel/libusb \
- jpeg.9:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
USE_GNOME= gnometarget lthack
USE_GMAKE= yes
USE_LIBTOOL_VER= 13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-MAKE_ENV= NOPORTDOCS=${NOPORTDOCS}
+MAKE_ENV= NOPORTDOCS=${NOPORTDOCS} \
+ DOCSDIR="${DOCSDIR}"
INSTALLS_SHLIB= yes
-OPTIONS= NLS "NLS support" on \
+OPTIONS= USB "USB support" on \
+ NLS "NLS support" on \
GPHOTO2 "gPhoto2 support" off
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_USB)
+CONFIGURE_ARGS+= --disable-libusb
+PLIST_SUB+= USB="@comment "
+.else
+LIB_DEPENDS+= usb-0.1.7:${PORTSDIR}/devel/libusb
+PLIST_SUB+= USB=""
+.endif
+
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-translations
PLIST_SUB+= NLS="@comment "