aboutsummaryrefslogtreecommitdiff
path: root/graphics/sane-backends
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2012-12-20 05:40:01 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2012-12-20 05:40:01 +0000
commit0d5f28b877e4dcd33ab8faa4a71ff0cfc18f86a5 (patch)
treef79b7cb18dfc15d57b2bbf9e9e4d7083fd1348ef /graphics/sane-backends
parent3cb888567e519135a2aa2d823243e9f7a72d9f25 (diff)
downloadports-0d5f28b877e4dcd33ab8faa4a71ff0cfc18f86a5.tar.gz
ports-0d5f28b877e4dcd33ab8faa4a71ff0cfc18f86a5.zip
- Update to 1.0.23.
- Add MAKE_JOBS_SAFE. - Trim header. PR: ports/172022 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=309282
Diffstat (limited to 'graphics/sane-backends')
-rw-r--r--graphics/sane-backends/Makefile66
-rw-r--r--graphics/sane-backends/Makefile.man2
-rw-r--r--graphics/sane-backends/distinfo8
-rw-r--r--graphics/sane-backends/files/patch-Makefile.in45
-rw-r--r--graphics/sane-backends/files/patch-backend-xerox_mfp.c73
-rw-r--r--graphics/sane-backends/files/patch-backend__epson2-commands.c10
-rw-r--r--graphics/sane-backends/files/patch-backend__epson2.c11
-rw-r--r--graphics/sane-backends/files/patch-backend__kodakaio.c13
-rw-r--r--graphics/sane-backends/files/patch-backend__kvs40xx.h19
-rw-r--r--graphics/sane-backends/files/patch-backend__kvs40xx_opt.c10
-rw-r--r--graphics/sane-backends/files/patch-backend__magicolor.c11
-rw-r--r--graphics/sane-backends/files/patch-backend__niash.c24
-rw-r--r--graphics/sane-backends/files/patch-backend__xerox_mfp-tcp.c11
-rw-r--r--graphics/sane-backends/files/patch-doc_Makefile.in60
-rw-r--r--graphics/sane-backends/files/patch-frontend__Makefile.in11
-rw-r--r--graphics/sane-backends/files/patch-include_sane_sanei_tcp.h10
-rw-r--r--graphics/sane-backends/files/patch-sanei_sanei_usb.c21
-rw-r--r--graphics/sane-backends/pkg-plist9
18 files changed, 125 insertions, 289 deletions
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index f3b64087fa79..ad3725f5e1f1 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -1,17 +1,17 @@
-# New ports collection makefile for: sane-backends
-# Date created: Sat Jul 19 16:23:10 MET DST 1997
-# Whom: gary@hotlava.com
-#
+# Created by: gary@hotlava.com
# $FreeBSD$
-#
PORTNAME= sane-backends
-PORTVERSION= 1.0.22
-PORTREVISION= 2
+PORTVERSION= 1.0.23
CATEGORIES= graphics
-MASTER_SITES= http://alioth.debian.org/frs/download.php/3503/ \
- ftp://ftp2.sane-project.org/pub/sane/%SUBDIR%/
-MASTER_SITE_SUBDIR= ${PORTNAME}-${PORTVERSION}
+MASTER_SITES= http://alioth.debian.org/frs/download.php/3752/:3752 \
+ http://alioth.debian.org/frs/download.php/3753/:3753 \
+ http://alioth.debian.org/frs/download.php/3754/:3754 \
+ ftp://ftp2.sane-project.org/pub/sane/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}.1:3752,DEFAULT \
+ ${DISTNAME}${EXTRACT_SUFX}.2:3753,DEFAULT \
+ ${DISTNAME}${EXTRACT_SUFX}.3:3754,DEFAULT
+EXTRACT_ONLY= # need to concatenate before extraction
MAINTAINER= ports@FreeBSD.org
COMMENT= API for access to scanners, digitals camera, frame grabbers etc
@@ -22,21 +22,23 @@ LICENSE_COMB= dual
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
-OPTIONS_DEFINE= USB NLS GPHOTO2 SNMP AVAHI IEEE1284 IPV6 DOCS
+OPTIONS_DEFINE= USB GPHOTO2 SNMP AVAHI IEEE1284 IPV6 DOCS
OPTIONS_DEFAULT= USB
USB_DESC= USB support
GPHOTO2_DESC= gPhoto2 support
IEEE1284_DESC= libieee1284 support
+USE_GNOME= gnomehack
+USE_PKGCONFIG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-docdir=${DOCSDIR} \
+CONFIGURE_ARGS= --with-docdir=${WRKDIR}/tmproot \
--disable-latex \
--disable-locking \
--enable-pthread
USE_LDCONFIG= yes
-MAKE_JOBS_UNSAFE= yes
+MAKE_JOBS_SAFE= yes
USE_RC_SUBR= saned
SUB_FILES+= pkg-message
@@ -50,13 +52,9 @@ LDFLAGS+= -L${LOCALBASE}/lib
.include "Makefile.man"
.include <bsd.port.pre.mk>
-.if empty(PORT_OPTIONS:MDOCS)
-MAKE_ENV+= NOPORTDOCS=1
-.endif
-
.if ${PORT_OPTIONS:MUSB}
.if ${OSVERSION} < 800069
-LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
.endif
.else
CONFIGURE_ARGS+= --disable-libusb
@@ -75,7 +73,7 @@ CONFIGURE_ARGS+= --disable-ipv6
.endif
.if ${PORT_OPTIONS:MGPHOTO2}
-LIB_DEPENDS+= gphoto2.2:${PORTSDIR}/graphics/libgphoto2
+LIB_DEPENDS+= gphoto2:${PORTSDIR}/graphics/libgphoto2
MAN5+= sane-gphoto2.5
PLIST_SUB+= GPHOTO2=""
.else
@@ -84,29 +82,49 @@ PLIST_SUB+= GPHOTO2="@comment "
.endif
.if ${PORT_OPTIONS:MSNMP}
-LIB_DEPENDS+= netsnmp.30:${PORTSDIR}/net-mgmt/net-snmp
+LIB_DEPENDS+= netsnmp:${PORTSDIR}/net-mgmt/net-snmp
.else
CONFIGURE_ARGS+= --without-snmp
.endif
.if ${PORT_OPTIONS:MAVAHI}
-LIB_DEPENDS+= avahi-client.3:${PORTSDIR}/net/avahi-app
+LIB_DEPENDS+= avahi-client:${PORTSDIR}/net/avahi-app
CONFIGURE_ARGS+= --enable-avahi
.endif
.if ${PORT_OPTIONS:MIEEE1284}
-LIB_DEPENDS+= ieee1284.5:${PORTSDIR}/sysutils/libieee1284
+LIB_DEPENDS+= ieee1284:${PORTSDIR}/sysutils/libieee1284
PLIST_SUB+= IEEE1284=""
+MAN5+= sane-canon_pp.5 sane-hpsj5s.5 sane-mustek_pp.5
.else
CONFIGURE_ENV+= sane_cv_use_libieee1284=no
PLIST_SUB+= IEEE1284="@comment "
.endif
+.if ${PORT_OPTIONS:MCUPS}
+LIB_DEPENDS+= cups:${PORTSDIR}/print/cups-client
+.else
+CONFIGURE_ENV+= ac_cv_header_cups_cups_h=no
+.endif
+
+post-extract:
+ @((cd ${DISTDIR} && ${CAT} ${DISTFILES:C/:[^:]+$//}) | (cd ${WRKDIR} \
+ && ${EXTRACT_CMD} ${EXTRACT_BEFOR_ARGS} ${EXTRACT_AFTER_ARGS}))
+
post-patch:
- @${REINPLACE_CMD} -e '/^for ac_header in/s|libc.h||g ; \
- s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/^for ac_header in/s|libc.h|cups/cups.h| ; \
+ s|-e .*/cups.h|"$$ac_cv_header_cups_cups_h" = "yes"| ; \
+ s|-pthread|${PTHREAD_LIBS}|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/^dist_doc_DATA/s|COPYING||' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^pkgconfigdir/s|@libdir@|@prefix@/libdata|' \
+ ${WRKSRC}/tools/Makefile.in
post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKDIR}/tmproot && ${COPYTREE_SHARE} . ${DOCSDIR})
+.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/graphics/sane-backends/Makefile.man b/graphics/sane-backends/Makefile.man
index 5c78451526be..4cefb1578829 100644
--- a/graphics/sane-backends/Makefile.man
+++ b/graphics/sane-backends/Makefile.man
@@ -38,8 +38,10 @@ MAN5+= sane-hpljm1005.5
MAN5+= sane-hs2p.5
MAN5+= sane-ibm.5
MAN5+= sane-kodak.5
+MAN5+= sane-kodakaio.5
MAN5+= sane-kvs1025.5
MAN5+= sane-kvs20xx.5
+MAN5+= sane-kvs40xx.5
MAN5+= sane-leo.5
MAN5+= sane-lexmark.5
MAN5+= sane-ma1509.5
diff --git a/graphics/sane-backends/distinfo b/graphics/sane-backends/distinfo
index b0b261b7b4b3..20c5e10ca03d 100644
--- a/graphics/sane-backends/distinfo
+++ b/graphics/sane-backends/distinfo
@@ -1,2 +1,6 @@
-SHA256 (sane-backends-1.0.22.tar.gz) = 9f84a16800497f0b79a278531bb1a0f438de6ce8cf509fefc65a252e29f90c54
-SIZE (sane-backends-1.0.22.tar.gz) = 5150661
+SHA256 (sane-backends-1.0.23.tar.gz.1) = 551d7e0c89d18ca438bfce4f1c242b59485195c493c5f935a3b11e724ee39537
+SIZE (sane-backends-1.0.23.tar.gz.1) = 1792000
+SHA256 (sane-backends-1.0.23.tar.gz.2) = b487df0d8dc921803577ee34ceaa676a4a3b6715cd4d9a229b43d6a501a1baab
+SIZE (sane-backends-1.0.23.tar.gz.2) = 1792000
+SHA256 (sane-backends-1.0.23.tar.gz.3) = af91e84cb72dc2b1fa4c7eaba948ae6ab8e2ab353f79805a21de4ac52de5b81a
+SIZE (sane-backends-1.0.23.tar.gz.3) = 1758350
diff --git a/graphics/sane-backends/files/patch-Makefile.in b/graphics/sane-backends/files/patch-Makefile.in
deleted file mode 100644
index d339911d056b..000000000000
--- a/graphics/sane-backends/files/patch-Makefile.in
+++ /dev/null
@@ -1,45 +0,0 @@
---- Makefile.in.orig 2010-04-14 09:52:59.000000000 +0900
-+++ Makefile.in 2010-05-10 21:48:54.000000000 +0900
-@@ -82,7 +82,6 @@
- am__base_list = \
- sed '$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\n/ /g' | \
- sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
--am__installdirs = "$(DESTDIR)$(docdir)"
- DATA = $(dist_doc_DATA)
- RECURSIVE_CLEAN_TARGETS = mostlyclean-recursive clean-recursive \
- distclean-recursive maintainer-clean-recursive
-@@ -292,7 +291,7 @@
- top_srcdir = @top_srcdir@
- SUBDIRS = include lib sanei backend frontend tools doc po
- DIST_SUBDIRS = include lib sanei backend frontend tools doc po japi testsuite
--dist_doc_DATA = AUTHORS ChangeLog COPYING LICENSE NEWS PROBLEMS PROJECTS \
-+dist_doc_DATA = AUTHORS ChangeLog LICENSE NEWS PROBLEMS PROJECTS \
- README README.aix README.beos README.darwin README.djpeg README.freebsd \
- README.hp-ux README.linux README.netbsd README.openbsd README.os2 \
- README.solaris README.unixware2 README.unixware7 README.windows \
-@@ -375,6 +374,7 @@
- distclean-libtool:
- -rm -f libtool config.lt
- install-dist_docDATA: $(dist_doc_DATA)
-+ifndef NOPORTDOCS
- @$(NORMAL_INSTALL)
- test -z "$(docdir)" || $(MKDIR_P) "$(DESTDIR)$(docdir)"
- @list='$(dist_doc_DATA)'; test -n "$(docdir)" || list=; \
-@@ -386,6 +386,7 @@
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(docdir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(docdir)" || exit $$?; \
- done
-+endif
-
- uninstall-dist_docDATA:
- @$(NORMAL_UNINSTALL)
-@@ -710,9 +711,6 @@
- all-am: Makefile $(DATA)
- installdirs: installdirs-recursive
- installdirs-am:
-- for dir in "$(DESTDIR)$(docdir)"; do \
-- test -z "$$dir" || $(MKDIR_P) "$$dir"; \
-- done
- install: install-recursive
- install-exec: install-exec-recursive
- install-data: install-data-recursive
diff --git a/graphics/sane-backends/files/patch-backend-xerox_mfp.c b/graphics/sane-backends/files/patch-backend-xerox_mfp.c
deleted file mode 100644
index b7f2fcb3a071..000000000000
--- a/graphics/sane-backends/files/patch-backend-xerox_mfp.c
+++ /dev/null
@@ -1,73 +0,0 @@
-From 5ea227caeacd504b64eef301e83fa63e0a25b3f7 Mon Sep 17 00:00:00 2001
-From: Alex Belkin <abc@telekom.ru>
-Date: Tue, 8 Mar 2011 17:57:19 +0300
-Subject: [PATCH] keep usb device by default (correct for bug introduced by tcp sub-backend
-
----
- backend/xerox_mfp.c | 27 +++++++++++----------------
- 1 files changed, 11 insertions(+), 16 deletions(-)
-
-diff --git a/backend/xerox_mfp.c b/backend/xerox_mfp.c
-index e08b50f..d4672a7 100644
---- backend/xerox_mfp.c.orig
-+++ backend/xerox_mfp.c
-@@ -37,10 +37,10 @@
- static const SANE_Device **devlist = NULL; /* sane_get_devices array */
- static struct device *devices_head = NULL; /* sane_get_devices list */
-
--transport available_transports[] = {
-+enum { TRANSPORT_USB, TRANSPORT_TCP, TRANSPORTS_MAX };
-+transport available_transports[TRANSPORTS_MAX] = {
- { "usb", usb_dev_request, usb_dev_open, usb_dev_close, usb_configure_device },
- { "tcp", tcp_dev_request, tcp_dev_open, tcp_dev_close, tcp_configure_device },
-- { 0 }
- };
-
- static int resolv_state(int state)
-@@ -824,7 +824,13 @@ free_devices (void)
- devices_head = NULL;
- }
-
--/* SANE API ignores return code of this callback */
-+static transport *tr_from_devname(SANE_String_Const devname)
-+{
-+ if (strncmp("tcp", devname, 3) == 0)
-+ return &available_transports[TRANSPORT_TCP];
-+ return &available_transports[TRANSPORT_USB];
-+}
-+
- static SANE_Status
- list_one_device (SANE_String_Const devname)
- {
-@@ -839,12 +845,7 @@ list_one_device (SANE_String_Const devname)
- return SANE_STATUS_GOOD;
- }
-
-- for (tr = available_transports; tr->ttype; tr++) {
-- if (!strncmp (devname, tr->ttype, strlen(tr->ttype)))
-- break;
-- }
-- if (!tr->ttype)
-- return SANE_STATUS_INVAL;
-+ tr = tr_from_devname(devname);
-
- dev = calloc (1, sizeof (struct device));
- if (dev == NULL)
-@@ -878,13 +879,7 @@ list_one_device (SANE_String_Const devname)
- static SANE_Status
- list_conf_devices (UNUSED (SANEI_Config * config), const char *devname)
- {
-- transport *tr;
--
-- for (tr = available_transports; tr->ttype; tr++) {
-- if (!strncmp (devname, tr->ttype, strlen(tr->ttype)))
-- return tr->configure_device(devname, list_one_device);
-- }
-- return SANE_STATUS_INVAL;
-+ return tr_from_devname(devname)->configure_device(devname, list_one_device);
- }
-
- SANE_Status
---
-1.7.2.5
-
diff --git a/graphics/sane-backends/files/patch-backend__epson2-commands.c b/graphics/sane-backends/files/patch-backend__epson2-commands.c
deleted file mode 100644
index 19345673d545..000000000000
--- a/graphics/sane-backends/files/patch-backend__epson2-commands.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- backend/epson2-commands.c.orig 2010-04-05 22:18:04.000000000 +0900
-+++ backend/epson2-commands.c 2010-05-10 22:24:33.000000000 +0900
-@@ -21,6 +21,7 @@
-
- #include <byteorder.h>
- #include <math.h>
-+#include <sys/types.h>
-
- #include "epson2.h"
- #include "epson2-io.h"
diff --git a/graphics/sane-backends/files/patch-backend__epson2.c b/graphics/sane-backends/files/patch-backend__epson2.c
deleted file mode 100644
index 6298509a11cd..000000000000
--- a/graphics/sane-backends/files/patch-backend__epson2.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- backend/epson2.c.orig 2010-04-05 22:18:04.000000000 +0900
-+++ backend/epson2.c 2010-05-10 22:18:47.000000000 +0900
-@@ -57,6 +57,8 @@
- #include <unistd.h>
- #include <errno.h>
- #include <sys/time.h>
-+#include <sys/types.h>
-+#include <sys/socket.h>
-
- #include "sane/saneopts.h"
- #include "sane/sanei_scsi.h"
diff --git a/graphics/sane-backends/files/patch-backend__kodakaio.c b/graphics/sane-backends/files/patch-backend__kodakaio.c
new file mode 100644
index 000000000000..8c7a1a89d292
--- /dev/null
+++ b/graphics/sane-backends/files/patch-backend__kodakaio.c
@@ -0,0 +1,13 @@
+--- backend/kodakaio.c.orig 2012-08-10 09:33:29.000000000 +0900
++++ backend/kodakaio.c 2012-08-29 16:35:36.000000000 +0900
+@@ -165,6 +165,10 @@
+ #include <math.h>
+ #include <poll.h>
+ #include <time.h>
++#include <sys/types.h>
++#ifdef HAVE_SYS_SOCKET_H
++#include <sys/socket.h>
++#endif
+
+ #if HAVE_CUPS
+ /* used for auto detecting network printers */
diff --git a/graphics/sane-backends/files/patch-backend__kvs40xx.h b/graphics/sane-backends/files/patch-backend__kvs40xx.h
new file mode 100644
index 000000000000..37fd459a568d
--- /dev/null
+++ b/graphics/sane-backends/files/patch-backend__kvs40xx.h
@@ -0,0 +1,19 @@
+--- backend/kvs40xx.h.orig 2012-08-20 05:27:18.000000000 +0900
++++ backend/kvs40xx.h 2012-08-29 17:01:58.000000000 +0900
+@@ -10,6 +10,7 @@
+
+ #include "../include/sane/config.h"
+ #include <semaphore.h>
++#include <pthread.h>
+
+ #undef BACKEND_NAME
+ #define BACKEND_NAME kvs40xx
+@@ -208,7 +209,7 @@
+ SANE_Status kvs40xx_document_exist (struct scanner *s);
+ SANE_Status get_buffer_status (struct scanner *s, unsigned *data_avalible);
+ SANE_Status kvs40xx_scan (struct scanner *s);
+-SANE_Status kvs40xx_sense_handler (int fd, u_char * sense_buffer, void *arg);
++SANE_Status kvs40xx_sense_handler (int fd, unsigned char * sense_buffer, void *arg);
+ SANE_Status stop_adf (struct scanner *s);
+ SANE_Status hopper_down (struct scanner *s);
+ SANE_Status inquiry (struct scanner *s, char *id);
diff --git a/graphics/sane-backends/files/patch-backend__kvs40xx_opt.c b/graphics/sane-backends/files/patch-backend__kvs40xx_opt.c
new file mode 100644
index 000000000000..b3d8f5840e74
--- /dev/null
+++ b/graphics/sane-backends/files/patch-backend__kvs40xx_opt.c
@@ -0,0 +1,10 @@
+--- backend/kvs40xx_opt.c.orig 2012-08-10 09:33:29.000000000 +0900
++++ backend/kvs40xx_opt.c 2012-08-29 16:57:47.000000000 +0900
+@@ -8,6 +8,7 @@
+
+ #include "../include/sane/config.h"
+
++#include <stdlib.h>
+ #include <string.h>
+ #define DEBUG_DECLARE_ONLY
+ #define BACKEND_NAME kvs40xx
diff --git a/graphics/sane-backends/files/patch-backend__magicolor.c b/graphics/sane-backends/files/patch-backend__magicolor.c
deleted file mode 100644
index 1ab4d7954e9f..000000000000
--- a/graphics/sane-backends/files/patch-backend__magicolor.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- backend/magicolor.c.orig 2011-01-31 03:49:46.000000000 +0900
-+++ backend/magicolor.c 2011-08-02 02:38:15.000000000 +0900
-@@ -50,6 +50,8 @@
- #include <unistd.h>
- #include <errno.h>
- #include <sys/time.h>
-+#include <sys/types.h>
-+#include <sys/socket.h>
- #include <math.h>
- #include <poll.h>
-
diff --git a/graphics/sane-backends/files/patch-backend__niash.c b/graphics/sane-backends/files/patch-backend__niash.c
new file mode 100644
index 000000000000..6820c6a1b220
--- /dev/null
+++ b/graphics/sane-backends/files/patch-backend__niash.c
@@ -0,0 +1,24 @@
+--- backend/niash.c.orig 2006-02-04 12:34:28.000000000 +0100
++++ backend/niash.c 2007-02-21 15:38:12.000000000 +0100
+@@ -89,7 +89,9 @@ typedef enum
+ optLamp,
+
+ optCalibrate,
+- optGamma /* analog gamma = single number */
++ optGamma, /* analog gamma = single number */
++/* have optEndOfList only to define arrays with sufficient size */
++ optEndOfList
+ } EOptionIndex;
+
+
+@@ -105,8 +107,8 @@ typedef union
+
+ typedef struct
+ {
+- SANE_Option_Descriptor aOptions[optLast];
+- TOptionValue aValues[optLast];
++ SANE_Option_Descriptor aOptions[optEndOfList];
++ TOptionValue aValues[optEndOfList];
+
+ TScanParams ScanParams;
+ THWParams HWParams;
diff --git a/graphics/sane-backends/files/patch-backend__xerox_mfp-tcp.c b/graphics/sane-backends/files/patch-backend__xerox_mfp-tcp.c
deleted file mode 100644
index 60677656bacc..000000000000
--- a/graphics/sane-backends/files/patch-backend__xerox_mfp-tcp.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- backend/xerox_mfp-tcp.c.orig 2010-12-02 08:49:58.000000000 +0900
-+++ backend/xerox_mfp-tcp.c 2011-08-02 02:37:27.000000000 +0900
-@@ -27,6 +27,8 @@
- #include <unistd.h>
- #include <errno.h>
- #include <sys/time.h>
-+#include <sys/types.h>
-+#include <sys/socket.h>
-
- #include "sane/saneopts.h"
- #include "sane/sanei_scsi.h"
diff --git a/graphics/sane-backends/files/patch-doc_Makefile.in b/graphics/sane-backends/files/patch-doc_Makefile.in
deleted file mode 100644
index 257af141fe45..000000000000
--- a/graphics/sane-backends/files/patch-doc_Makefile.in
+++ /dev/null
@@ -1,60 +0,0 @@
---- doc/Makefile.in.orig 2010-04-14 09:52:59.000000000 +0900
-+++ doc/Makefile.in 2010-05-10 22:02:46.000000000 +0900
-@@ -73,8 +73,7 @@
- sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
- man1dir = $(mandir)/man1
- am__installdirs = "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man7dir)" \
-- "$(DESTDIR)$(man8dir)" "$(DESTDIR)$(docdir)" \
-- "$(DESTDIR)$(docdir)" "$(DESTDIR)$(docdir)"
-+ "$(DESTDIR)$(man8dir)"
- man7dir = $(mandir)/man7
- man8dir = $(mandir)/man8
- NROFF = nroff
-@@ -559,6 +558,7 @@
- echo " ( cd '$(DESTDIR)$(man8dir)' && rm -f" $$files ")"; \
- cd "$(DESTDIR)$(man8dir)" && rm -f $$files; }
- install-dist_docDATA: $(dist_doc_DATA)
-+ifndef NOPORTDOCS
- @$(NORMAL_INSTALL)
- test -z "$(docdir)" || $(MKDIR_P) "$(DESTDIR)$(docdir)"
- @list='$(dist_doc_DATA)'; test -n "$(docdir)" || list=; \
-@@ -570,6 +570,7 @@
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(docdir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(docdir)" || exit $$?; \
- done
-+endif
-
- uninstall-dist_docDATA:
- @$(NORMAL_UNINSTALL)
-@@ -579,6 +580,7 @@
- echo " ( cd '$(DESTDIR)$(docdir)' && rm -f" $$files ")"; \
- cd "$(DESTDIR)$(docdir)" && rm -f $$files
- install-docDATA: $(doc_DATA)
-+ifndef NOPORTDOCS
- @$(NORMAL_INSTALL)
- test -z "$(docdir)" || $(MKDIR_P) "$(DESTDIR)$(docdir)"
- @list='$(doc_DATA)'; test -n "$(docdir)" || list=; \
-@@ -590,6 +592,7 @@
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(docdir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(docdir)" || exit $$?; \
- done
-+endif
-
- uninstall-docDATA:
- @$(NORMAL_UNINSTALL)
-@@ -599,6 +602,7 @@
- echo " ( cd '$(DESTDIR)$(docdir)' && rm -f" $$files ")"; \
- cd "$(DESTDIR)$(docdir)" && rm -f $$files
- install-nobase_dist_docDATA: $(nobase_dist_doc_DATA)
-+ifndef NOPORTDOCS
- @$(NORMAL_INSTALL)
- test -z "$(docdir)" || $(MKDIR_P) "$(DESTDIR)$(docdir)"
- @list='$(nobase_dist_doc_DATA)'; test -n "$(docdir)" || list=; \
-@@ -613,6 +617,7 @@
- echo " $(INSTALL_DATA) $$xfiles '$(DESTDIR)$(docdir)/$$dir'"; \
- $(INSTALL_DATA) $$xfiles "$(DESTDIR)$(docdir)/$$dir" || exit $$?; }; \
- done
-+endif
-
- uninstall-nobase_dist_docDATA:
- @$(NORMAL_UNINSTALL)
diff --git a/graphics/sane-backends/files/patch-frontend__Makefile.in b/graphics/sane-backends/files/patch-frontend__Makefile.in
deleted file mode 100644
index 131de5a6c3b0..000000000000
--- a/graphics/sane-backends/files/patch-frontend__Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- frontend/Makefile.in.orig 2009-04-30 22:41:19.000000000 +0900
-+++ frontend/Makefile.in 2009-05-13 15:21:53.000000000 +0900
-@@ -254,7 +254,7 @@
- scanimage_LDADD = ../lib/liblib.la ../lib/libfelib.la ../backend/libsane.la
- saned_SOURCES = saned.c
- saned_LDADD = ../sanei/libsanei.la ../lib/liblib.la ../lib/libfelib.la \
-- ../backend/libsane.la @SYSLOG_LIBS@
-+ ../backend/libsane.la @SYSLOG_LIBS@ @AVAHI_LIBS@
-
- test_SOURCES = test.c
- test_LDADD = ../lib/liblib.la ../lib/libfelib.la ../backend/libsane.la
diff --git a/graphics/sane-backends/files/patch-include_sane_sanei_tcp.h b/graphics/sane-backends/files/patch-include_sane_sanei_tcp.h
deleted file mode 100644
index f4e50b89d750..000000000000
--- a/graphics/sane-backends/files/patch-include_sane_sanei_tcp.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- include/sane/sanei_tcp.h.orig 2006-11-30 14:23:19.000000000 -0900
-+++ include/sane/sanei_tcp.h 2009-01-16 05:02:42.000000000 -0900
-@@ -20,6 +20,7 @@
-
- #include <sane/sane.h>
-
-+#include <sys/types.h>
- #include <netinet/in.h>
- #include <netdb.h>
-
diff --git a/graphics/sane-backends/files/patch-sanei_sanei_usb.c b/graphics/sane-backends/files/patch-sanei_sanei_usb.c
deleted file mode 100644
index 79523f1866bf..000000000000
--- a/graphics/sane-backends/files/patch-sanei_sanei_usb.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- sanei/sanei_usb.c.orig 2009-07-26 21:29:33.000000000 +0200
-+++ sanei/sanei_usb.c 2009-07-26 21:31:42.000000000 +0200
-@@ -96,7 +96,8 @@
- }
- #endif /* HAVE_USBCALLS */
-
--#if defined (__FreeBSD__)
-+#if (defined (__FreeBSD__) && (__FreeBSD_version < 800064))
-+#include <sys/param.h>
- #include <dev/usb/usb.h>
- #endif /* __FreeBSD__ */
- #if defined (__DragonFly__)
-@@ -273,7 +274,7 @@
- *vendorID = vendor;
- *productID = product;
- }
--#elif defined (__FreeBSD__) || defined (__DragonFly__)
-+#elif (defined (__FreeBSD__) && __FreeBSD_version < 800064) || defined (__DragonFly__)
- {
- int controller;
- int ctrl_fd;
diff --git a/graphics/sane-backends/pkg-plist b/graphics/sane-backends/pkg-plist
index 3efa22333ebe..b2b6c7d832c5 100644
--- a/graphics/sane-backends/pkg-plist
+++ b/graphics/sane-backends/pkg-plist
@@ -38,6 +38,7 @@ bin/scanimage
@unexec if cmp -s %D/etc/sane.d/hs2p.conf %D/etc/sane.d/dist/hs2p.conf; then rm -f %D/etc/sane.d/hs2p.conf; fi
@unexec if cmp -s %D/etc/sane.d/ibm.conf %D/etc/sane.d/dist/ibm.conf; then rm -f %D/etc/sane.d/ibm.conf; fi
@unexec if cmp -s %D/etc/sane.d/kodak.conf %D/etc/sane.d/dist/kodak.conf; then rm -f %D/etc/sane.d/kodak.conf; fi
+@unexec if cmp -s %D/etc/sane.d/kodakaio.conf %D/etc/sane.d/dist/kodakaio.conf; then rm -f %D/etc/sane.d/kodakaio.conf; fi
@unexec if cmp -s %D/etc/sane.d/leo.conf %D/etc/sane.d/dist/leo.conf; then rm -f %D/etc/sane.d/leo.conf; fi
@unexec if cmp -s %D/etc/sane.d/lexmark.conf %D/etc/sane.d/dist/lexmark.conf; then rm -f %D/etc/sane.d/lexmark.conf; fi
@unexec if cmp -s %D/etc/sane.d/ma1509.conf %D/etc/sane.d/dist/ma1509.conf; then rm -f %D/etc/sane.d/ma1509.conf; fi
@@ -113,6 +114,7 @@ etc/sane.d/dist/hp5400.conf
etc/sane.d/dist/hs2p.conf
etc/sane.d/dist/ibm.conf
etc/sane.d/dist/kodak.conf
+etc/sane.d/dist/kodakaio.conf
etc/sane.d/dist/leo.conf
etc/sane.d/dist/lexmark.conf
etc/sane.d/dist/ma1509.conf
@@ -276,12 +278,18 @@ lib/sane/libsane-ibm.so.1
lib/sane/libsane-kodak.la
lib/sane/libsane-kodak.so
lib/sane/libsane-kodak.so.1
+lib/sane/libsane-kodakaio.la
+lib/sane/libsane-kodakaio.so
+lib/sane/libsane-kodakaio.so.1
lib/sane/libsane-kvs1025.la
lib/sane/libsane-kvs1025.so
lib/sane/libsane-kvs1025.so.1
lib/sane/libsane-kvs20xx.la
lib/sane/libsane-kvs20xx.so
lib/sane/libsane-kvs20xx.so.1
+lib/sane/libsane-kvs40xx.la
+lib/sane/libsane-kvs40xx.so
+lib/sane/libsane-kvs40xx.so.1
lib/sane/libsane-leo.la
lib/sane/libsane-leo.so
lib/sane/libsane-leo.so.1
@@ -402,6 +410,7 @@ lib/sane/libsane-umax_pp.so.1
lib/sane/libsane-xerox_mfp.la
lib/sane/libsane-xerox_mfp.so
lib/sane/libsane-xerox_mfp.so.1
+libdata/pkgconfig/sane-backends.pc
sbin/saned
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog