aboutsummaryrefslogtreecommitdiff
path: root/graphics/seexpr/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-13 12:45:25 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-13 12:45:25 +0000
commitb15d5954577ced9b10ee8f7ccc9ecb2b8c55301f (patch)
treee148877223c2f865b58a8a89bbabbf0e0cdf36b8 /graphics/seexpr/Makefile
parent39f82d71205ef6c90e50be3aceb82f8cdb1ce219 (diff)
downloadports-b15d5954577ced9b10ee8f7ccc9ecb2b8c55301f.tar.gz
ports-b15d5954577ced9b10ee8f7ccc9ecb2b8c55301f.zip
Update PyQt4 to 4.11.4, SIP to 4.17 and QScintilla2 to 2.9.1.
Bring in some long overdue updates, some of which are required for us to later land the PyQt5 ports. One big change with this update is that the PyQt4 ports now install their .sip files into share/py-sip/PyQt4 instead of share/py-sip. This way we do not end up with directories like share/py-sip/QtCore, which are especially confusing once PyQt5 lands and starts installing files with the same names. Other noteworthy items: - PORTREVISION has been bumped on ports depending on devel/qscintilla2 because libqscintilla2.so's SOVERSION has changed. - graphics/seexpr has been converted to USE_PYQT, as the file it used to define a build-time dependency on x11-toolkits/py-qt4-gui has moved. Once again, big thanks to Tobias Berner <tcberner@gmail.com> and Guido Falsi (madpilot@) for their initial work on these ports as part of the effort to land PyQt5 into the tree (see D2910 in Phabricator for an earlier version of the PyQt5 patch set). PR: 205143
Notes
Notes: svn path=/head/; revision=403662
Diffstat (limited to 'graphics/seexpr/Makefile')
-rw-r--r--graphics/seexpr/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/graphics/seexpr/Makefile b/graphics/seexpr/Makefile
index 85827a06b4bd..038071035091 100644
--- a/graphics/seexpr/Makefile
+++ b/graphics/seexpr/Makefile
@@ -11,13 +11,12 @@ COMMENT= Embeddable expression evaluation language
LICENSE= APACHE20
-BUILD_DEPENDS= ${LOCALBASE}/share/py-sip/QtGui/QtGuimod.sip:${PORTSDIR}/x11-toolkits/py-qt4-gui
-
USE_GITHUB= yes
GH_ACCOUNT= wdas
GH_TAGNAME= 36ffb818b8
-USES= bison cmake compiler:c++0x python
+USES= bison cmake compiler:c++0x pyqt:4 python
+USE_PYQT= gui_build
USE_QT4= moc_build qmake_build rcc_build uic_build gui opengl
WRKSRC= ${WRKDIR}/SeExpr-${GH_TAGNAME_EXTRACT}