aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2016-07-14 07:33:35 +0000
committerThierry Thomas <thierry@FreeBSD.org>2016-07-14 07:33:35 +0000
commit0a5aaa276ee5903659f430d1b00af08fa3d9663e (patch)
tree1c1a51ca35388cfb19f13b6d1e61c2be07163d54 /graphics
parentff71747c0f4df30498de1c2aa45a6c137d95cb8e (diff)
downloadports-0a5aaa276ee5903659f430d1b00af08fa3d9663e.tar.gz
ports-0a5aaa276ee5903659f430d1b00af08fa3d9663e.zip
Switch to Github and upgrade to 0.9.4.
Notes
Notes: svn path=/head/; revision=418520
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libboard/Makefile15
-rw-r--r--graphics/libboard/distinfo5
-rw-r--r--graphics/libboard/files/patch-configure47
-rw-r--r--graphics/libboard/files/patch-src_Shapes.cpp11
-rw-r--r--graphics/libboard/pkg-plist20
5 files changed, 80 insertions, 18 deletions
diff --git a/graphics/libboard/Makefile b/graphics/libboard/Makefile
index 29d4a1e90427..6a2c5c8a9835 100644
--- a/graphics/libboard/Makefile
+++ b/graphics/libboard/Makefile
@@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= libboard
-DISTVERSION= 0.9.0
-PORTREVISION= 1
+DISTVERSION= 0.9.4
CATEGORIES= graphics
-MASTER_SITES= LOCAL/thierry
MAINTAINER= thierry@FreeBSD.org
COMMENT= Vector graphics C++ library
@@ -13,6 +11,7 @@ COMMENT= Vector graphics C++ library
LICENSE= LGPL3
BUILD_DEPENDS= doxygen:devel/doxygen
+LIB_DEPENDS= libMagick++-6.so:graphics/ImageMagick
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
@@ -20,8 +19,9 @@ CONFIGURE_ENV= CXX=${CXX}
USES= gmake
USE_LDCONFIG= yes
-
-WRKSRC= ${WRKDIR}/${DISTNAME:C/-.$//}
+USE_GITHUB= yes
+GH_ACCOUNT= c-koi
+GH_TAGNAME= 5b38274
PORTDOCS= *
@@ -34,7 +34,8 @@ CXXFLAGS+= -fPIC
.endif
pre-configure:
- ${REINPLACE_CMD} -e 's|-O3|${CXXFLAGS}|' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ ${REINPLACE_CMD} -e 's|-O3|${CXXFLAGS}|;s|g++|${CXX}|' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
post-install:
${MV} ${STAGEDIR}${PREFIX}/lib/libboard.so ${STAGEDIR}${PREFIX}/lib/libboard.so.0
@@ -56,6 +57,6 @@ regression-test:
.for ex in 1 2 3
(cd ${WRKDIR} && ${WRKSRC}/bin/example${ex})
.endfor
- ${LS} -l ${WRKDIR}/arithm* ${WRKDIR}/draw*
+ ${LS} -l ${WRKDIR}/arithm* ${WRKDIR}/example*
.include <bsd.port.post.mk>
diff --git a/graphics/libboard/distinfo b/graphics/libboard/distinfo
index 13ffa2790373..d1470bf25ec1 100644
--- a/graphics/libboard/distinfo
+++ b/graphics/libboard/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libboard-0.9.0.tar.gz) = 01a481e9853502643d964a32b74eac3f8b0ca12d261185ae2d20b16bdcbf19e8
-SIZE (libboard-0.9.0.tar.gz) = 355463
+TIMESTAMP = 1468352804
+SHA256 (c-koi-libboard-0.9.4-5b38274_GH0.tar.gz) = 247cb53f1119b7b8505917f2e319bd38339d833652e83af43d4a034a4f8edcc7
+SIZE (c-koi-libboard-0.9.4-5b38274_GH0.tar.gz) = 270250
diff --git a/graphics/libboard/files/patch-configure b/graphics/libboard/files/patch-configure
index 760380601822..e609575aa973 100644
--- a/graphics/libboard/files/patch-configure
+++ b/graphics/libboard/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2010-07-16 09:07:39.000000000 +0200
-+++ configure 2014-04-21 11:18:10.000000000 +0200
-@@ -117,23 +117,6 @@
+--- configure.orig 2016-06-09 17:30:46 UTC
++++ configure
+@@ -163,23 +163,6 @@ fi
##
## Are we on a 64 bits arch
##
@@ -22,9 +22,9 @@
-fi
-rm -f is64 is64.c
- cat > Makefile <<EOF
-@@ -147,7 +130,7 @@
+ #
+@@ -204,7 +187,7 @@ DYNLIB_NAME=\$(LIBNAME).\$(DYNLIB_EXTENS
STATICLIB_NAME=\$(LIBNAME).\$(STATICLIB_EXTENSION)
DYNLIB=lib/\$(DYNLIB_NAME)
STATICLIB=lib/\$(STATICLIB_NAME)
@@ -33,10 +33,43 @@
RM=rm -f
CP=cp
LD=\$(CXX)
-@@ -220,10 +203,6 @@
- chmod 755 \$(PREFIX)/include/board
+@@ -231,6 +214,7 @@ ${ECHO} -n "Checking plateform..."
+ WIN32=0
+ case $(uname) in
+ Linux ) WIN32=0; PLATEFORM=Linux ;;
++ FreeBSD ) WIN32=0; PLATEFORM=FreeBSD ;;
+ Darwin) WIN32=0; PLATEFORM="Mac OS X" ;;
+ Darwin ) WIN32=0; PLATEFORM="Mac OS X" ;;
+ MINGW* ) WIN32=1; PLATEFORM="Win32/Mingw" ;;
+@@ -241,7 +225,7 @@ ${ECHO} $PLATEFORM
+ ${ECHO} -n "Creating include/BoardConfig.h..."
+ sed -e 's/@Board_Have_MagickPlusPlus@/'${MAGICKPLUSPLUS}'/' \
+ -e 's/@Board_Win32@/'${WIN32}'/' \
+- -e 's/@LibBoard_VERSION@/'${VERSION}'/' \
++ -e "s/@LibBoard_VERSION@/'${VERSION}'/" \
+ include/BoardConfig.h.in > include/BoardConfig.h
+ ${ECHO} "done."
+
+@@ -269,6 +253,7 @@ obj/Board.o: src/Board.cpp include/Board
+
+ bin/%: examples/%.cpp \$(STATICLIB)
+ \$(CXX) \$(CXXFLAGSEXEC) -o \$@ \$< ${IMAGE_CXXFLAGS} ${IMAGE_LDFLAGS} \$(STATICLIB)
++ \strip \$@
+
+ clean:
+ rm -f obj/*.o lib/* bin/* include/*~ include/board/*~ src/*~ examples/*~ *~
+@@ -292,7 +277,6 @@ if [ ${ON_PLACE} = no ]; then
+ \$(CP) include/BoardConfig.h \$(PREFIX)/include/
+ \$(CP) include/board/*.h \$(PREFIX)/include/board
+ \$(CP) include/board/*.ih \$(PREFIX)/include/board
+- ldconfig
+ EOF
+ fi
+ cat >> Makefile <<EOF
+@@ -300,10 +284,6 @@ cat >> Makefile <<EOF
chmod 644 \$(PREFIX)/include/Board.h
chmod 644 \$(PREFIX)/include/board/*.h
+ chmod 644 \$(PREFIX)/include/board/*.ih
- install -d \$(PREFIX)/share/libboard/examples
- \$(CP) examples/*.cpp \$(PREFIX)/share/libboard/examples
- \$(CP) examples/README \$(PREFIX)/share/libboard/examples
diff --git a/graphics/libboard/files/patch-src_Shapes.cpp b/graphics/libboard/files/patch-src_Shapes.cpp
new file mode 100644
index 000000000000..506ea0267ace
--- /dev/null
+++ b/graphics/libboard/files/patch-src_Shapes.cpp
@@ -0,0 +1,11 @@
+--- src/Shapes.cpp.orig 2016-06-09 17:30:46 UTC
++++ src/Shapes.cpp
+@@ -1908,7 +1908,7 @@ Text::Text( double x, double y,
+ }
+
+ Text::Text(Point p,
+- const std::__cxx11::string & text,
++ const std::string & text,
+ const Fonts::Font font,
+ double size,
+ Color color,
diff --git a/graphics/libboard/pkg-plist b/graphics/libboard/pkg-plist
index 556d10726e8b..171c527fe4da 100644
--- a/graphics/libboard/pkg-plist
+++ b/graphics/libboard/pkg-plist
@@ -1,21 +1,27 @@
include/Board.h
+include/BoardConfig.h
+include/board/Board.ih
include/board/Color.h
-include/board/Path.h
+include/board/Image.h
include/board/PSFonts.h
+include/board/Path.h
+include/board/PathBoundaries.h
include/board/Point.h
include/board/Rect.h
include/board/ShapeList.h
include/board/ShapeList.ih
+include/board/ShapeVisitor.h
include/board/Shapes.h
include/board/Shapes.ih
include/board/Tools.h
include/board/Tools.ih
+include/board/TransformMatrix.h
+include/board/TransformMatrix.ih
include/board/Transforms.h
include/board/Transforms.ih
lib/libboard.a
lib/libboard.so
lib/libboard.so.0
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arithmetic
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arithmetic.cpp
@@ -37,11 +43,21 @@ lib/libboard.so.0
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/flag.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/images
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/images.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/koch
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/koch.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/line_segment
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/line_segment.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/line_style
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/line_style.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/logo
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/logo.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ruler
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ruler.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scale_ellipse
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scale_ellipse.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/stroke_path
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/stroke_path.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tilings
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tilings.cpp