aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-07-14 09:00:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-07-14 09:00:29 +0000
commit37faed2b8f0686bfb249a93c060c32c94fd7b05e (patch)
treed340346af4c7a2790971cb0b5659fc6444244947 /graphics
parentc7f56437af88c39f6ccebd05bf026088c744e4c3 (diff)
downloadports-37faed2b8f0686bfb249a93c060c32c94fd7b05e.tar.gz
ports-37faed2b8f0686bfb249a93c060c32c94fd7b05e.zip
- Add LICENSE
- Switch to options helpers - Cosmetic fixes
Notes
Notes: svn path=/head/; revision=418524
Diffstat (limited to 'graphics')
-rw-r--r--graphics/deegree-wcs/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/graphics/deegree-wcs/Makefile b/graphics/deegree-wcs/Makefile
index e1efcd2d2354..44c1c9bdb78b 100644
--- a/graphics/deegree-wcs/Makefile
+++ b/graphics/deegree-wcs/Makefile
@@ -12,10 +12,13 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Deegree Web Coverage Service(WCS)
+LICENSE= LGPL21+
+
USES= zip
USE_JAVA= 1.6+
NO_BUILD= yes
+NO_ARCH= yes
TOMCATDIR= ${PREFIX}/${TOMCATVER}
APPHOME= ${LOCALBASE}/${TOMCATVER}
WEBAPPDIR= ${TOMCATDIR}/webapps
@@ -34,14 +37,14 @@ OPTIONS_DEFINE= DOCS
.if ${PORT_OPTIONS:MTOMCAT6}
TOMCATVER= apache-tomcat-6.0
-TCPORT= 8180
+TCPORT= 8180
BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat6
RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat6
.endif
.if ${PORT_OPTIONS:MTOMCAT7}
TOMCATVER= apache-tomcat-7.0
-TCPORT= 8080
+TCPORT= 8080
BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat7
RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat7
.endif
@@ -51,10 +54,11 @@ post-extract:
@${TAR} xf ${WRKDIR}/deegree-wcs.war -C ${WRKDIR}/${PORTDIRNAME}
do-install:
- cd ${WRKDIR} && \
- ${INSTALL} -d ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
+ @${MKDIR} ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
@cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKDIR}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>