aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:45:51 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:21:09 +0000
commit3d214ee27d2d5cd82214d7838b6ee8c5ac35eff1 (patch)
tree567bcfa5601fa6d50b75900f02a9ea2989c708b5 /graphics
parentc2a04964fc8ac26fe1482d36b355a37b5b367ad3 (diff)
downloadports-3d214ee27d2d5cd82214d7838b6ee8c5ac35eff1.tar.gz
ports-3d214ee27d2d5cd82214d7838b6ee8c5ac35eff1.zip
graphics/py-imageio: Convert to USE_PYTHON=pytest
PR: 269145 Reported by: yuri
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-imageio/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/graphics/py-imageio/Makefile b/graphics/py-imageio/Makefile
index 2ca3e87d9176..b2366a9b4c33 100644
--- a/graphics/py-imageio/Makefile
+++ b/graphics/py-imageio/Makefile
@@ -12,12 +12,22 @@ WWW= https://github.com/imageio/imageio
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+# requests is from fsspec[github]
LIB_DEPENDS= libfreeimage.so:graphics/freeimage
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pillow>=8.3.2:graphics/py-pillow@${PY_FLAVOR}
+TEST_DEPENDS= opencv>=0:graphics/opencv \
+ ${PYTHON_PKGNAMEPREFIX}astropy>=0:astro/py-astropy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}av>=0:multimedia/py-av@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gdal>=0:graphics/py-gdal@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fsspec>=0:devel/py-fsspec@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}invoke>=0:devel/py-invoke@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tifffile>=0:graphics/py-tifffile@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent distutils pytest
NO_ARCH= yes