aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2022-07-30 16:37:48 +0000
committerDimitry Andric <dim@FreeBSD.org>2022-07-31 17:12:11 +0000
commit4ba3797c9993a25a082ed767d4f44234b1f7dc04 (patch)
tree86fea6a2a6eb931b1cbdb399b3af5272231bd8ed /graphics
parentb3668183ee5d58571fa2fbd3b4ce3d15e86b9953 (diff)
downloadports-4ba3797c9993a25a082ed767d4f44234b1f7dc04.tar.gz
ports-4ba3797c9993a25a082ed767d4f44234b1f7dc04.zip
graphics/png: fix build with clang 15
Building png with clang 15 results in an error: contrib/libtests/pngvalid.c:11662:4: error: call to undeclared function 'feenableexcept'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration] feenableexcept(FE_DIVBYZERO | FE_INVALID | FE_OVERFLOW); ^ This is because clang 15 introduced this new warning, and fenv.h only declares feenableexcept() when compiling for C standards before C11. The least disruptive way to solve this is to make the port build with USE_CSTD=gnu89. PR: 265521 Approved by: portmgr (antoine) MFH: 2022Q3
Diffstat (limited to 'graphics')
-rw-r--r--graphics/png/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index 18f0accd5f9f..d157f7187248 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -16,6 +16,7 @@ LICENSE_NAME= libpng License
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+USE_CSTD= gnu89
USES= cpe libtool tar:xz
CPE_PRODUCT= libpng
GNU_CONFIGURE= yes