aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-04-29 07:14:37 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-05-01 17:55:55 +0000
commit6707a3c942b51ab3e3cf110383e3119dfe2e49b0 (patch)
treebd3221fe24dd880cfb3169fd2241e74ff7f78bed /graphics
parent51abee5375fe25f7ef6a69d7d2800ca935ca1827 (diff)
downloadports-6707a3c942b51ab3e3cf110383e3119dfe2e49b0.tar.gz
ports-6707a3c942b51ab3e3cf110383e3119dfe2e49b0.zip
Clean up some things
- Fix typos - Remove duplicate variables - Remove nop variables - Clean up commented PORTREVISION - Add missing USES Reported by: portscan
Diffstat (limited to 'graphics')
-rw-r--r--graphics/feh/Makefile1
-rw-r--r--graphics/ksnip/Makefile2
-rw-r--r--graphics/osg/Makefile2
-rw-r--r--graphics/rawtherapee/Makefile2
-rw-r--r--graphics/wayland/Makefile2
5 files changed, 4 insertions, 5 deletions
diff --git a/graphics/feh/Makefile b/graphics/feh/Makefile
index 6e6ab02553be..8973295db4e9 100644
--- a/graphics/feh/Makefile
+++ b/graphics/feh/Makefile
@@ -18,7 +18,6 @@ LIB_DEPENDS= libImlib2.so:graphics/imlib2 \
USES= compiler:c++11-lang cpe desktop-file-utils gmake localbase:ldflags \
tar:bzip2 xorg
USE_XORG= x11 xt xinerama
-USE_PERL5= run
CPE_VENDOR= daniel_friesel
MAKE_ENV+= LDFLAGS="${LDFLAGS}" verscmp=0
diff --git a/graphics/ksnip/Makefile b/graphics/ksnip/Makefile
index c1879676d7d5..263f74950727 100644
--- a/graphics/ksnip/Makefile
+++ b/graphics/ksnip/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libkColorPicker.so:graphics/kcolorpicker \
libkImageAnnotator.so:graphics/kimageannotator
-USES= cmake compiler:c++11-lang kde:5 qt:5
+USES= cmake compiler:c++11-lang kde:5 qt:5 xorg
USE_GITHUB= yes
GH_ACCOUNT= ksnip
USE_KDE= ecm_build
diff --git a/graphics/osg/Makefile b/graphics/osg/Makefile
index f23a6b01d0c7..9c419d036357 100644
--- a/graphics/osg/Makefile
+++ b/graphics/osg/Makefile
@@ -93,9 +93,11 @@ OPENEXR_LIB_DEPENDS= libOpenEXR.so:graphics/openexr libImath.so:math/Imath
OPENEXR_VARS= FORCE_REQUIRE+=OpenEXR
OPENEXR_VARS_OFF= FORCE_IGNORE+=OpenEXR
PDF_LIB_DEPENDS= libpoppler-glib.so:graphics/poppler-glib
+PDF_USES= gnome
PDF_USE= GNOME=cairo
PDF_VARS= FORCE_REQUIRE+=Poppler-glib
PDF_VARS_OFF= FORCE_IGNORE+=Poppler-glib
+SDL_USES= sdl
SDL_USE= SDL=sdl
SDL_VARS= FORCE_REQUIRE+=SDL
SDL_VARS_OFF= FORCE_IGNORE+=SDL
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index 13005de649cb..9a36e086d945 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -30,8 +30,6 @@ LIB_DEPENDS= \
USES= cmake desktop-file-utils compiler:gcc-c++11-lib gnome \
jpeg localbase:ldflags pkgconfig tar:xz
-DOS2UNIX_REGEX= .*\.(cc|h)
-
# Binutils required for LTO (base ar/nm/ld/ranlib don't work)
USE_BINUTILS= yes
diff --git a/graphics/wayland/Makefile b/graphics/wayland/Makefile
index adaf4cc8f1fa..fda3cb475ca2 100644
--- a/graphics/wayland/Makefile
+++ b/graphics/wayland/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
CFLAGS+= "-I${LOCALBASE}/include/libepoll-shim"
-USES= meson pkgconfig tar:xz
+USES= gnome meson pkgconfig tar:xz
USE_GNOME= libxslt:build
USE_LDCONFIG= yes
MESON_ARGS= -Ddocumentation=false