aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-08 17:48:45 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-08 17:48:45 +0000
commit9037ad5d8bb5dcfb30b5b5ccfbd11648cfb6fccb (patch)
tree6111ebac6a369e00177f142d326c82c9361c9e40 /graphics
parent0f8b2d9e10f11dd968f0aa05f594a0b4efbda65f (diff)
downloadports-9037ad5d8bb5dcfb30b5b5ccfbd11648cfb6fccb.tar.gz
ports-9037ad5d8bb5dcfb30b5b5ccfbd11648cfb6fccb.zip
- Add LICENSE
- Switch to USES=localbase - Install docs PR: 179337 Submitted by: nemysis@gmx.ch Approved by: maintainer timeout (grog, 3 years)
Notes
Notes: svn path=/head/; revision=421570
Diffstat (limited to 'graphics')
-rw-r--r--graphics/enblend/Makefile26
1 files changed, 17 insertions, 9 deletions
diff --git a/graphics/enblend/Makefile b/graphics/enblend/Makefile
index 9389fead5b2b..f4376aa67c28 100644
--- a/graphics/enblend/Makefile
+++ b/graphics/enblend/Makefile
@@ -11,6 +11,9 @@ DISTNAME= enblend-enfuse-${PORTVERSION}
MAINTAINER= grog@FreeBSD.org
COMMENT= Tool for image blending with multiresolution splines
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= help2man:misc/help2man \
${LOCALBASE}/bin/makeinfo:print/texinfo \
OpenEXR>=1.0:graphics/OpenEXR
@@ -22,16 +25,20 @@ LIB_DEPENDS= liblcms2.so:graphics/lcms2 \
RUN_DEPENDS= OpenEXR>=1.0:graphics/OpenEXR
USE_AUTOTOOLS= automake:env autoconf:env
-USES= compiler:features gmake jpeg makeinfo
+USES= compiler:features gmake jpeg localbase makeinfo
# We need a newer version of makeinfo for this.
# Remove this line when we remove texinfo from the base system.
-CONFIGURE_ARGS= MAKEINFO="${LOCALBASE}/bin/makeinfo"
+CONFIGURE_ARGS= MAKEINFO="${LOCALBASE}/bin/makeinfo" \
+ --with-boost-filesystem
USE_GL= glew glut
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-boost-filesystem
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lboost_system
+
+INFO= enfuse enblend
+PLIST_FILES= bin/enblend bin/enfuse man/man1/enblend.1.gz man/man1/enfuse.1.gz
+PORTDOCS= AUTHORS NEWS README
+
+OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
@@ -44,10 +51,11 @@ USE_GCC= yes
CXXFLAGS+= -Wno-c++11-extensions
.endif
-INFO= enfuse enblend
-PLIST_FILES= bin/enblend bin/enfuse man/man1/enblend.1.gz man/man1/enfuse.1.gz
-
post-install:
- ${INSTALL_DATA} ${WRKSRC}/doc/*.info ${STAGEDIR}${PREFIX}/${INFO_PATH}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.info ${STAGEDIR}${PREFIX}/${INFO_PATH}
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.post.mk>