aboutsummaryrefslogtreecommitdiff
path: root/java/jdk14/Makefile
diff options
context:
space:
mode:
authorAlexey Zelkin <phantom@FreeBSD.org>2003-03-15 09:57:58 +0000
committerAlexey Zelkin <phantom@FreeBSD.org>2003-03-15 09:57:58 +0000
commite051920066dd91ff7333b6ffad06f93459e7ce9e (patch)
treea9ee14951c11ae73182f194facd6b3262a7f42b4 /java/jdk14/Makefile
parentc53a3fe9fd5b2cfc1cc74aa52be8ed1c1f8b14d1 (diff)
downloadports-e051920066dd91ff7333b6ffad06f93459e7ce9e.tar.gz
ports-e051920066dd91ff7333b6ffad06f93459e7ce9e.zip
Fix checking of libc_r capabilities at FreeBSD version which
don't have pthread_attr_get_np() at all (early 4.7-STABLE and previous versions). Reported by: Phillip Oleson <poleson@verio.net>
Notes
Notes: svn path=/head/; revision=77130
Diffstat (limited to 'java/jdk14/Makefile')
-rw-r--r--java/jdk14/Makefile28
1 files changed, 22 insertions, 6 deletions
diff --git a/java/jdk14/Makefile b/java/jdk14/Makefile
index f8782a5b0f8c..4ac38b35dab8 100644
--- a/java/jdk14/Makefile
+++ b/java/jdk14/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jdk
PORTVERSION= ${JDK_VERSION}p${JDK_PATCHSET_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= java devel
MASTER_SITES= # http://www.sun.com/software/java2/download.html
# http://www.eyesbeyond.com/freebsddom/java/jdk14.html
@@ -99,24 +99,40 @@ http://www.eyesbeyond.com/freebsddom/java/jdk14.html.\n\
Please place the patchset in ${DISTDIR}.\n
.endif
+# JDK 1.4.1 require recent version of FreeBSD due to recent libc_r updates.
+# Make check for reqiuired primities as early as possible
+
+TESTPROG=testos
+
.if ${OSVERSION} > 500000
LINKIT= -lc_r
.else
LINKIT= -pthread
.endif
-# JDK 1.4.1 require recent version of FreeBSD due to recent libc_r updates.
check-os:
.if !defined(SKIP_OS_TEST)
- @mkdir -p ${WRKDIR} ; \
- gcc ${LINKIT} -o ${WRKDIR}/testos ${FILESDIR}/testos.c > /dev/null 2>&1 ; \
- ${WRKDIR}/testos 2>/dev/null
+ -@mkdir -p ${WRKDIR} ; \
+ rm -f ${WRKDIR}/${TESTPROG} ; \
+ gcc ${LINKIT} -o ${WRKDIR}/${TESTPROG} \
+ ${FILESDIR}/${TESTPROG}.c > /dev/null 2>&1
+ @if [ ! -f ${WRKDIR}/${TESTPROG} ] ; \
+ then \
+ /usr/bin/printf "\n\
+You must have a version of FreeBSD later than 4.7-STABLE\n\
+February 2003 or 5-CURRENT February 2003 to compile and\n\
+use JDK 1.4.1.\n\n" ; \
+ exit 1 ; \
+ fi
+ @${WRKDIR}/${TESTPROG} 2>/dev/null
.endif
pre-fetch: check-os
@${ECHO_MSG}
+ @${ECHO_MSG} "NOTICES:"
+ @${ECHO_MSG}
@${ECHO_MSG} "To build JDK 1.4.1 port, you should have at least"
- @${ECHO_MSG} "1.5Gb of disk space!"
+ @${ECHO_MSG} "1.5Gb of free disk space in build area!"
@${ECHO_MSG}
@${ECHO_MSG} "Please use \`make -DNODEBUG' if you don't want to"
@${ECHO_MSG} "install libraries and binaries with debugging support."