aboutsummaryrefslogtreecommitdiff
path: root/lang/nickle/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-03-25 11:28:46 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-03-25 11:28:46 +0000
commit94d74c6da5b167fcd6c60331824ac9226ba663a0 (patch)
tree050fb5718f46b68ca72a77df8d798af381bcb7aa /lang/nickle/Makefile
parent644fa5f9096c2b42a9da020691676d2b2a7ad7ad (diff)
downloadports-94d74c6da5b167fcd6c60331824ac9226ba663a0.tar.gz
ports-94d74c6da5b167fcd6c60331824ac9226ba663a0.zip
- Provide a comment about what we are reinplacing here for
- Fix a typo (NIPORTEXAMPLES -> NOPORTEXAMPLES) - Merge two options of cpio(1) so that line does not touch screen boundary Feature safe: yes
Notes
Notes: svn path=/head/; revision=293797
Diffstat (limited to 'lang/nickle/Makefile')
-rw-r--r--lang/nickle/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/lang/nickle/Makefile b/lang/nickle/Makefile
index 58e7fded24e3..72befef327f7 100644
--- a/lang/nickle/Makefile
+++ b/lang/nickle/Makefile
@@ -26,16 +26,18 @@ LDFLAGS+= ${PTHREAD_LIBS}
MAN1= nickle.1
post-patch:
- @${REINPLACE_CMD} -e \
- '/^SUBDIRS/s|examples|| ; \
- s| -O2||' ${WRKSRC}/Makefile.in
+# Do not descend into "examples" subdirectory to prevent them being installed
+# under DATADIR (instead, we manually install them later in post-install into
+# EXAMPLESDIR; also remove extra -O2 since we provide our own CFLAGS.
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s|examples|| ; s| -O2||' \
+ ${WRKSRC}/Makefile.in
post-install:
-.if !defined(NIPORTEXAMPLES)
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
@(cd ${WRKSRC}/examples && ${FIND} . ! \( -name "*Makefile*" -or \
- -name "*.sgml" \) | ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} \
- ${EXAMPLESDIR})
+ -name "*.sgml" \) | ${CPIO} -pdm -LR ${SHAREOWN}:${SHAREGRP} \
+ ${EXAMPLESDIR})
@${FIND} ${EXAMPLESDIR} -type d | ${XARGS} ${CHMOD} a+rx
@${FIND} ${EXAMPLESDIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
.endif