aboutsummaryrefslogtreecommitdiff
path: root/lang/php70/files
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2016-02-15 14:34:26 +0000
committerMartin Wilke <miwi@FreeBSD.org>2016-02-15 14:34:26 +0000
commite630e52bb5f688a26b92533f2f2b0e17e3b85f33 (patch)
tree921070ae859847e6ad2f11168de4014a9c3571e8 /lang/php70/files
parent8b812c1bf4f8270bf585201073f5504abac62e07 (diff)
downloadports-e630e52bb5f688a26b92533f2f2b0e17e3b85f33.tar.gz
ports-e630e52bb5f688a26b92533f2f2b0e17e3b85f33.zip
Welcome php 7.0.3
Changelog: http://php.net/ChangeLog-7.php#7.0.0 http://php.net/ChangeLog-7.php#7.0.1 http://php.net/ChangeLog-7.php#7.0.2 http://php.net/ChangeLog-7.php#7.0.3 I'd like to thanks: Kurt Jaeger Matthias Breddin Rainer Duffner Victor van Vlaardingen Torsten Zuehlsdorff Franco Fichtner and all helpers and testers from ports@.
Notes
Notes: svn path=/head/; revision=408932
Diffstat (limited to 'lang/php70/files')
-rw-r--r--lang/php70/files/patch-configure.in53
-rw-r--r--lang/php70/files/patch-main__php_config.h.in12
-rw-r--r--lang/php70/files/patch-sapi_apache2handler_config.m411
-rw-r--r--lang/php70/files/patch-sapi_fpm_config.m419
-rw-r--r--lang/php70/files/php-fpm.in43
5 files changed, 138 insertions, 0 deletions
diff --git a/lang/php70/files/patch-configure.in b/lang/php70/files/patch-configure.in
new file mode 100644
index 000000000000..f30e9d392594
--- /dev/null
+++ b/lang/php70/files/patch-configure.in
@@ -0,0 +1,53 @@
+--- configure.in.orig 2014-04-01 12:32:03.000000000 +0000
++++ configure.in 2014-04-09 07:56:27.824397653 +0000
+@@ -370,7 +370,6 @@
+ dnl .
+ dnl -------------------------------------------------------------------------
+
+-PTHREADS_CHECK
+ PHP_HELP_SEPARATOR([SAPI modules:])
+ PHP_SHLIB_SUFFIX_NAMES
+ PHP_BUILD_PROGRAM
+@@ -401,15 +400,9 @@
+ AC_MSG_RESULT([none])
+ fi
+
+-dnl Exit early
+-if test -z "$PHP_INSTALLED_SAPIS"; then
+- AC_MSG_ERROR([Nothing to build.])
+-fi
+-
+ dnl force ZTS
+ if test "$enable_maintainer_zts" = "yes"; then
+ PTHREADS_ASSIGN_VARS
+- PTHREADS_FLAGS
+ fi
+
+ dnl Starting system checks.
+@@ -688,7 +681,7 @@
+ )
+
+ dnl Some systems (like OpenSolaris) do not have nanosleep in libc
+-PHP_CHECK_FUNC_LIB(nanosleep, rt)
++PHP_CHECK_FUNC(nanosleep, rt)
+
+ dnl Check for getaddrinfo, should be a better way, but...
+ dnl Also check for working getaddrinfo
+@@ -1225,7 +1218,7 @@
+ EXPANDED_DATADIR=$datadir
+ EXPANDED_PHP_CONFIG_FILE_PATH=`eval echo "$PHP_CONFIG_FILE_PATH"`
+ EXPANDED_PHP_CONFIG_FILE_SCAN_DIR=`eval echo "$PHP_CONFIG_FILE_SCAN_DIR"`
+-INCLUDE_PATH=.:$EXPANDED_PEAR_INSTALLDIR
++INCLUDE_PATH=.:${prefix}/share/pear
+
+ exec_prefix=$old_exec_prefix
+ libdir=$old_libdir
+@@ -1435,7 +1428,7 @@
+ PHP_SUBST(install_targets)
+ PHP_SUBST(install_binary_targets)
+
+-PHP_INSTALL_HEADERS([Zend/ TSRM/ include/ main/ main/streams/])
++PHP_INSTALL_HEADERS([Zend/ TSRM/ main/ main/streams/])
+
+ PHP_ADD_SOURCES(TSRM, TSRM.c tsrm_strtok_r.c tsrm_virtual_cwd.c)
+
diff --git a/lang/php70/files/patch-main__php_config.h.in b/lang/php70/files/patch-main__php_config.h.in
new file mode 100644
index 000000000000..421a576bce11
--- /dev/null
+++ b/lang/php70/files/patch-main__php_config.h.in
@@ -0,0 +1,12 @@
+--- main/php_config.h.in.orig 2015-12-01 16:36:43.000000000 +0300
++++ main/php_config.h.in 2015-12-09 21:45:32.033676604 +0300
+@@ -2405,6 +2405,9 @@
+ /* Define if processor uses big-endian word */
+ #undef WORDS_BIGENDIAN
+
++/* Include external shared modules configurations */
++#include "ext/php_config.h"
++
+ /* Whether sprintf is broken */
+ #undef ZEND_BROKEN_SPRINTF
+
diff --git a/lang/php70/files/patch-sapi_apache2handler_config.m4 b/lang/php70/files/patch-sapi_apache2handler_config.m4
new file mode 100644
index 000000000000..dcd79e12117f
--- /dev/null
+++ b/lang/php70/files/patch-sapi_apache2handler_config.m4
@@ -0,0 +1,11 @@
+--- sapi/apache2handler/config.m4.orig 2013-12-10 23:31:06.000000000 +0000
++++ sapi/apache2handler/config.m4 2013-12-13 21:50:25.488258534 +0000
+@@ -67,7 +67,7 @@ if test "$PHP_APXS2" != "no"; then
+ fi
+
+ APXS_LIBEXECDIR='$(INSTALL_ROOT)'`$APXS -q LIBEXECDIR`
+- if test -z `$APXS -q SYSCONFDIR`; then
++ if true; then
+ INSTALL_IT="\$(mkinstalldirs) '$APXS_LIBEXECDIR' && \
+ $APXS -S LIBEXECDIR='$APXS_LIBEXECDIR' \
+ -i -n php7"
diff --git a/lang/php70/files/patch-sapi_fpm_config.m4 b/lang/php70/files/patch-sapi_fpm_config.m4
new file mode 100644
index 000000000000..3c13d5e9ecf7
--- /dev/null
+++ b/lang/php70/files/patch-sapi_fpm_config.m4
@@ -0,0 +1,19 @@
+--- sapi/fpm/config.m4.orig 2015-12-01 16:36:27.000000000 +0300
++++ sapi/fpm/config.m4 2015-12-09 21:34:18.665722795 +0300
+@@ -317,14 +317,14 @@
+
+ AC_MSG_CHECKING([for TCP_INFO])
+
+- AC_TRY_COMPILE([ #include <netinet/tcp.h> ], [struct tcp_info ti; int x = TCP_INFO;], [
++ AC_TRY_COMPILE([ #include <netinet/tcp.h> ], [struct tcp_info ti; ti.tcpi_sacked = 0; int x = TCP_INFO;], [
+ have_lq=tcp_info
+ AC_MSG_RESULT([yes])
+ ], [
+ AC_MSG_RESULT([no])
+ ])
+
+- if test "$have_lq" = "tcp_info"; then
++ if test "$have_lq" = "so_listenq"; then
+ AC_DEFINE([HAVE_LQ_TCP_INFO], 1, [do we have TCP_INFO?])
+ fi
+
diff --git a/lang/php70/files/php-fpm.in b/lang/php70/files/php-fpm.in
new file mode 100644
index 000000000000..55e2ac992408
--- /dev/null
+++ b/lang/php70/files/php-fpm.in
@@ -0,0 +1,43 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: php-fpm
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+
+#
+# Add the following line to /etc/rc.conf to enable php-fpm:
+# php_fpm_enable="YES"
+#
+
+. /etc/rc.subr
+
+name="php_fpm"
+rcvar=php_fpm_enable
+
+load_rc_config "$name"
+
+: ${php_fpm_enable="NO"}
+
+extra_commands="reload logrotate"
+
+command="%%PREFIX%%/sbin/php-fpm"
+pidfile="/var/run/php-fpm.pid"
+sig_stop="QUIT"
+sig_reload="USR2"
+logrotate_cmd="php_fpm_logrotate"
+
+required_files="%%PREFIX%%/etc/php-fpm.conf"
+
+php_fpm_logrotate() {
+ if [ -z "$rc_pid" ]; then
+ _run_rc_notrunning
+ return 1
+ fi
+ echo "Rotating logs $name."
+ kill -USR1 $rc_pid
+}
+
+run_rc_command "$1"